Junos
Junos

Ex2300 switch irb interface pinging access vlan not reachable

Tuesday

I have a switch with basic access ports and single trunk port taking it back to carrier. I setup irb interface with IP /30 and trunk carrying all vlans etc. 

 

I can ping my switch from ISP but cannot ping any customers attached to it. 

 

 

switch is ex2300

 

 

interfaces {
ge-0/0/0 {
description Subnet-1;
unit 0 {
family ethernet-switching {
vlan {
members 100;
}
}
}
}
ge-0/0/1 {
description Subnet-2;
unit 0 {
family ethernet-switching {
vlan {
members 101;
}
}
}
}
ge-0/0/2 {
description Subnet-3;
unit 0 {
family ethernet-switching {
vlan {
members 102;
}
}
}
}
ge-0/0/3 {
description Subnet-4;
mtu 1500;
unit 0 {
family ethernet-switching {
vlan {
members 103;
}
}
}
}
ge-0/0/4 {
description Subnet-5;
unit 0 {
family ethernet-switching {
vlan {
members 104;
}
}
}
}
ge-0/0/5 {
description Subnet-6;
unit 0 {
family ethernet-switching {
vlan {
members 105;
}
}
}
}
ge-0/0/6 {
description Subnet-7;
unit 0 {
family ethernet-switching {
vlan {
members 106;
}
}
}
}
ge-0/0/7 {
description Submet-8;
unit 0 {
family ethernet-switching {
vlan {
members 107;
}
}
}
}
ge-0/0/8 {
description Subnet-9;
unit 0 {
family ethernet-switching {
vlan {
members 108;
}
}
}
}
ge-0/0/9 {
description Subnet-10;
unit 0 {
family ethernet-switching {
vlan {
members 109;
}
}
}
}
ge-0/0/10 {
description "Subnet-11 (perm for subnet-6)";
unit 0 {
family ethernet-switching {
vlan {
members 110;
}
}
}
}
ge-0/0/11 {
unit 0 {
description Subnet-12;
family ethernet-switching {
vlan {
members 111;
}
}
}
}
ge-0/0/12 {
unit 0 {
description Subnet-13;
family ethernet-switching {
vlan {
members 112;
}
}
}
}
ge-0/0/13 {
unit 0 {
description Subnet-14;
family ethernet-switching {
vlan {
members 113;
}
}
}
}
ge-0/0/14 {
unit 0 {
description Subnet-15;
family ethernet-switching {
vlan {
members 114;
}
}
}
}
ge-0/0/15 {
unit 0 {
description Subnet-16;
family ethernet-switching {
vlan {
members 115;
}
}
}
}
ge-0/0/16 {
unit 0 {
description Subnet-17;
family ethernet-switching {
vlan {
members 116;
}
}
}
}
ge-0/0/17 {
unit 0 {
description Subnet-18;
family ethernet-switching {
vlan {
members 117;
}
}
}
}
ge-0/0/18 {
unit 0 {
description Subnet-19;
family ethernet-switching {
vlan {
members 118;
}
}
}
}
ge-0/0/19 {
unit 0 {
description Subnet-20;
family ethernet-switching {
vlan {
members 119;
}
}
}
}
ge-0/0/20 {
unit 0 {
description Subnet-21;
family ethernet-switching {
vlan {
members 120;
}
}
}
}
ge-0/0/21 {
unit 0 {
description Subnet-22;
family ethernet-switching {
vlan {
members 121;
}
}
}
}
ge-0/0/22 {
unit 0 {
description Subnet-23;
family ethernet-switching {
vlan {
members 122;
}
}
}
}
ge-0/0/23 {
unit 0 {
family ethernet-switching;
}
}
ge-0/0/25 {
unit 0 {
description Subnet-25;
family ethernet-switching {
vlan {
members 125;
}
}
}
}
ge-0/0/47 {
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members all;
}
}
}
}
ge-0/1/2 {
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members all;
}
}
}
}
xe-0/1/2 {
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members all;
}
}
}
}
ge-0/1/3 {
speed 1g;
link-mode full-duplex;
ether-options {
no-auto-negotiation;
}
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members all;
}
}
}
}
irb {
unit 0 {
family inet {
address /30

}
}
}
}
snmp {
community {
authorization read-only;
clients {

}
}
}
routing-options {
static {
route 0.0.0.0/0 next-hop xxxxx
}
}
protocols {
lldp {
interface all;
}
lldp-med {
interface all;
}
}
vlans {
customers {
vlan-range 100-150;
}
default {
vlan-id 10;
l3-interface irb.0;
}
}

1 REPLY 1
Junos

Re: Ex2300 switch irb interface pinging access vlan not reachable

Tuesday

Hi Simon,

 

 I see you configured VLANs from 100 to 150, however, there is only one IRB configured under VLAN 10. If this switch is working as the gateway for all VLANs, you need to configured an IRB for each Vlan with its corresponding subnet so the switch can perform intervlan routing.

 

 If your scenario is different kindly share more details.

 

Regards!

Esteban,

 

If this clears your concerns please mark as solved