Junos
Highlighted
Junos

GRE tunnels on ACX1100-DC

‎06-26-2018 09:21 PM

G'day all,

I'm struggling to configure a couple of GRE tunnels on ACX1100-DCs. Current config is:

chassis {
    fpc 0 {
        pic 0 {
            tunnel-services {
                bandwidth 1g;
            }
        }
    }
}
interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                address 10.250.65.27/29;
            }
        }
    }
    gr-0/0/0 {                          
        unit 1 {
            tunnel {
                source 10.250.65.27;
                destination 10.250.4.26;
            }
            family inet {
                address 172.16.1.78/30;
            }
        }
    }
}

However after committing, the gr-0/0/0 interface doesn's show up.

8 REPLIES 8
Highlighted
Junos

Re: GRE tunnels on ACX1100-DC

‎06-26-2018 10:01 PM
It should be gr-0/0/10 interface.


root@jtac-acx1100-r2001# set chassis fpc 0 pic 0 tunnel-services bandwidth 1g



[edit]

root@jtac-acx1100-r2001# commit

commit complete



[edit]

root@jtac-acx1100-r2001# run show interfaces terse | match gr

gr-0/0/10 up up

gre up up



[edit]

root@jtac-acx1100-r2001#
Highlighted
Junos

Re: GRE tunnels on ACX1100-DC

‎06-26-2018 10:23 PM

G'day Kingsman,

No dice:

root@Newman-Supp# show chassis                            
fpc 0 {
    pic 0 {
        tunnel-services {
            bandwidth 1g;
        }
    }
}

[edit]
root@Newman-Supp# show interfaces gr-0/0/10 
unit 1 {
    tunnel {
        source 10.250.65.27;
        destination 10.250.4.26;
    }
    family inet {
        address 172.16.1.78/30;
    }
}

[edit]
root@Newman-Supp# run show interfaces terse | match gr 
gre                     up    up

[edit]

Is there a minimum OS version I should be looking for to get this feature?

Cheers,

Adrian

Highlighted
Junos

Re: GRE tunnels on ACX1100-DC

‎06-26-2018 10:37 PM

which junos release are you using?

Highlighted
Junos

Re: GRE tunnels on ACX1100-DC

‎06-26-2018 10:39 PM

root@Newman-Supp# run show version
Hostname: Newman-Supp
Model: acx1100
Junos: 15.1R3.6 export
JUNOS Base OS boot [15.1R3.6]
JUNOS Base OS Software Suite [15.1R3.6]
JUNOS Packet Forwarding Engine Support (ACX) [15.1R3.6]
JUNOS Web Management [15.1R3.6]
JUNOS Online Documentation [15.1R3.6]
JUNOS Services Application Level Gateways [15.1R3.6]
JUNOS Services Jflow Container package [15.1R3.6]
JUNOS Services Stateful Firewall [15.1R3.6]
JUNOS Services NAT [15.1R3.6]
JUNOS Services RPM [15.1R3.6]
JUNOS Services Captive Portal and Content Delivery Container package [15.1R3.6]
JUNOS Kernel Software Suite [15.1R3.6]
JUNOS Routing Software Suite [15.1R3.6]

Highlighted
Junos

Re: GRE tunnels on ACX1100-DC

‎06-26-2018 10:45 PM

You are using export image, i am not sure if that's the problem.

 

Let me test this in my LAB 

Highlighted
Junos

Re: GRE tunnels on ACX1100-DC

‎06-26-2018 11:08 PM

Support for generic routing encapsulation (GRE) (ACX Series)—Starting with Junos OS Release 17.1R1, ACX Series Universal Access Routers supports configuring generic routing encapsulation (GRE). GRE provides a private, secure path for transporting packets through an otherwise public network by encapsulating (or tunneling) the packets inside a transport protocol known as an IP encapsulation protocol. 

Highlighted
Junos

Re: GRE tunnels on ACX1100-DC

‎06-26-2018 11:11 PM

RTFM - gotcha! I'll bump the version on my gear and see how I go.

Thanks Mayar and Kingsman for your help.

Highlighted
Junos

Re: GRE tunnels on ACX1100-DC

‎06-26-2018 11:16 PM

Hi,

 

Just my lab output.

 

labroot@corolla> show version
Hostname: corolla
Model: acx1100
Junos: 16.2R1.6

labroot@corolla# set chassis fpc 0 pic 0 tunnel-services bandwidth 1g

labroot@corolla# run show interfaces terse | grep gr-

 

labroot@INIT# run show version
Hostname: INIT
Model: acx1100
Junos: 17.1R2.7

labroot@INIT# run show interfaces ter| grep gr-

labroot@INIT# set chassis fpc 0 pic 0 tunnel-services bandwidth 1g

labroot@INIT# run show interfaces terse | match gr-
gr-0/0/10 up up
gr-0/0/10.0 up up inet 172.16.1.2/30

 

Regards,

Rahul

Feedback