Junos
Highlighted
Junos

Gratuitous ARP Problem

‎01-22-2015 01:23 AM

Dears,

 I testing Gratuitous ARP over AE interface,but i have some questions,

topology  R1 logical system <==AE==> R2 logical system

 

 

AE interfaces divided into 3 units.

i used  gratuitous-arp-on-ifup to send G-ARP once interface goes up but the problem is that G-ARP PKT sent only over one sub-interface where i need to flood it over all interfaces, is there is any command for that ??

 

config:

 

 

ae3 {
vlan-tagging;
gratuitous-arp-reply;
aggregated-ether-options {
lacp {
active;
}
}
}
ae4 {
vlan-tagging;
gratuitous-arp-reply;
aggregated-ether-options {
lacp {
active;
}
}
}

 

lab# show logical-systems
R1 {
interfaces {
ae3 {
unit 100 {
arp-resp unrestricted;
vlan-id 100;
family inet {
address 1.1.1.1/24;
}
}
unit 200 {
arp-resp unrestricted;
vlan-id 200;
family inet {
address 2.2.2.1/24;
}
}
unit 300 {
arp-resp unrestricted;
vlan-id 300;
family inet {
address 3.3.3.1/24;
}
}
}
}
routing-instances {
A1 {
instance-type virtual-router;
interface ae3.100;
}
}
system {
arp {
purging;
gratuitous-arp-on-ifup;
}
}
}
R2 {
interfaces {
ae4 {
unit 100 {
arp-resp unrestricted;
vlan-id 100;
family inet {
address 1.1.1.2/24;
}
}
unit 200 {
arp-resp unrestricted;
vlan-id 200;
family inet {
address 2.2.2.2/24;
}
}
unit 300 {
arp-resp unrestricted;
vlan-id 300;
family inet {
address 3.3.3.2/24;
}
}
}
}
routing-instances {
A2 {
instance-type virtual-router;
interface ae4.100;
}
}
system {
arp {
purging;
gratuitous-arp-on-ifup;
}
}
}

[edit]
lab#

1 REPLY 1
Highlighted
Junos

Re: Gratuitous ARP Problem

‎03-02-2015 01:09 AM

It seems that you are hitting this PR:

 

https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR986262


=====

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.

Feedback