Junos
Highlighted
Junos

Help - Basic multicast test environment does not work (JUNOS SRX)

Wednesday

Hello team:

I have two tiny SRX100 devices connected to each other and sharing a /24 network. JUNOS version is 12.1; according to answers in this forum this is enough to run a basic multicast environment.

 

I want device 10.1.1.1 to ping 239.10.10.10 and get the answer from device 10.1.1.2.

 

Based on my former Cisco background I configured the destination device with the "protocols igmp ... static group " command, but I have not succeeded. 

 

Before disturbing you, I browsed thru some threads in this forum, and based on the answers I added the "protocols sap listen" command, and just in case I also added the PIM protocol to both devices.

Based on more suggestions written in this forum, I ran the ping command with the "bypass-routing" option.

 

Nothing happened.

 

¿ Is there anything else I am missing? I would have expected this to be pretty simple, but I can not manage it to work.

 

This is the configuration on the "sending" device:

 

set interfaces fe-0/0/0 unit 0 family inet address 10.1.1.1/24
set protocols sap listen 239.10.10.10
set protocols pim interface all
set security forwarding-options family mpls mode packet-based

 

This is the configuration on the "receiving" device:

 

set interfaces fe-0/0/0 unit 0 family inet address 10.1.1.2/24
set protocols igmp interface fe-0/0/0.0 static group 239.10.10.10
set protocols sap listen 239.10.10.10
set protocols pim interface fe-0/0/0.0
set security forwarding-options family mpls mode packet-based

 

Here is the output from the sending device not being able to receive an answer:

 

root> ping 239.10.10.10 bypass-routing source 10.1.1.1 ttl 3 count 2 wait 2 interface fe-0/0/0.0
PING 239.10.10.10 (239.10.10.10): 56 data bytes

--- 239.10.10.10 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss

 

Your help will be greatly appreciated!!!

 

Thanks a lot in advance

Rogelio

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Junos
Solution
Accepted by topic author ralvez
Friday

Re: Help - Basic multicast test environment does not work (JUNOS SRX)

[ Edited ]
Thursday

By default PIM mode is sparse in Junos. Since you do not have RP in your setup, configure PIM dense mode in both device and remove sap config from sending device. Working config is given below:

 

R1:

+++

set interfaces fe-0/0/0 unit 0 family inet address 10.1.1.1/24
set protocols pim interface fe-0/0/0.0 mode dense
set security forwarding-options family mpls mode packet-based

 

R2:

++++
set interfaces fe-0/0/0 unit 0 family inet address 10.1.1.2/24
set protocols sap listen 239.10.10.10
set protocols pim interface fe-0/0/0.0 mode dense
set security forwarding-options family mpls mode packet-based

 

Verification:

+++++++++++

root@R1# run ping 239.10.10.10 bypass-routing ttl 10 interface fe-0/0/0.0
PING 239.10.10.10 (239.10.10.10): 56 data bytes
64 bytes from 10.1.1.2: icmp_seq=0 ttl=64 time=201.791 ms
64 bytes from 10.1.1.2: icmp_seq=1 ttl=64 time=28.387 ms
64 bytes from 10.1.1.2: icmp_seq=2 ttl=64 time=16.887 ms
64 bytes from 10.1.1.2: icmp_seq=3 ttl=64 time=6.386 ms

 

Thanks,
Nellikka
JNCIE x3 (SEC #321; SP #2839; ENT #790), CCIE RS #48338
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
2 REPLIES 2
Junos
Solution
Accepted by topic author ralvez
Friday

Re: Help - Basic multicast test environment does not work (JUNOS SRX)

[ Edited ]
Thursday

By default PIM mode is sparse in Junos. Since you do not have RP in your setup, configure PIM dense mode in both device and remove sap config from sending device. Working config is given below:

 

R1:

+++

set interfaces fe-0/0/0 unit 0 family inet address 10.1.1.1/24
set protocols pim interface fe-0/0/0.0 mode dense
set security forwarding-options family mpls mode packet-based

 

R2:

++++
set interfaces fe-0/0/0 unit 0 family inet address 10.1.1.2/24
set protocols sap listen 239.10.10.10
set protocols pim interface fe-0/0/0.0 mode dense
set security forwarding-options family mpls mode packet-based

 

Verification:

+++++++++++

root@R1# run ping 239.10.10.10 bypass-routing ttl 10 interface fe-0/0/0.0
PING 239.10.10.10 (239.10.10.10): 56 data bytes
64 bytes from 10.1.1.2: icmp_seq=0 ttl=64 time=201.791 ms
64 bytes from 10.1.1.2: icmp_seq=1 ttl=64 time=28.387 ms
64 bytes from 10.1.1.2: icmp_seq=2 ttl=64 time=16.887 ms
64 bytes from 10.1.1.2: icmp_seq=3 ttl=64 time=6.386 ms

 

Thanks,
Nellikka
JNCIE x3 (SEC #321; SP #2839; ENT #790), CCIE RS #48338
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
Junos

Re: Help - Basic multicast test environment does not work (JUNOS SRX)

Friday

Thanks! So a properly configured PIM control plane is indeed necessary to get the router answer to multicast ICMP packets. I did not know it.

 

Question: ¿ how do I give you a Kudos? This is my first attempt to do it, and I do not find how to carry this out.

 

Looking forward to hearing from you soon.

Regards, Rogelio