Junos
Highlighted
Junos

How to limit the number of multicast flows that a subscriber can receive in a customer's VRF

‎03-18-2009 08:30 AM

We want to limit the number of multicast flows that a customer can "subscribe to" in a next-gen MVPN configuration (SSM mode)

 

Does someone knows if this can be done using the statement under the VRF:

 

"routing-options multicast forwarding-cache" or with some other parameters ?

 

Thanks in advance

 

Alain

 

8 REPLIES 8
Highlighted
Junos

Re: How to limit the number of multicast flows that a subscriber can receive in a customer's VRF

‎03-18-2009 08:41 AM

The command is available under the VRF configurations so I would assume it works.

 

 

[edit routing-instances mvpn routing-options] root@router-re0# set multicast forwarding-cache threshold ? Possible completions: + apply-groups Groups from which to inherit configuration data + apply-groups-except Don't inherit configuration data from these groups reuse Reuse threshold (1..200000) suppress Suppress threshold (1..200000) [edit routing-instances mvpn routing-options] root@router-re0#

 

 

 

Highlighted
Junos

Re: How to limit the number of multicast flows that a subscriber can receive in a customer's VRF

‎03-18-2009 09:03 AM

Ok Anton

 

Thanks for your relpy but I have already seen that it was available there.

 

The only thing I am wondering is , if it can do what I want :

 

Limit the numbers of flows that a user in my VRF will be able to subscribe to ?

 

In fact I am not sure to understand the the use of this parameter.

 

If someone can clarify this ?

Highlighted
Junos

Re: How to limit the number of multicast flows that a subscriber can receive in a customer's VRF

‎03-23-2009 03:03 AM

I have just tested this and confirm that it works.

 

Mar 23 11:00:31.962 router-re0 rpd[6367]: %DAEMON-4: Configured suppress threshold (3) for multicast forwarding-cache exceeded

 

 

lab@router-re0> show configuration routing-instances mvpn routing-options multicast forwarding-cache { threshold { suppress 3; } } lab@router-re0>

 

lab@router-re0> show pim join instance mvpn Instance: PIM.mvpn Family: INET R = Rendezvous Point Tree, S = Sparse, W = Wildcard Group: 238.1.1.1 Source: 10.0.10.100 Flags: sparse,spt Upstream interface: mt-1/2/0.32768 Group: 238.1.1.2 Source: 10.0.10.100 Flags: sparse,spt Upstream interface: mt-1/2/0.32768 Group: 238.1.1.3 Source: 10.0.10.100 Flags: sparse,spt Upstream interface: mt-1/2/0.32768 Group: 238.1.1.4 Source: 10.0.10.100 Flags: sparse Upstream interface: mt-1/2/0.32768 Instance: PIM.mvpn Family: INET6 R = Rendezvous Point Tree, S = Sparse, W = Wildcard lab@router-re0> show multicast route instance mvpn Family: INET Group: 238.1.1.1 Source: 10.0.10.100/32 Upstream interface: mt-1/2/0.49152 Downstream interface list: fe-1/3/1.122 Group: 238.1.1.2 Source: 10.0.10.100/32 Upstream interface: mt-1/2/0.49152 Downstream interface list: fe-1/3/1.122 Group: 238.1.1.3 Source: 10.0.10.100/32 Upstream interface: mt-1/2/0.49152 Downstream interface list: fe-1/3/1.122 Family: INET6 lab@router-re0>

 

 

 

Highlighted
Junos

Re: How to limit the number of multicast flows that a subscriber can receive in a customer's VRF

‎03-23-2009 06:47 AM

Thanks Anthon for theses tests

 

I will test on my side also

 

Kind regards

Alain

 

Highlighted
Junos

Re: How to limit the number of multicast flows that a subscriber can receive in a customer's VRF

[ Edited ]
‎04-03-2009 07:17 AM

Hi Anton,

 

I have done some tests about it. Unfortunetely I am not getting the same result that you. Let me show you:


Samuel@J4350# show routing-instances VPN_Client_A routing-options
multicast {
forwarding-cache {
threshold {
suppress 2;
}
}
}

 

Samuel@J4350> show pim join instance VPN_Client_A
Instance: PIM.VPN_Client_A Family: INET

Group: 232.1.1.1
Source: 192.168.3.2
Flags: sparse
Upstream protcol: BGP
Upstream interface: Through BGP

Group: 232.2.2.2
Source: 192.168.3.2
Flags: sparse
Upstream protcol: BGP
Upstream interface: Through BGP

Group: 232.3.3.3
Source: 192.168.3.2
Flags: sparse
Upstream protcol: BGP
Upstream interface: Through BGP

Group: 232.4.4.4
Source: 192.168.3.2
Flags: sparse
Upstream protcol: BGP
Upstream interface: Through BGP

Instance: PIM.VPN_Client_A Family: INET

 

Samuel@J4350> show multicast route instance VPN_Client_A
Family: INET

Group: 232.1.1.1
Source: 192.168.3.2/32
Upstream interface: lsi.0
Downstream interface list:
ge-0/0/1.0

Group: 232.2.2.2
Source: 192.168.3.2/32
Upstream interface: lsi.0
Downstream interface list:
ge-0/0/1.0

Group: 232.3.3.3
Source: 192.168.3.2/32
Upstream interface: lsi.0
Downstream interface list:
ge-0/0/1.0

Group: 232.4.4.4
Source: 192.168.3.2/32
Upstream interface: lsi.0
Downstream interface list:
ge-0/0/1.0

Family: INET6

 

Apr 2 23:14:32 J4350 rpd[4114]: Configured suppress threshold (2) for multicast forwarding-cache exceeded


The message in the logs is correct but my client is able to be connected to 4 multicast sources even if the "forwarding-cache threshold" is configured to 2.

FYI all my routers are in version 8.5R4.3.

 

This is my lab:

 

 

Have you already met this problem?

 

Regards,

Samuel

Message Edited by Samuel on 04-03-2009 04:18 PM
Highlighted
Junos

Re: How to limit the number of multicast flows that a subscriber can receive in a customer's VRF

‎04-03-2009 07:43 AM

Hi Samuel

 

No I have not come across this. I do know in the past there where some problems with this especially in combination with SSM. See PR/10325 for example. This one was however solved in 8.5R1.  I suggest you open a case with JTAC and have this further investigated.

 

Anton

Highlighted
Junos

Re: How to limit the number of multicast flows that a subscriber can receive in a customer's VRF

‎04-03-2009 08:17 AM
Ok Thx Anton. In which JUNOS version are you working ?
Highlighted
Junos

Re: How to limit the number of multicast flows that a subscriber can receive in a customer's VRF

‎04-07-2009 10:00 AM

1) I have upgraded my routers in 9.4R2.9, the issue is the same.

 

2) I have tested this statement with "classic" multicast: PIM SSM without MPLS and VPN, and it works.

 

=> I have opened a case about this issue. I keep you in touch.

 

 

Feedback