Junos
Highlighted
Junos

IPv6 RADIUS assigned address not working

a week ago

I have configured our RADIUS server to assign an framed-ipv6-prefix to the CPE.

 

When I lookat the access-accept return from the RADIUS it shows the allocated /56 being sent to the LNS. When I complete "sho subscribers" it shows the subscriber with the allocated IPv6 address, but the CPE only has the Link-Local address. My conclusion to this is:

 

The RADIUS returns the correct IPv6 address to the LNS (MX240) but the LNS is not forwarding this on, via the dynamic-profile, to the CPE.

 

I have configured the following:

 

set dynamic-profiles dyn-lns-profile interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" family inet6 address $junos-ipv6-address

 

And I have also tried with the following:

 

set dynamic-profiles dyn-lns-profile interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" family inet6 unnumbered-address "$junos-loopback-interface"

 

And neither of them work. The si interface is configured as follows:

set interfaces si-1/0/0 hierarchical-scheduler maximum-hierarchy-levels 2
set interfaces si-1/0/0 encapsulation generic-services
set interfaces si-1/0/0 unit 0 family inet
set interfaces si-1/0/0 unit 0 family inet6

 

This is stopping us being able to complete our IPv6 testing and dual-stack.

 

As an add on, I can get the pool working fine, but this is no good as we need the RADIUS to assign the address.

 

Any help would be greatly appreciated.

 

Thank you

 

6 REPLIES
Junos
Solution
Accepted by topic author adgwytc
a week ago

Re: IPv6 RADIUS assigned address not working

[ Edited ]
a week ago

Hi,

 

IPv6 address is assigned via NDRA or DHCPv6 PD.

 

Under the Dynamic-Profile.

 

protocols {

    router-advertisement {

        interface "$junos-interface-name" {

            other-stateful-configuration;

            dns-server-address 2001:4860:4860::8844;

            dns-server-address 2001:4860:4860::8888;

            prefix $junos-ipv6-ndra-prefix;

        }

    }

}

 

For DNS,

 

show system services 

dhcp-local-server {

    dhcpv6 {

        overrides {

            process-inform;

        }

        group test {

            interface si-x/x/x.0;

        }

    }

Regards,

Rahul 

 

Junos

Re: IPv6 RADIUS assigned address not working

a week ago

Hi Rahul,

 

Apologies, I also tried the $junos-ipv6-ndra-prefix command and that also did not work. The CPE is just not getting the IPv6 prefix.

Junos

Re: IPv6 RADIUS assigned address not working

a week ago

Hi Clive,

 

CPE receiving IPv6 RA from MX? Did you tried with /64 prefix?

 

Regards,

Rahul

Junos

Re: IPv6 RADIUS assigned address not working

a week ago

Hi Rahul,

 

The CPE is not receiving the prefix. Or does not appear to be receiving the prefix.

 

Thanks

Junos

Re: IPv6 RADIUS assigned address not working

a week ago

Kindly share the dynamic-profile configuration and return attributes from radius.

 

Regards,
Rahul

Junos

Re: IPv6 RADIUS assigned address not working

a week ago

Hi Rahul,

 

It appears that the CPE was using IANA and not NDRA.

 

This is now working and assigning the corect address and prefix.

 

Thank you for your help Rahul