Junos
Highlighted
Junos

JUNOS recovery on SRX210HE2

‎04-02-2014 11:41 PM

Hi all,

my first approach with an SRX router was very unlucky.

Probably due to a power outage, my SRX210HE2 with JUNOS 12.1X44-D15.5 now shows the following prompt:

 

=>

 

I'm not familiar with SRX, so the the first attempts was an help from prompt:

 

=> ?
? - alias for 'help'
askenv - get environment variables from stdin
base - print or set address offset
boot - boot default, i.e., run 'bootcmd'
bootd - boot default, i.e., run 'bootcmd'
bootelf - Boot from an ELF image in memory
bootloader - upgrade u-boot
bootloader - upgrade loader
bootloader - upgrade ushell
bootloader - check u-boot
bootloader - check loader
bootm - boot application image from memory
bootoct - Boot from an Octeon Executive ELF image in memory
bootoctelf - Boot a generic ELF image in memory. NOTE: This command does not sup
port
simple executive applications, use bootoct for those.
bootoctlinux - Boot from a linux ELF image in memory
bootp - boot image via network using BootP/TFTP protocol
bootvx - Boot vxWorks from an ELF image
cmp - memory compare
cp - memory copy
cpld - peek/poke CPLD
crc32 - checksum calculation
dhcp - invoke DHCP client to obtain IP/boot params
dumpoct - dump octeon regs
dumpstats - dump cavium stats
echo - echo args to console
erase - erase FLASH memory
fatinfo - print information about filesystem
fatload - load binary file from a dos filesystem
fatls - list files in a directory (default /)
flinfo - print FLASH memory information
go - start application at address 'addr'
gpio - read/write on gpio pins
help - print online help
i2c - read/write on i2c bus
id_eeprom - peek/poke EEPROM
ide - IDE sub-system
iminfo - print header information for application image
imls - list all images found in flash
loop - infinite loop on address range
ls609x_read_reg - Read 88E6097 register
md - memory display
mdkinit - start MDK
mm - memory modify (auto-incrementing)
mtest - simple RAM test
mw - memory write (fill)
nand_format - format nand flash
nand_patch_verify - verifies patch in nand flash
nfs - boot image via network using NFS protocol
nm - memory modify (constant address)
pci - list and access PCI Configuration Space
pciemd - pcie memory display
pciemw - pcie memory write
pciereset - do PCIE reset
ping - send ICMP ECHO_REQUEST to network host
printenv- print environment variables
protect - enable or disable FLASH write protection
rarpboot- boot image via network using RARP/TFTP protocol
read64 - read 64 bit word from 64 bit address
read64b - read 8 bit word from 64 bit address
read64l - read 32 bit word from 64 bit address
read_cmp - read and compare memory to val
reset - Perform RESET of the CPU
run - run commands in an environment variable
saveenv - save environment variables to persistent storage
setenv - set environment variables
sleep - delay execution for some time
smi - peek/poke SMI devices
tftpboot- boot image via network using TFTP protocol
usb - USB sub-system
usbboot - boot from USB device
version - print monitor version
watchdog <start | stop | show | pat>
write64 - write 64 bit word to 64 bit address
write64b - write 8 bit word to 64 bit address
write64l - write 32 bit word to 64 bit address
=>

 

Then tried the bootm command. The result was disappointing:


=> bootm
## Booting image at 20000000 ...
Bad Magic Number
=>

 

So, I tried to look something on Junos documentation but did not find any help.

Any suggestion to "resurrect" my SRX ?

Thanks a lot in advance to anybody will help me.

Tiziano

1 REPLY 1
Junos

Re: JUNOS recovery on SRX210HE2

‎04-03-2014 12:15 AM