Junos
Highlighted
Junos

Junos DHCP - Reserved IP not working

‎10-06-2019 09:11 AM

Hi Guys

 

Please have a review of the configuration below:

 

set access address-assignment pool DATA family inet network 192.168.8.0/24
set access address-assignment pool DATA family inet range r1 low 192.168.8.100
set access address-assignment pool DATA family inet range r1 high 192.168.8.200
set access address-assignment pool DATA family inet dhcp-attributes maximum-lease-time 2419200
set access address-assignment pool DATA family inet dhcp-attributes name-server 10.0.0.2
set access address-assignment pool DATA family inet dhcp-attributes name-server 10.0.0.10
set access address-assignment pool DATA family inet dhcp-attributes router 192.168.8.10
set access address-assignment pool DATA family inet dhcp-attributes propagate-settings ge-0/0/1.0
set access address-assignment pool DATA family inet host HOST1 hardware-address 64:db:8b:80:09:31
set access address-assignment pool DATA family inet hostHOST1 ip-address 192.168.8.136
set access address-assignment pool DATA family inet host HOST2 hardware-address b4:a3:82:c2:05:84
set access address-assignment pool DATA family inet host HOST2 ip-address 192.168.8.135
set access address-assignment pool DATA family inet host HOST3 hardware-address 64:db:8b:80:07:d3
set access address-assignment pool DATA family inet host HOST3 ip-address 192.168.8.144

 

With regards to me configuring the MAC Assignment to an IP Address, for some reason, the host devices are not getting the IP as allocated above, and is instead getting an IP in the Address Pool Range although the static IP that is assigned is also in the DHCP Pool Range.

 

I have restarted the DHCP Process, cleared the DHCP Server Bindings, restarted the Juniper SRX. I am not sure as to why the DHCP is not OFFERING the correct IP as mentioned above.

 

Does any of you have the same situation? If you perhaps have any resolution to this, this would be much appreciated.

 

Junos Version: JUNOS 12.1X46-D76.1

 

Kind Regards

Himal Bissessar

2 REPLIES 2
Junos

Re: Junos DHCP - Reserved IP not working

‎10-06-2019 01:58 PM

Hi Himal,

 

i just tested this on a new SRX with a configuration matching yours... and it just works as you can see below:

 

set access address-assignment pool int family inet network 10.10.10.0/24
set access address-assignment pool int family inet range scope low 10.10.10.30
set access address-assignment pool int family inet range scope high 10.10.10.99
set access address-assignment pool int family inet dhcp-attributes grace-period 86400
set access address-assignment pool int family inet dhcp-attributes name-server 10.10.10.1
set access address-assignment pool int family inet dhcp-attributes name-server 1.0.0.1
set access address-assignment pool int family inet dhcp-attributes router 10.10.10.1
set access address-assignment pool int family inet host TestMachine hardware-address 04:4b:ed:xx:xx:xx
set access address-assignment pool int family inet host TestMachine ip-address 10.10.10.98

user@fw# run show dhcp server binding | match 10:98
10.10.10.98      31          04:4b:ed:xx:xx:xx  86270       BOUND      irb.10

have you tried enabling traceoptions on the dhcp process to figure out why it offers an IP from the pool and not the static one?

 

set system processes dhcp-service traceoptions file JDHCPDEBUG
set system processes dhcp-service traceoptions file size 5m
set system processes dhcp-service traceoptions file files 2
set system processes dhcp-service traceoptions flag all

Please share your findings with us afterwards...


--
Best regards,

Jonas Hauge Klingenberg
Systems Engineer, SEC DATACOM A/S (Denmark)
Junos

Re: Junos DHCP - Reserved IP not working

‎10-06-2019 10:32 PM

Hi Jonas 

 

Thank you very much for your response, I will give the below a try and let you know what my findings are

 

Much appreciated

 

Kind Regards