Junos
Junos

Junos upgrade from 15.1X49-D150 to 19.3R2

[ Edited ]
a week ago

Hi Juniper team,

 

I tried to upgrade Junos from 15.1 to 17.4R2 in order to reach 19.3R2.

However, I failed to upgrade. 

Can you tell me if any of my understandings below are wrong?

and 

Could you please guide me on how to upgrade from 15.1 to 19.3R2?

 

#Basic information:

Model: SRX340

JunOS: 15.1X49-D150.2

 

#Original plan:

JunOS Upgrade path: 15.1X49 -> 17.4R2 -> 18.4R2 -> 19.3R2

 

# A procedure that I did.

 

Tried to upgrade via J-Web -> Administration -> Software -> Upload Package

1. Select "junos-srxsme-17.4R2.4.tgz"

2. Checked "Reboot If Required"

3. Checked "Do not save backup"

4. Unchecked "Format and re-partition the media before installation"

5. Click Upload and Install Package

6. After a while, I can see the normal success messages and shutdown message on CLI.

7. I was waiting for 30 minutes. However, I can not access the management port via J-Web and CLI both.

8. LED status:

- PWR: Solid green

- STAT: Solid red

- Management port: Solide green

- Other ports: Not operated

 

# A procedure for recovering.

1. I tried "Forced shutdown" twice.

2. SRX340 booted from the backup Junos image.

- WARNING: THIS DEVICE HAS BOOTED FROM THE BACKUP JUNOS IMAGE

3. I reviewed how to recover and tried below:

- request system snapshot slice alternate

- request system reboot

4. After rebooting:

- The system rebooted in normal via original JunOS(15.1X49-D150.2) successfully. 

 

Thanks

JW

 

 

2 REPLIES 2
Junos

Re: Junos upgrade from 15.1X49-D150 to 19.3R2

a week ago

I guess you could just try again... Maybe use cli this time - at least it will give some more info we could work with...

 

You can try "request system storage cleanup" before you copy the image to the device. Then

"request system software add <file> no-copy"

If it gives validation errors, you might want to address them or, if you feel brave/competent - you can try "no-validate" option (if you do - better have console / serial access to the device handy).

If all else fails, it is possible to rebuild the SRX regardless of the previous version (install junos from loader / USB), but it would be prudent to backup config, licenses and PKI keys (if you use PKI) before you try that. There are also some special considerations for the TPM, (only if you activated it / use it). It will also regenerate ssh keys / they will change. Before doing that you could try 'partition' option. Less intrusive then loader install, but do backup nontheless.

 

Loader install on the SRX platform:

https://kb.juniper.net/InfoCenter/index?page=content&id=KB33005&actp=RSS

Softaware install (request system software add, partition, no-validate etc.)

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/install-software-on-srx.html

 

Regards,

Pawel Mazurkiewicz

Junos

Re: Junos upgrade from 15.1X49-D150 to 19.3R2

[ Edited ]
Monday

Hi pmazurkiewicz,

 

Thanks for your help.

I tried once again via CLI. But I failed again. Could you please review/ help me to solve this problem?

Thanks in advance.

 

# What I did

1. Downloaded via file copy command in operation mode:

 

host> file copy "https://cdn.juniper.net/software/ittest/software_target/agileEcotTest/Dev_Binary_Build.tar?SM_USER=u.../var/tmp/image-name.tgz

 

2. Succeed downloading the file and I did as follows: 

3. The situation after the reboot command was the same as before.

4. I recovered to old one and it succeed.

=====================================================================================

root@xxxx> request system software add /var/tmp/junos-srxsme-17.4R2.4.tgz no-copy
NOTICE: Validating configuration against junos-srxsme-17.4R2.4.tgz.
NOTICE: Use the 'no-validate' option to skip this if desired.
Formatting alternate root (/dev/da0s1a)...
/dev/da0s1a: 588.2MB (1204616 sectors) block size 16384, fragment size 2048
using 4 cylinder groups of 147.06MB, 9412 blks, 18944 inodes.
super-block backups (for fsck -b #) at:
32, 301216, 602400, 903584
Checking compatibility with configuration
Initializing...
Verified manifest signed by PackageProductionEc_2018 method ECDSA256+SHA256
Using junos-17.4R2.4 from /altroot/cf/packages/install-tmp/junos-17.4R2.4
Copying package ...
veriexec: cannot update veriexec for /cf/var/validate/c/junos/usr/lib/libpsu.so.3: Too many links
veriexec: cannot update veriexec for /cf/var/validate/c/junos/usr/lib/libyaml.so.3: Too many links
veriexec: cannot update veriexec for /cf/var/validate/c/junos/usr/lib/libext_db.so.3: Too many links
veriexec: cannot update veriexec for /cf/var/validate/c/junos/usr/telemetry/na-mqttd/na-mqtt.conf: No such file or directory
Verified manifest signed by PackageProductionEc_2018 method ECDSA256+SHA256
Hardware Database regeneration succeeded
Validating against /config/juniper.conf.gz
mgd: commit complete
Validation succeeded
Installing package '/altroot/cf/packages/install-tmp/junos-17.4R2.4' ...
WARNING: If IPS is configured, A full install of the security package is required after reboot.
WARNING: Please perform a full update of the security package using
WARNING: "request security idp security-package download full-update"
WARNING: followed by
WARNING: "request security idp security-package install"
WARNING: after the device reboots.
Verified junos-boot-srxsme-17.4R2.4.tgz signed by PackageProductionEc_2018 method ECDSA256+SHA256
Verified junos-srxsme-17.4R2.4-domestic signed by PackageProductionEc_2018 method ECDSA256+SHA256
JUNOS 17.4R2.4 will become active at next reboot
WARNING: A reboot is required to load this software correctly
WARNING: Use the 'request system reboot' command
WARNING: when software installation is complete
Saving state for rollback ...

root@xxxxxx> request system reboot
Reboot the system ? [yes,no] (no) yes

Shutdown NOW!
[pid 10210]

root@xxxxxx>
*** FINAL System shutdown message from root@xxxxxx ***

System going down IMMEDIATELY

============================================================================================