Junos
Junos

Junos upgrade on J2350 through USB

‎06-25-2014 07:50 AM

Hi all,

I was given a J2350 with Junos 8.R1.4 and since I already have a J2350 with 9.3R1.7, I'd like to upgrade Junos. I do not have a FTP server so I tried to use USB. But unfortunately I was unsuccessful. This the procedure I tried, taken from:

 

http://kb.juniper.net/InfoCenter/index?page=content&id=KB10800

 

1) On the J2350 with 93.R1.7 I connected a USB pen (bought to a supermarket) and then tried to format it with the shell command : 

root@host% dd if=/dev/zero of=/dev/da0 bs=128k

 

Here I had the first problem. The document says that the operation takes several minutes. Bue after one hour the router still gave no sign that operation was over so I lost my patience and stopped the operation typing a ctrl-C. Anyway it seemed that everything worked.

 

2) I checked all the steps in the document up to the seventh and then I issued a:

 

root@host> request system snapshot media usb partition

 

I then checked the result of this operation with the following commands :

 

root@host% mount /dev/da0s1a /altroot

root@host% mount /dev/da0s1e /altconfig

root@host% ls /altroot

root@host% ls /altconfig

 

and everything seemed OK.

 

Then after unmountingdevices /dev/da0s1a and /dev/da0s1e, I extracted the USB pen and connected it to the other J2350. Big problem ! This router recognized the introduction of the USB pen but as soon as I tryed to mount it, I was given the following message:

 

root@host% mount /dev/da0s1 /var/tmp/usb

mount: /dev/da0s1: Block device required

 

It seems as the new J2350 (the one with the older Junos) does not recognizes the device da0s1.

 

Any idea on how to get around the problem ?

One more question. Is it possible to act in a cisco-like fashion and use a router as an FTP server ? Things would be much simpler. I searched on Junos documentation but did not find anything.

 

I understand that having an FTP server would be much simpler, but I'd like to test all the options.

 

Thanks a lot in advance for your cooperation.

Tiziano

1 REPLY 1
Junos

Re: Junos upgrade on J2350 through USB

‎06-26-2014 11:31 PM

Hi

 

J-series procedures:

 

http://www.juniper.net/techpubs/software/junos-security/junos-security10.2/junos-security-admin-guid...

 

if it does not , then try these SRX upgrade procedures .

http://kb.juniper.net/InfoCenter/index?page=content&id=KB16652

 

Thanks & Regards,

rparthi


[Please Mark My Solution Accepted if it Helped, Kudos are Appreciated Too] .....