Junos
Junos

MPLS configuration MX204

‎08-08-2019 01:16 AM

Hi,

We are running Cisco ASR9k atm, but i got my hands on some Juniper gear (MX204 and QFX switches). And since i'm fairly new to Junos i thought i'd ask how to convert my IOS-XR config to Junos.

 

Scenario 1

Here's the IOS-XR config:

l2vpn
bridge group 500
bridge-domain BD500
interface Bundle-Ether22.500
!
neighbor 10.0.0.6 pw-id 10001
!
!
!
!
interface Bundle-Ether22.500 l2transport
encapsulation dot1q 500
rewrite ingress tag pop 1 symmetric
!

 

I would like to span one VLAN over my MPLS network. Like this:

VLAN500 QFX ---- L2-trunk ---- MX204 ---- L3-MPLS ---- MX204 ---- L2-trunk ---- QFX VLAN500

 

 

Scenario 2

IOS-XR config:

l2vpn
xconnect group CUST300
p2p 30001
interface GigabitEthernet0/2/0/35
neighbor ipv4 10.0.0.38 pw-id 30001
!
!
!
!

interface GigabitEthernet0/2/0/35
description CUST300
mtu 1614
negotiation auto
l2transport
!
!

 

Here i just like to forward untagged and tagget packages from one end to another. 

 

Kind Regards

M

4 REPLIES 4
Junos

Re: MPLS configuration MX204

‎08-08-2019 03:21 AM

Hello ehsab,

 

I see you are looking to convert configuration in IOS to JunOS. If you have access to Juniper support website then there is a tool called IOS to JunOS translator which can easily help you convert.

 

This is the kb article: https://kb.juniper.net/InfoCenter/index?page=content&id=KB13220&cat=JUNOS_PLATFORM&actp=LIST

Link to the tool: https://migrationtools.juniper.net/i2j/index.jsp

 

Also, you can check the Juniper documentation. I am sure you can easily navigate through.

 

Do hit kudos if you find this useful, mark "accept as a solution" so other enthusiasts are directed to this post without them having to repost!! :-)

 

//Nex

Junos

Re: MPLS configuration MX204

[ Edited ]
‎08-08-2019 04:19 AM

Hi,

I did try it, but it couldn't convert the configurations i pasted.

Is it even designed for IOS-XR configuration?

 

Kind Regards

M

Junos

Re: MPLS configuration MX204

‎08-14-2019 03:04 AM

No one?

 

Kind Regards

M

Highlighted
Junos

Re: MPLS configuration MX204

[ Edited ]
‎08-20-2019 01:41 AM

Hi,

Please try below configuration

Scenario 1

set interfaces ge-* unit * encapsulation vlan-ccc
set interfaces ge-* unit * vlan-id *
set interfaces ge-* unit * input-vlan-map pop
set interfaces ge-* unit * output-vlan-map push

set protocols l2circuit neighbor 10.0.0.6 interface ge-* virtual-circuit-id 10001


Scenario 2

set interfaces ge-* unit * encapsulation vlan-ccc
set interfaces ge-* unit * vlan-id *

set protocols l2circuit neighbor 10.0.0.6 interface ge-* virtual-circuit-id 30001

 

 

Accept as Solution = cool
Accept as Solution+Kudo = You are a Star