Junos
Highlighted
Junos

MX Router SFB Error

‎04-11-2018 09:00 PM

> show chassis sfb                
Slot  State              Uptime
 0    Offline              --- Error ---
 1    Offline              --- Error ---
 2    Offline              --- Error ---
 3    Offline              --- Error ---

 

I already rebooted, not solve. How should I do?

 

Thank you very much.

ปลาวาฬทราย
9 REPLIES 9
Junos

Re: MX Router SFB Error

‎04-12-2018 06:22 AM

Hi,

 

Can you please attach output of "request support information | no-more" command in a text file? We need to get the SFB HW version and Junos version.

 

Thanks.

Junos

Re: MX Router SFB Error

[ Edited ]
‎04-12-2018 08:03 AM

Hi,

 

It is a lot of information. Could I send the private message to you?

 

Thank you very much.

ปลาวาฬทราย
Junos

Re: MX Router SFB Error

[ Edited ]
‎04-12-2018 09:39 AM

It looks like the complete RSI output might be too big of a file to attach to the post. Can you get the following output in a text file and attach to the post?

 

show chassis hardware | no-more

show version

show configuration chassis | no-more

show chassis alarms

 

Also, can you try this command to bringup the SFB -

request chassis sfb slot 0 online

 

After entering command monitor the output of chassisd logs usign this command -

 

monitor start chassisd

 

Please also provide the chassisd logs after entering the command.

Junos

Re: MX Router SFB Error

‎04-13-2018 02:06 AM

Hi,

 

FYI

 

Thank you very much.

ปลาวาฬทราย

Attachments

Junos

Re: MX Router SFB Error

‎04-13-2018 07:26 AM

Hi,

 

From data you have provided, I see the chassis has 4 SFB cards installed, all are offline. I cannot determine the hardware model becasue they are not listed in the hardware output. Are these SFB boards or SFB 2 boards? Have these cards ever come online on this chassis? If yes, then what made them go offline?

 

Could you also provide the following command output -

 

request pfe execute command "show syslog messages" target spmb0 | no-more

request pfe execute command "show nvram" target spmb0 | no-more

show chassis environment | no-more

show chassis fabric summary extended | no-more

show chassis fabric degradation| no-more

show chassis fpc

show chassis fpc errros

show log messages |no-more << Preferrably from the time when issue started.

show chassis power

show log inventory

 

If the FPCs are currently powered on, please power them off and then re-seat one of the SFB's and provide the chassisd logs.

 

Thanks for your patience!

Junos

Re: MX Router SFB Error

‎04-14-2018 02:52 AM

Hi,

 

These cards have ever come online on this chassis. I don't know what made them go offline.

show log messages |no-more << Preferably from the time when the issue started. -

I don't know when and I already rebooted the node before.

Re-seat the SFB means re-seat the RE, right? I'm going to do on Tuesday.

 

Thank you very much.

ปลาวาฬทราย

Attachments

Junos

Re: MX Router SFB Error

‎04-17-2018 07:48 AM

Hi,

 

Did you get a chance to re-seat the SFB cards? I meant the fabric cards in the middle cage of the chassis, see the attached image for reference. The prcocedure is listed here -

 

https://www.juniper.net/documentation/en_US/release-independent/junos/topics/task/installation/remov...

 

What we need to make sure is that when the SFB card is re-seated, there is an entry in inventory logs, show chassis hardware output and gather output of "show chassis environment sfb". Even

 

request pfe execute command "show jspec client" target spmb0 | no-more

request pfe execute command "show chassis commands" target spmb0 | no-more

 

Since in this case, none of the SFB cards is slots 0 to 4 are coming online, it is pointing to an Hardware issue with the Control Board to me.

 

The SPMB manages FRUs & programs SFB's via PCIe. In this case, the PCIE  switch link between SPMB & SFB5 is down which prevents the SFB from coming online & getting the links trained, reporting failed ASICs.
Please consider having the CB-RE FRU replaced.

 

GOT: [Apr 14 09:17:06.535 LOG: Err] TYSPMB: XF chip not reset. SFB#0 not started
GOT: [Apr 14 09:17:06.535 LOG: Info] TYSPMB: SFB #0 state transition CMTY_SFB_STATE_POWER_ON_WAIT -> CMTY_SFB_STATE_FAULT
GOT: [Apr 14 09:17:07.014 LOG: Info] TYSPMB: SFB #0 state transition CMTY_SFB_STATE_FAULT -> CMTY_SFB_STATE_OFFLINE_ACK_WAIT
GOT: [Apr 14 09:17:07.015 LOG: Debug] cmty_sfb_offline_req: sfb 0 sfb_i2c=0xc0e reason=-1
GOT: [Apr 14 09:17:07.021 LOG: Debug] cmty_sfb_offline_vector: sfb 0 state OFFLINE sfb_i2c = 0x0
GOT: [Apr 14 09:17:07.021 LOG: Debug] cmty_sfb_offline_vector: sfb 0 state OFFLINE
GOT: [Apr 14 09:17:07.021 LOG: Info] TYSPMB: SFB #0 state transition CMTY_SFB_STATE_OFFLINE_ACK_WAIT -> CMTY_SFB_STATE_OFFLINE
GOT: [Apr 14 09:17:07.021 LOG: Err] HSL2: hsl2_unregister_asic: Asic 559 is not a valid chip
GOT: [Apr 14 09:17:07.021 LOG: Err] Hsl2 unregister asic failed  40
GOT: [Apr 14 09:17:07.021 LOG: Err] cmty_sfb_asics_down: Failed to unregister SFB 0 chip 0
GOT: [Apr 14 09:17:07.021 LOG: Err] HSL2: hsl2_unregister_asic: Asic 560 is not a valid chip
GOT: [Apr 14 09:17:07.021 LOG: Err] Hsl2 unregister asic failed  41
GOT: [Apr 14 09:17:07.022 LOG: Err] cmty_sfb_asics_down: Failed to unregister SFB 0 chip 1
GOT: [Apr 14 09:17:07.022 LOG: Err] HSL2: hsl2_unregister_asic: Asic 561 is not a valid chip
GOT: [Apr 14 09:17:07.022 LOG: Err] Hsl2 unregister asic failed  42
GOT: [Apr 14 09:17:07.022 LOG: Err] cmty_sfb_asics_down: Failed to unregister SFB 0 chip 2
GOT: [Apr 14 09:17:07.022 LOG: Err] cmty_sfb_repeater_flash_unregister: ptr NULL flash never registered for sfb_slot 0
GOT: [Apr 14 09:17:07.022 LOG: Info] cmty_set_sfb_state: Disabling power for SFB 0 - hard reset or offline requested
GOT: [Apr 14 09:17:07.743 LOG: Info] TYSPMB: SFB #0 state transition CMTY_SFB_STATE_OFFLINE -> CMTY_SFB_STATE_PRESENT

 

 

Attachments

Junos
Solution
Accepted by topic author plawansai
‎04-17-2018 07:03 PM

Re: MX Router SFB Error

‎04-17-2018 07:01 PM

Hi,

 

I found the root cause. I tried to upgrade to Junos: 16, it solved. Man LOL

 

> show chassis hardware | match SFB
SFB 0            REV 11   711-052892   CGJ3190          Switch Fabric Board 2
SFB 1            REV 11   711-052892   CGG5294          Switch Fabric Board 2
SFB 2            REV 11   711-052892   CGD5125          Switch Fabric Board 2
SFB 3            REV 11   711-052892   CGJ2031          Switch Fabric Board 2

 

Thank you very much.

ปลาวาฬทราย
Junos

Re: MX Router SFB Error

‎04-18-2018 08:14 AM

Hi,

 

Thanks for the update, glad the issue is resolved. Just FYI -
Junos 15.1F5 is required for SFB2 model, hence I had asked earlier whether the SFB model is SFB2.