Junos
Highlighted
Junos

MX204 Rate selection

‎02-10-2020 02:14 PM

Hi,

 

Please help me out and tell me weather this is possible, I find the documentation very confusing.

Port Cheker claims that the config is ok. This page however describes the config unfortunatelly only selectivly without a mixed heterogenous example which is claimed that can be achived only in port-mode as attempted

 

I want to achive the following:

 

image.png

In this scenario ports on PIC1 are working and PIC0 interfaces are disabled.

I am using the port mode configuration as follows:

 

    fpc 0 {
        pic 0 {
            port 0 {
                speed 100g;
            }
            port 1 {
                speed 100g;
            }
            port 2 {
                speed 100g;
        }
        pic 1 {
            port 0 {
                speed 10g;
            }
            port 1 {
                speed 10g;
            }
            port 2 {
                speed 10g;
            }
            port 3 {
                speed 10g;
            }
            port 7 {
                speed 10g;
            }

Juniper MX204 18.2R3-S1.7

4 REPLIES 4
Highlighted
Junos

Re: MX204 Rate selection

‎02-10-2020 02:29 PM

Does

 

set chassis fpc 0 pic 1 number-of-ports 8 

 

help?

Highlighted
Junos

Re: MX204 Rate selection

[ Edited ]
‎02-10-2020 06:58 PM

Hello Pawel,

 

Did you try to reset the PIC module after commiting the changes? When you change the port speed at the port level, you must reset the PIC for the configuration to take effect. Resetting the PIC takes several minutes and affects all the Packet Forwarding Engines. To avoid this, use the request chassis pic pic-slot mic-slot-number fpc-slot fpc-slot-number (offline | online) command to reset the PIC and apply your configuration changes. An alarm is generated indicating the change in port speed.

 

As earlier suggested by smicker, please check if the set chassis fpc 0 pic 1 number-of-ports 8 helps.

 

Thanks,

Vishaal

 

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.


Regards,
Vishaal


Accept as Solution = cool ! (Help fellow community members with similar query be redirected here instead of them reposting again)
Accept as Solution+Kudo = You are a Star !
Highlighted
Junos

Re: MX204 Rate selection

‎02-12-2020 01:55 PM

To follow up on this reply, you can't specify number-of-ports with individual port speeds. This is currently working for me:

 

 

chassis {
    fpc 0 {
        pic 0 {
            port 0 {
                speed 100g;
            }
            port 1 {
                speed 100g;
            }
            port 2 {                    
                speed 100g;
            }
        }
        pic 1 {
            port 0 {
                speed 10g;
            }
        }
    }
}
FPC 0                     BUILTIN      BUILTIN           MPC
  PIC 0                   BUILTIN      BUILTIN           4XQSFP28 PIC
    Xcvr 0       REV 01   740-080491   1M1CS84361ZJ      100GBASE-BXSR
    Xcvr 1       REV 01   740-080491   1M1CS84361RH      100GBASE-BXSR
    Xcvr 2       REV 01   740-080491   1M1CS84361ZK      100GBASE-BXSR
  PIC 1                   BUILTIN      BUILTIN           8XSFPP PIC
    Xcvr 0       REV 01   740-021308   XN327B79560       SFP+-10G-SR

 

et-0/0/0                up    up
et-0/0/0.0              up    up   inet     10.177.19.51/31 
et-0/0/1                up    up
et-0/0/1.0              up    up   inet     10.177.19.56/31 
et-0/0/2                up    up
et-0/0/2.0              up    up   inet     10.177.19.58/31 
xe-0/1/0                up    up
xe-0/1/0.0              up    up   inet     10.177.90.51/31 

 

Highlighted
Junos

Re: MX204 Rate selection

‎02-12-2020 05:55 PM

This is valid configuration. Please check "show chassis alarms" and see if any alarm. Mostly you can get it working by restarting FPC


Mengzhe Hu
JNCIE x 3 (SP DC ENT)