Junos
Junos

Meaning of syslog Return code 1 not EOK

‎10-08-2019 11:05 PM

Hello
I have two interfaces connected from a router J2350 (Junos 12.1X46-D35) to a switch EX2200(Junos 11.4R5.5) running rather ancient software Smiley Wink

I had noticed im losing connection on one of the interfaces from J2350 to EX2200 with the interfacing going to up-down state on both devices while the other interface connecting the two devices does not flap. After investigation I have noted a ridiculous amount of log messages like below

chassism[1034]: Return code 1 not EOK: platform_an_periodic (1606)
chassism[1034]: Return code 1 not EOK: an_periodic (479)


This two messages happen every second essentially filling up all the 10 log files on the switch within a few hours.

After 20 minutes the link between the two devices came up, stayed up for an hour and went down again, then went down again for some time then came back up. It is still up for now it has been more than 5 hours but the log messages never stopped.

 

What do these logs mean I ?

4 REPLIES 4
Junos

Re: Meaning of syslog Return code 1 not EOK

‎10-08-2019 11:18 PM

Hi,

 

This log message is about the autonegiciation transition update from kernal to ifstate.

 

thank you

Prabin

Junos

Re: Meaning of syslog Return code 1 not EOK

‎10-09-2019 12:03 AM

Thank you for the hint, is there a way to tell which interface in particular is the cause?

Junos

Re: Meaning of syslog Return code 1 not EOK

‎10-09-2019 12:21 AM

Hi, 

 

We might have to  look at the logs in detail to confirm it, This log you mentioned is not a problematic log.

 

Can you check when you started seeing this log 

 

Also for the actual issue "Interface going down" please check any errors on the interface, issues with SFP etc, any L1 issue ?

 

Thank you

Prabin

 

 

 

 

Junos

Re: Meaning of syslog Return code 1 not EOK

[ Edited ]
‎10-09-2019 12:26 AM

It is not an SFP port, regular copper port. I checked the interface for errors and there were none. I monitored it for some time to see if there would be errors but none popped

I have rebooted the switch and the log message has stopped showing