Junos
Junos

Port will not turn on after vlan assignment

‎01-10-2019 01:01 PM

So I find this bizarre (coming from Cisco).

I moved an interface into a vlan but the port will not come on. It is not disabled. When I plug the same device to a port that is part of a interface-range group that interface comes on. Help!

10 REPLIES 10
Junos

Re: Port will not turn on after vlan assignment

‎01-10-2019 01:23 PM
Hello,
Please provide configuration.
Regards,
Lado
Junos

Re: Port will not turn on after vlan assignment

‎01-10-2019 01:50 PM

root@PPAL# show interfaces ge-1/0/16
unit 0 {
    family ethernet-switching {
        interface-mode access;
        vlan {
            members 2606;
        }
        storm-control default;
    }
}

Highlighted
Junos

Re: Port will not turn on after vlan assignment

‎01-10-2019 01:51 PM

Really weird! Did I miss something???

 

 

root@PPAL# show interfaces ge-1/0/16
unit 0 {
    family ethernet-switching {
        interface-mode access;
        vlan {
            members 2606;
        }
        storm-control default;
    }
}

Junos

Re: Port will not turn on after vlan assignment

‎01-10-2019 02:04 PM

 

root@PPAL# show interfaces
interface-range user-ports {
member-range ge-0/0/0 to ge-0/0/47;
unit 0 {
family ethernet-switching {
interface-mode access;
vlan {
members PPALINET;
}
storm-control default;
}
}
}
interface-range staff-ports {
member-range ge-1/0/1 to ge-1/0/3;
unit 0 {
family ethernet-switching {
interface-mode access;
vlan {
members PPALSTAFF;
}
storm-control default;
}
}
}
interface-range inet-ports {
member-range ge-1/0/4 to ge-1/0/15;
unit 0 {
family ethernet-switching {
interface-mode access;
vlan {
members PPALINET;
}
}
}
}
ge-0/1/0 {
ether-options {
802.3ad ae0;
}
}
ge-1/0/0 {
unit 0 {
family ethernet-switching {
interface-mode access;
vlan {
members PPALPRINT;
}
storm-control default;
}
}
}
ge-1/0/4 {
unit 0 {
family ethernet-switching {
vlan {
members PPALINET;
}
}
}
}
ge-1/0/15 {
unit 0;
}
ge-1/0/16 {
unit 0 {
family ethernet-switching {
interface-mode access;
vlan {
members 2606;
}
storm-control default;
}
}
}
ge-1/0/22 {
description "BMS Port";
unit 0 {
family ethernet-switching {
interface-mode access;
vlan {
members 2606;
}
}
}
}
ge-1/0/23 {
unit 0 {
family ethernet-switching {
interface-mode access;
vlan {
members 1706;
}
storm-control default;
}
}
}
ge-1/1/0 {
ether-options {
802.3ad ae0;
}
}
ae0 {
aggregated-ether-options {
link-speed 1g;
}
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members all;
}
}
}
}
irb {
unit 0 {
family inet {
dhcp {
vendor-id Juniper-ex2300-48P;
}
}
}
unit 27 {
family inet {
address 172.18.27.13/24;
}
}
unit 1706 {
family inet {
address 172.17.6.100/24;
}
}
unit 2106 {
family inet {
address 172.21.6.100/24;
}
}
}
lo0 {
unit 0 {
family inet {
address 1.1.1.1/32;
}
}
}
vme {
unit 0 {
family inet {
dhcp {
vendor-id Juniper-ex2300-48P;
}
}
}
}

{master:1}[edit]

 

root@PPAL# show vlans
MGMTVLAN {
vlan-id 27;
l3-interface irb.27;
}
PPALHVAC {
vlan-id 2606;
}
PPALINET {
vlan-id 2306;
}
PPALPRINT {
vlan-id 2206;
}
PPALSTAFF {
vlan-id 1706;
l3-interface irb.1706;
}
PPALVOICE {
vlan-id 2106;
l3-interface irb.2106;
}
default {
vlan-id 1;
l3-interface irb.0;
}

{master:1}[edit]

Junos

Re: Port will not turn on after vlan assignment

‎01-10-2019 02:36 PM
Try vlan name not vlan-id like this:
ge-1/0/16 {
unit 0 {
family ethernet-switching {
interface-mode access;
vlan {
members PPALHVAC;
}
storm-control default;
Regards,
Lado
Junos

Re: Port will not turn on after vlan assignment

‎01-10-2019 02:47 PM

Try what?

Junos

Re: Port will not turn on after vlan assignment

‎01-10-2019 02:52 PM
Configure vlan name PPALHVAC under vlan members instead vlan-id 2606
Regards,
Lado
Junos

Re: Port will not turn on after vlan assignment

‎01-11-2019 08:33 AM

I did!

Any port that wasn't configured in the member-range interface doesnt seem to want to come on.

I plugged in the same device that wouldnt connect and moved it to the port that is part of the memberrange vlan and it worked. I moved it to the ports that were not part of it but part of the hvac vlan and none will light up.

Any suggestions?

 

Junos

Re: Port will not turn on after vlan assignment

‎01-11-2019 09:50 AM

Hello,

2 suggestions:

1/ do You have a configuration group that disables ge-* interfaces? Please post printout:

show configuration groups | no-more

3/ what happens if You add "enable" knob under ge-1/0/16?

 

set interfaces ge-1/0/16 enable

And please provide printouts:

show interfaces ge-1/0/16 media detail
show interfaces diagnostics optics ge-1/0/16

HTH

Thx

Alex

 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Junos

Re: Port will not turn on after vlan assignment

‎01-11-2019 10:28 AM
Hello,
Please post full config.
Regards,
Lado