Junos
Junos

Recovery issue

[ Edited ]
‎08-16-2019 07:48 AM

Hi, I have an EX2300 Juniper switches. and it can not be loaded. It just stacks on a boot-up loading. I have a media bootable USB, a snapshot USB recovery but they did not work, because there is no prompt or any option to into. It's just keeping on the loop.

I attached the shot screen of the loop. I hope you guys will have a solution.

Thank you

 

U-Boot 2016.01-rc1 (Nov 11 2016 - 14:26:00 -0800) VERSION=1.3.2

U-Boot code: F0000000 -> F007C59C BSS: -> F00DA238
DRAM: DEV ID = 0xb064
SKU ID = 0xb064
DDR type: DDR3
MEMC 0 DDR speed = 800MHz
PHY revision version: 0x00a1e003
A Series - PHY Initialization (PHY index: 00)
A01. Turn off CKE
A02. Configure timing parameters
A03. Configure PHY PLL
PHY PLL Configuration
Fref.............: 50 MHz
Data rate........: 1600 Mbps
PLL locked.
A04. Configure reference voltage
A05. Compute VDL step size
VDL calibration complete.
VDL step size....: 7.575 ps
UI size..........: 82.500 steps
A06. Configure ADDR/CTRL VDLs
A07. Disable Virtual VTT
A08. ZQ calibration
P drive..........: 0x10
N drive..........: 0x0F
P termination....: 0x06
N termination....: 0x06
P idle...........: 0x00
N idle...........: 0x00
A09. Configure Static Pad Control
A10. Configure ODT
A11. Configure Write Pre-/Post-amble
A12. Configure Auto Idle
A13. Release PHY control
A Series - PHY Initialization complete (PHY index: 00)
Programming controller register
Validate Shmoo parameters stored in flash ..... OK
DDR Tuning Complete
Running simple memory test ..... OK
DDR Interface Ready
Monitor len: 000DA238
Ram size: 80000000
Ram top: E0000000
TLB table from dfff0000 to dfff4000
Reserving 872k for U-Boot at: dff15000
Reserving 320k for malloc() at: dfec5000
Reserving 80 Bytes for Board Info at: dfec4fb0
Reserving 176 Bytes for Global Data at: dfec4f00

RAM Configuration:
Bank #0: 60000000
DRAM: New Stack Pointer is: dfec4ee0
Relocation Offset is: eff15000
Relocating to dff15000, new gd at dfec4f00, sp at dfec4ee0

PCIe clk val:00

PCIe clk val:00
Now running in RAM - U-Boot at: dff15000
SF: Detected MX25L6405D with page size 256 Bytes, erase size 64 KiB, total 8 MiB
In: eserial1
Out: eserial1
Err: eserial1

7 REPLIES 7
Junos

Re: Recovery issue

‎08-16-2019 09:32 AM

Please check if the following works for you:

 

https://kb.juniper.net/InfoCenter/index?page=content&id=KB31462&cat=EX3400&actp=LIST

 

https://kb.juniper.net/InfoCenter/index?page=content&id=KB31265&cat=EX2300&actp=LIST

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution".
If you think that my answer was helpful, please spend some Kudos.
Junos

Re: Recovery issue

‎08-16-2019 10:21 AM

Nope, they did not work because as I mentioned that there is no prompt or there is even no option to get the boot sequence.  You can not do anything, and it just keeps boot-up on the loop.

Junos

Re: Recovery issue

‎08-19-2019 08:35 AM

Ehsanz,

 

If none of the recovery methods works and if you were unable to stop the boot loop, then I'm afraid the replacement of the device is our only option. 

 

I would suggest you contact the JTAC for further proceedings.



Thanks,
π00bm@$t€®.
Please, Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!
Junos

Re: Recovery issue

‎08-19-2019 08:54 PM

Use a different 4GB/8GB USB drive and check the md5 once the junos is copied.

 

Make sure, you are using "install-media" junos version for USB recovery instead of normal version.

 

Junos

Re: Recovery issue

‎11-07-2019 05:24 AM

bonjour EhsanZ,

just I that same problem this morning on one of my EX2300. 

Was replacement the solution you ended up with ?

Michel Lapointe

Junos

Re: Recovery issue

‎11-07-2019 05:48 AM

Wow, 

after restarting the switch 4 times by unplugging the AC and always ending up stuck on the same Err: eserial1  line, I gave up and was ready to replace the switch. 

I went for coffee, chatted with colleague and came back: the switch was up and running !!!!!

I  resetted the AC, and started a timer: the switch got stuck 5 mns at ersial1, and after that showed login as if nothing happenned

weird. 

 

RAM Configuration:
Bank #0: 60000000
DRAM:  New Stack Pointer is: dfec4ee0
Relocation Offset is: eff15000
Relocating to dff15000, new gd at dfec4f00, sp at dfec4ee0
Now running in RAM - U-Boot at: dff15000
SF: Detected MX25L6405D with page size 256 Bytes, erase size 64 KiB, total 8 MiB
In:    eserial1
Out:   eserial1
Err:   eserial1

FreeBSD/arm (cat-valdor-01) (ttyu0)

login: root
Password:
Last login: Mon Sep  9 15:29:51 on ttyu0

--- JUNOS 15.1X53-D58.3 Kernel 32-bit  JNPR-11.0-20180119.e26d166_buil
root@cat-valdor-01:RE:0%
Junos

Re: Recovery issue

‎11-11-2019 08:12 AM

solution proposed by JTAC was to reboot using a formatted usb drive.

_ Format the entire file-system and re-install Junos.
_ If that does not have any effect, RMA.

[EX] How to format install on EX2300 and EX3400
https://kb.juniper.net/InfoCenter/index?page=content&id=KB31265&cat=EX2300&actp=LIST

turns out I already had formatted usb keys with old 15.1 - it worked. After booting from usb, the switch keeps going through the full usual display during boot as before. 

not syre what caused it, but the solution seems to work. 

Michel