Junos
Highlighted
Junos

SRX240 High process utilisation - softdepflush

[ Edited ]
‎02-08-2016 03:09 PM

Hi,

 

A router in the network locket itself up and I could not telnet remotely to the node. Later on after 2 days, the L2vpn and bgp was down between this site and connected site carrying some critical traffic. Luckily we have a backup path. 

 

However, I requested someone on site to run below commands to clear all telnet sessions after running  > show system processes |match telnet  and found multiple telnet sessions.

 

Then requested to run> request system logout user admin all " to cleare them all. 

Running, % netstat -atn |grep 23 displayed only a single IP address in the command. This did not solve the telnet issue at all.

 

Further, looking at the >request support information on this router, I found 3 process running at around 7000+ % and I could not find any related information on these tasks. 

 

PID USERNAME THR PRI NICE SIZE RES STATE C TIME WCPU COMMAND
44 root 1 -16 0 0K 16K sdflus 0 26:06 7518.75% softdepflush
51 root 1 -16 0 0K 16K psleep 0 500:27 2363.87% vmkmemdaemon
48 root 1 -16 0 0K 16K psleep 0 16:27 554.88% vmuncachedaemon
1438 root 7 76 0 994M 63876K select 0 ??? 301.42% flowd_octeon_hm
9939 root 1 77 0 49152K 16480K select 0 0:01 0.73% cli
27 root 1 -28 -147 0K 16K WAIT 0 0:01 0.73% swi5: cambio

 

At the moment I have rebooted the device and the processes are running normal. I had to do this to get the traffic up and running somehow. 

 

Wondering whether anyone has come across this process, believe it could be related to freeBSD. Not an expert on it would appreciate if anyone can shed some light.