Junos
Highlighted
Junos

Solved: Upgrade Failure

‎05-25-2020 03:30 PM

Hi all,

 

This is not a question, but something that I learned recently that may help others.

I had an EX 4300 that was running Junos 14.x. Time for an update!

 

I wanted to upgrade to a JTAC recommended version, in this case 18.4

As per recommendations, I started upgrading in increments (14.x > 15.x, 15.x > 17.x, 17.x > 18.x)

 

The first two updates were fine, but the final one did not work. The update installed, and the switch rebooted, but the version remained at 17.x

 

Here are the two things I learned:

First, There was some config that was not compatible with the update. I fixed these issues, but it still wasn't working. I discovered that I also needed to update the rescue config before the update would proceed.

 

Second, The password encryption method for the root account needed to be updated. I simply had to set the root password again, commit, and update the rescue config.

 

After this the update worked.

 

 

I'm still fairly new with Junos, so I'm still finding tricks like these. I hope this is helpful to someone else out there!

 

2 REPLIES 2
Highlighted
Junos

Re: Solved: Upgrade Failure

‎05-25-2020 09:19 PM

Hi Luke,

 

That's really impressive that you figured quite a lot of things yourself, I have been using the Juniper Devices for some time now too. I want to contribute my 2 cents to your post:

1. For Juniper  upgrade path, I would suggest you skip a version in between, like say you can directly go to 13.x to 15.x or 15.x to 17.x-> this is called step upgrade process. But there's an exception let's say you have to go from 14.x to 16.x, then you have to first come to intermediary version 15.x and then to 16.x. (this is because JunOS from 15.x is based on an upgraded FreeBSD kernel and requires you to first come to 15.x whenever you upgrade from version lesser than 15.x to versions greater than 15.x)

 

2. You can refer table1 in the artlice for more information: https://www.juniper.net/documentation/en_US/junos/topics/topic-map/upgrading-and-downgrading-to-upgr...

 

3. Let's say you proceed with USB install for the device, you can directly flash the required version without the need for the above step upgrade process.

 

Let me know what you think by using below reactions..

Accept as Solution = cool ! (Help fellow community members with similar query be redirected here instead of them reposting again)
Accept as Solution+Kudo = You are a Star !
 

Highlighted
Junos

Re: Solved: Upgrade Failure

‎05-26-2020 03:05 PM

Thanks, I knew about the two versions at a time rule, but I didn't know that you couldn't skip 15.x. Thanks!

 

I've done the full reload with USB on more than one occasion. Bit of a pain, but it's very clean.

Feedback