Junos
Junos

Two irb interfaces with same vlan

3 weeks ago

I have two logical-systems and want both of them to use same same vlan with l3 interface:

 

show interfaces xe-0/0/0                                                          
description Test;
unit 0 {
    family bridge {
        interface-mode trunk;
        vlan-id-list [ 100 ];
}

show bridge-domains test-vlan
vlan-id 100;
routing-interface irb.100;


show logical-systems test interfaces irb unit 100
family inet {
    address 10.0.0.1/24;
}

show interfaces irb unit 100
family inet {
    address 10.0.0.2/24;



# commit check 
re0: 
[edit logical-systems test interfaces irb]
  'unit 100'
    Interface irb.100 is also configured at the top-level
error: configuration check-out failed

Thanks in advance for any suggestions!

9 REPLIES 9
Junos

Re: Two irb interfaces with same vlan

3 weeks ago

You cant have same interface irb.100 under two diffenret logical-systems, main one and "test", you will need to use a differnt number (unit)




#####
Please mark my post as solution if it helped you
Kudos will also be appreciated
Junos

Re: Two irb interfaces with same vlan

3 weeks ago

Also I wabnted to add this in case that what you are looking for is connectivity between logical systems,

 

set chassis fpc 0 pic 0 tunnel-services bandwidth 1g

 

set interfaces lt-0/0/10 unit 0 encapsulation ethernet
set interfaces lt-0/0/10 unit 0 peer-unit 1
set interfaces lt-0/0/10 unit 0 family inet address 10.0.0.1/24

 

set logical-systems TEST interfaces lt-0/0/10 unit 1 encapsulation ethernet
set logical-systems TEST interfaces lt-0/0/10 unit 1 peer-unit 0
set logical-systems TEST interfaces lt-0/0/10 unit 1 family inet address 10.0.0.2/24

 

run ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2): 56 data bytes
64 bytes from 10.0.0.2: icmp_seq=0 ttl=64 time=2.760 ms
64 bytes from 10.0.0.2: icmp_seq=1 ttl=64 time=0.870 ms
64 bytes from 10.0.0.2: icmp_seq=2 ttl=64 time=3.169 ms

 

run ping logical-system TEST 10.0.0.1
PING 10.0.0.1 (10.0.0.1): 56 data bytes
64 bytes from 10.0.0.1: icmp_seq=0 ttl=64 time=0.864 ms
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.911 ms
64 bytes from 10.0.0.1: icmp_seq=2 ttl=64 time=3.293 ms

 

With this minimal config using logical-tunnels you will have connectivity between logcal-systems, hopefully this is the solution for what you are trying to accomplish.




#####
Please mark my post as solution if it helped you
Kudos will also be appreciated
Junos

Re: Two irb interfaces with same vlan

3 weeks ago

Hi

 

It's obvious that you can't use same irb, even in different logical systems. Remember, any logical interface is unique in junos.

 

I know you want it to match your vlan and you don't want to use any random unit. My suggestion is to use irb.100 and irb.10100 in your case. 


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Junos

Re: Two irb interfaces with same vlan

2 weeks ago

 


@ECalderon wrote:

You cant have same interface irb.100 under two diffenret logical-systems, main one and "test", you will need to use a differnt number (unit)


Okay, the second irb can be .1100 for example, but how to add it in same bridge-domain? It support only one

routing-interface

 

 

 

@ECalderon wrote:

Also I wabnted to add this in case that what you are looking for is connectivity between logical systems,

 

With this minimal config using logical-tunnels you will have connectivity between logcal-systems, hopefully this is the solution for what you are trying to accomplish.


Yes I know about logical-tunnels between the logical-systems, but in the current setup I need to have connectivity to same vlan from both logical-systems, the traffic will not be between them.

 

 

@mhu wrote:

Hi

 

It's obvious that you can't use same irb, even in different logical systems. Remember, any logical interface is unique in junos.

 

I know you want it to match your vlan and you don't want to use any random unit. My suggestion is to use irb.100 and irb.10100 in your case. 


irb id is not a problem, how to add second irb in same vlan?

 

 

Junos

Re: Two irb interfaces with same vlan

2 weeks ago

You can try something like this, and have a physical loop between xe-0/0/0 and xe-0/0/1 for interconnectivity, altough you may want to try this on a lab nviroment to see how it behaves,

 

*** Main one ***

show interfaces xe-0/0/0
description Test;
unit 0 {
family bridge {
interface-mode trunk;
vlan-id-list [ 100 ];
}

show bridge-domains test-vlan
vlan-id 100;
routing-interface irb.100;

show interfaces irb unit 100
family inet {
address 10.0.0.2/24;


*** Logical system ***

show logical-systems test interfaces irb unit 1100
family inet {
address 10.0.0.1/24;

show interfaces xe-0/0/1
description Test;
unit 0 {
family bridge {
interface-mode trunk;
vlan-id-list [ 100 ];
}

show bridge-domains test-vlan
vlan-id 100;
routing-interface irb.1100;
}




#####
Please mark my post as solution if it helped you
Kudos will also be appreciated
Junos

Re: Two irb interfaces with same vlan

2 weeks ago

At the moment works with physical loop and vlan translation but i'd prefer some smart way if exist..

Junos

Re: Two irb interfaces with same vlan

Saturday

Can we bridge the irb interface with vlan and logical-tunnel, which to be used in second logical-system?

Junos

Re: Two irb interfaces with same vlan

Sunday
You can use lt interface instead of physical loop, if you don't want use physical loop Here is an great article on how to use lt interface: https://packetpushers.net/junos-logical-system-great-way-to-learn-junos-and-prepare-for-certificatio... PS: Please accept my response as solution if it answers your query, kudos are appreciated too! Thanks Vishal
Junos

Re: Two irb interfaces with same vlan

Tuesday

Hi,

 

Will you be able to add another ip address on the same irb sub unit?


Mengzhe Hu
JNCIE x 3 (SP DC ENT)