Junos
Junos

isis inet6 advertisement received but not in routing table

[ Edited ]
‎11-26-2019 03:49 AM

Hello

 

My topology is as such 

 

      +----+                 +----+
      | R1 |-----------------| R2 |
      +----+                 +----+    
        |                      |
        |                      |
      +----+                 +----+
      | R4 |-----------------| R3 |
      +----+                 +----+

 

All the routers are running isis  (level 2) and all the interfaces are configured with family inet6 addresses (including loopback interface)

The problem is with R2, while all the other routers have R2's inet6 loopback address (and the point-to-point addresses) on their isis databases and the inet6 routing table, R2 does not have any inet6 routes in the inet6 routing table except for the direct connected routes

 

paul@R2> show isis route inet6
IS-IS routing table Current version: L1: 0 L2: 1661

 

paul@R2> show route protocol isis table inet6.0

 

paul@R2>

 

 

IPv4 however works fine

 

paul@R2> show route protocol isis table inet.0 terse

inet.0: 16 destinations, 32 routes (16 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

A V Destination P Prf Metric 1 Metric 2 Next hop AS path
* ? 10.10.17.17/32 I 18 6100 >10.211.24.121
* ? 10.10.20.20/30 I 18 3040 >10.211.24.121

 

-- output filtered --

 

 

When I check the isis database however the v6 prefixes are there

 

paul@R2> show isis adjacency
Interface System L State Hold (secs) SNPA
ge-1/0/0.0   R1  2   Up   24
ge-1/0/1.0   R3  2   Up   18

 

paul@R2> show isis database R1 extensive | match "^[aA-zZ]+|v6"
IS-IS level 1 link-state database:
IS-IS level 2 link-state database:
R1.00-00 Sequence: 0x3fca0, Checksum: 0x5d77, Lifetime: 901 secs
   V6 prefix: 2001:xxxx::3:4::1/128 Metric: 0 Internal Up
   V6 prefix: 2001:xxxx::2:3:0/112 Metric: 10 Internal Up
   V6 prefix: 2001:xxxx::1:2:0/112 Metric: 10 Internal Up

 

-- output filtered --

 

 

I have confirmed all routers are using the same metric type (wide metric) what could be the issue?

9 REPLIES 9
Highlighted
Junos

Re: isis inet6 advertisement received but not in routing table

‎11-26-2019 07:52 AM

Can you please share your isis related config? including "protocol isis" and interfaces

Do you have isis import policy on R2?


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Highlighted
Junos

Re: isis inet6 advertisement received but not in routing table

‎11-26-2019 09:01 AM

Hello

 

Below output from R2 & R1, R3 & R4 share the same pattern

 

paul@R2> show configuration protocols isis 
level 1 disable;
level 2 {
   authentication-key "$9$8gLLdsZGiq.5HqF/A0hcYg4Jik"; ## SECRET-DATA
   authentication-type simple;
   wide-metrics-only;
}
interface ge-1/0/0.0 {
   point-to-point;
   level 2 metric 600001;
}
interface ge-1/0/1.0 {
   level 2 metric 3000;
}
interface lo0.0 {
   passive;
}

paul@R2>

 

 

paul@R1> show configuration protocols isis 
level 1 disable;
level 2 {
   authentication-key "$9$8gLLdsZGiq.5HqF/A0hcYg4Jik"; ## SECRET-DATA
   authentication-type simple;
   wide-metrics-only;
}
interface ge-0/0/0.0 {
   point-to-point;
   level 2 metric 600001;
}
interface ge-0/0/1.0 {

   point-to-point;

   level 2 metric 3000;

}
interface lo0.0 {
   passive;
}

paul@R1>

Highlighted
Junos

Re: isis inet6 advertisement received but not in routing table

‎11-26-2019 09:12 AM

Interface configuration

 

paul@R2> show configuration interfaces ge-1/0/0.0 
description "Connection to R1";
family inet {
   mtu 1500;
   address 10.188.129.94/30;
}
family iso {
   mtu 1497;
}
family inet6 {
   mtu 1500;
   address 2001:xxxx::xxxx:xxxx:fc20/112;
}
family mpls;

 

paul@R2>

 

 

paul@R1> show configuration interfaces ge-0/0/0.0 
description "R2 connection";
family inet {
   mtu 1500;
   address 10.188.129.93/30;
}
family iso {
   mtu 1497;
}
family inet6 {
   mtu 1500;
   address 2001:xxxx::xxxx:xxxx:f120/112;
}
family mpls;

 

paul@R1>

Highlighted
Junos

Re: isis inet6 advertisement received but not in routing table

‎11-26-2019 09:31 AM

Nothing abnormal I could tell. What about lo0 interface config? 


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Highlighted
Junos

Re: isis inet6 advertisement received but not in routing table

‎11-26-2019 12:25 PM

From the config you sent everything looks normal

Maybe give ipv6 topologies a shot. Should configure on all devices.

 

set isis topologies ipv6-unicast

Highlighted
Junos

Re: isis inet6 advertisement received but not in routing table

‎11-26-2019 01:01 PM

Hello,

 

Please check if some import policy is inherited from group:

 

                 show configuration protocols isis | display inheritance no-comment

Thanks

Vishal

Highlighted
Junos
Solution
Accepted by topic author basondolepaul
‎12-02-2019 03:41 AM

Re: isis inet6 advertisement received but not in routing table

‎11-26-2019 01:13 PM

Hello,

 

It may be a long shot, but have you tried pinging your directly connected neighbors R1 and R3 using IPv6 (just to make sure IPv6 addresses on both ends of corresponding links are in the same subnet)?

 

Best regards,

Sergii

-------------------------------------------------------------------

Please accept the solution if your problem is resolved Smiley Happy

-------------------------------------------------------------------

Highlighted
Junos

Re: isis inet6 advertisement received but not in routing table

‎11-27-2019 02:45 AM

So I tried to ping all the IPv6 addresses configured on the physical interface from each router with a note since ISIS is broken on R2 I should not be able to ping any ipv6 address on R2 from R4, and to my suprise ping from R4 to the ipv6 address configured on one of the physical interface on R2 responded. So I did a traceroute to that ipv6 from R4 and behold it was locally configured on an interface on R4. After removing the duplicate address on R4 isis is operating as expected. Is there a way I could have captured this via traceoptions?

Highlighted
Junos

Re: isis inet6 advertisement received but not in routing table

‎11-27-2019 02:54 AM

Good to know that the issue has been resolved! I don't think it's possible to catch such type of errors by means of traceoptions. 

 

Best regards,

Sergii

-------------------------------------------------------------------

Please accept the solution if your problem is resolved Smiley Happy

-------------------------------------------------------------------

Feedback