Junos
Highlighted
Junos

load balancing issue in ae4 bundle

‎08-03-2017 05:10 AM

Dear All ,

 

Traffic is not load balancing across all physical interfaces of ae bundle .In one of physical interface traffic is very low in output direction compared to other two interfaces .Traffic is very low in xe-4/0/3 interface in output direction compared to other two interfaces .Please suggest some work around to load balance traffic across all interfaces .

 

show interfaces ae4 | match rate
  Input rate     : 8844850576 bps (1017134 pps)
  Output rate    : 9596152744 bps (1879530 pps)

 

show interfaces xe-4/2/1 | match rate    
  Input rate     : 3077255720 bps (346539 pps)
  Output rate    : 5102413048 bps (856334 pps)

{master}
 show interfaces xe-0/2/2 | match rate    
  Input rate     : 3161508120 bps (360702 pps)
  Output rate    : 5035475952 bps (842336 pps)

{master}
show interfaces xe-4/0/3 | match rate    
  Input rate     : 3249627672 bps (364550 pps)
  Output rate    : 435030984 bps (287375 pps)

show configuration interfaces ae4
per-unit-scheduler;
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
aggregated-ether-options {
    minimum-links 2;
    link-speed 10g;
    lacp {
        active;
    }

2 REPLIES 2
Highlighted
Junos

Re: load balancing issue in ae4 bundle

‎08-03-2017 02:19 PM

Hello,


 By default the ae bundle does load distribution based on session formation i.e. per flow basis so we observe uneven traffic on child interfaces.
 You can try the different ways to load balance as per the network requirement. Below are the links:

•    https://www.juniper.net/documentation/en_US/junos/topics/concept/load-balance-technique-overview.htm...
•    https://www.juniper.net/documentation/en_US/junos/topics/concept/aggregated-ethernet-stateful-load-b...
•    https://www.juniper.net/documentation/en_US/junos12.3/topics/usage-guidelines/interfaces-configuring...  




Regards,
Rahul

Please mark my solution as accepted if it helped.

Highlighted
Junos

Re: load balancing issue in ae4 bundle

‎09-03-2017 02:04 PM

Hello Shiv,

 

You can try to configure indexed-load-balance [It will increase the memory usase]

 

Refer to below document for more details.

 

indexed-load-balance