Junos
Highlighted
Junos

shmlog eats all space on RE

‎04-10-2020 12:23 PM

Hello,
I've found that some files with *.arg extensions located in /.mount/var/log/shmlog/arg concumes alot of space on RE and not rotated (cleared) automatically.
To fix this I switch to backup RE and delete biggest *.arg file by hand.
Last time it was 13GB

root@:/.mount/var/log/shmlog/arg # rm jdhcpd-event.95.jdhcpd.0.arg

I'm not using telemetry and:

subscriber-management {
    overrides {
        shmlog {
            disable;
        }
    }
    enable;
}

Is it save to clear all files in directory /.mount/var/log/shmlog/arg?

2 REPLIES 2
Highlighted
Junos
Solution
Accepted by topic author schadel
‎04-11-2020 02:35 AM

Re: shmlog eats all space on RE

‎04-10-2020 03:34 PM

Hey schadel,

 

Greetings,  these are shared memory logs and they will not cause any harm, nothing to worry about please check below:

 

https://www.juniper.net/documentation/en_US/junos/topics/reference/configuration-statement/shmlog-co...

 

Now if they are cluttering and not rotating as they should you might want to check this PR:

 

https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1364775

 

The correct way to clear them is ">clear shmlog all-info logname all" or disable them as you did also will do the job!

 

Good luck and happy Friday.

 

If this solves your problem, please mark this post as "Accepted Solution" so we can help others too \:)/

Regards,

 

Lil Dexx
JNCIE-ENT#863, 3X JNCIP-[SP-ENT-DC], 4X JNCIA [cloud-DevOps-Junos-Design], Champions Ingenius, SSYB

 

 

Highlighted
Junos

Re: shmlog eats all space on RE

‎04-11-2020 02:40 AM

Thank you very much.Smiley Happy

Feedback