Junos
Highlighted
Junos

using TFTP for backup

‎07-01-2014 04:55 AM

Hi.

I want to save backup of my config on SRX to TFTP server which is running on my PC. I tried the "file copy /config/juniper.conf.1.gz tftp://100.1.1.50" but the following error displayed:

 

ssh: Could not resolve hostname tftp: hostname nor servname provided, or not known
lost connection
error: put-file failed
error: could not send local copy of file

 

I searched the net and found the running "start shell" and did the following:

 

root@% tftp 100.1.1.50
tftp> put juniper.conf.1.gz
Sent 1221 bytes in 0.0 seconds
tftp> quit
root@%

 

the file appeared on TFTP server with GZ suffix and it cannot be opend. why I did not managed to open the backed up file on Windows? isn't be readable by text editors or I did something wrong? 

and another thing. why we cannot copy the files to TFTP with "file copy" command? were my commands wrong?

 

1 REPLY 1
Highlighted
Junos

Re: using TFTP for backup

‎07-02-2014 02:21 AM

.gz is for an archive. You cannot open it with notepad. 

 

Try the same using a regular text file and you should be able to see correctly the content.

 

The command was correct and if you replace it with ftp instead of tftp and add the username and password, it will work.

 

It's just that you cannot use tftp with file copy.

 

 

 

=====

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.

Feedback