Junosphere
This forum is intended for all discussions and questions relating to Junosphere. It is a branch-off from the former "Junos and Junosphere" forum, which is now titled "Junos".
Junosphere

Martini L2VPN Not Working

‎12-05-2013 02:41 PM

Having issues with my Martini L2VPN in Junosphere.

 

My targeted LDP session is up:

 

cjones@PE1# run show ldp neighbor
Address            Interface          Label space ID         Hold time
2.2.2.2            lo0.0              2.2.2.2:0                34

 

Show l2circuit connections shows:

 

cjones@PE1# run show l2circuit connections | find Neigh
Neighbor: 2.2.2.2
    Interface                 Type  St     Time last up          # Up trans
    ge-0/0/2.0(vc 1)          rmt   NC

 

NC is intf encaps not CCC/TCC

 


My interface is configured with CCC encap, though:

 

cjones@PE1# show interfaces ge-0/0/1
encapsulation ethernet-ccc;
unit 0 {
    family ccc;
}

Is it possible that Junosphere simply doesnt support Martini L2Circuits?

 

Here is my full relevant config:

 

interfaces {
    ge-0/0/1 {
        encapsulation ethernet-ccc;
        unit 0 {
            family ccc;
        }
    }
    ge-0/0/2 {
        unit 0 {
            family inet {
                address 10.255.255.1/30;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 1.1.1.1/32;
            }
            family iso {
                address 49.0000.1111.1111.1111.00;
            }
        }
    }
}
protocols {
    rsvp {
        interface ge-0/0/2.0;
        interface lo0.0;
    }
    mpls {
        label-switched-path PE1_TO_PE2 {
            to 2.2.2.2;
        }
        interface ge-0/0/2.0;
    }
    isis {
        level 1 disable;
        level 2 wide-metrics-only;
        interface ge-0/0/2.0;
        interface lo0.0;
    }
    ldp {
        interface lo0.0;
    }
    l2circuit {
        neighbor 2.2.2.2 {
            interface ge-0/0/2.0 {
                virtual-circuit-id 1;
            }
        }
    }
}
--
Chris Jones
JNCIE-ENT #272
Former JNCIP-SP
Former CCIE #25655
Former Juniper Ambassador
3 REPLIES 3
Junosphere

Re: Martini L2VPN Not Working

‎12-06-2013 01:51 AM
Junosphere supports Martini. At least I tried it with vlan-ccc in VJX and it worked. Make sure the transport LSPs are up, as well as the targeted LDP session.
Junosphere
Solution
Accepted by topic author JunosChris
‎08-26-2015 01:27 AM

Re: Martini L2VPN Not Working

‎12-06-2013 03:22 AM

Hello  there,

You are using wrong interface for Your L2circuit:

 

interfaces {
    ge-0/0/1 {
        encapsulation ethernet-ccc;
        unit 0 {
            family ccc;
        }
    }

 

And

 

 l2circuit {
        neighbor 2.2.2.2 {
            interface ge-0/0/2.0 {
                virtual-circuit-id 1;
            }

 Please change it to ge-0/0/1.0 and it should be working.

HTH

Thanks
Alex

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Junosphere

Re: Martini L2VPN Not Working

‎12-06-2013 09:04 AM

@aarseniev wrote:

Hello  there,

You are using wrong interface for Your L2circuit:

 

interfaces {
    ge-0/0/1 {
        encapsulation ethernet-ccc;
        unit 0 {
            family ccc;
        }
    }

 

And

 

 l2circuit {
        neighbor 2.2.2.2 {
            interface ge-0/0/2.0 {
                virtual-circuit-id 1;
            }

 Please change it to ge-0/0/1.0 and it should be working.

HTH

Thanks
Alex


Wow, that's what I get for copy/pasting while tired. 

 

Thanks for catching that. I need to learn to not make such obvious mistakes if I have any chance of passing the JNCIE-SP.

--
Chris Jones
JNCIE-ENT #272
Former JNCIP-SP
Former CCIE #25655
Former Juniper Ambassador