Management
Highlighted
Management

Automatic archival via FTP in mgmt_junos routing instance

[ Edited ]
‎03-31-2020 02:14 PM

Hi,

I configured the out-of-band management port (fxp0) in a special routing instance (mgmt_junos). But seem configuration archival does not work in mgmt_junos. In log I recived this messages:

Mar 31 22:01:08 core5 fetch: fetch: ftp://core5:*@10.200.19.250/backup/core5_20200331_185951_juniper.conf.gz: Operation timed out
Mar 31 22:01:08 core5 logger: transfer-file failed to transfer /var/transfer/config/core5_20200331_185951_juniper.conf.gz rc 1
Mar 31 22:04:39 core5 fetch: fetch: ftp://core5:*@10.200.19.250/backup/core5_20200331_185951_juniper.conf.gz: Operation timed out
Mar 31 22:04:39 core5 logger: transfer-file failed to transfer /var/transfer/config/core5_20200331_185951_juniper.conf.gz rc 1
Mar 31 22:06:54 core5 pfed: Error <256> uploading file '/var/transfer/config/core5_20200331_185951_juniper.conf.gz'


Part of config:

rom@core5# show routing-instances mgmt_junos |display set
set routing-instances mgmt_junos description MANAGEMENT

rom@core5# show system archival |display set
set system archival configuration transfer-interval 15
set system archival configuration routing-instance mgmt_junos
set system archival configuration archive-sites "ftp://core5:core5qazwsxedc@10.200.19.250/backup"

rom@core5# show interfaces fxp0 |display set
set interfaces fxp0 unit 0 family inet filter input acl_fxp0.0_in
set interfaces fxp0 unit 0 family inet filter output acl_fxp0.0_out
deactivate interfaces fxp0 unit 0 family inet filter
set interfaces fxp0 unit 0 family inet address 10.200.19.30/24
set interfaces fxp0 unit 0 family inet address 10.200.19.43/24


System connection:

rom@core5> show system connections inet show-routing-instances |match 10.200.19.250.21
tcp4 0 0 XXX.XXX.XXX.XXX.61664 10.200.19.250.21 default SYN_SENT


Seem automatic archival continues to use the default routing instance.

PS:  Junos: 18.4R2-S3

2 REPLIES 2
Highlighted
Management

Re: Automatic archival via FTP in mgmt_junos routing instance

‎03-31-2020 04:50 PM

cab you try installing a static route sneding that specific traffic to the MGMNT table, like this :

 

set routing-options static route xxx.xxx.xxx.xxx/32 next-table XXX-MGMT.inet.0 

 

 

I help you, you help me... please share a Kudos or accepted solution whenever you feel I have helped with your problem! 🙂
Highlighted
Management

Re: Automatic archival via FTP in mgmt_junos routing instance

‎04-01-2020 02:10 AM

Yes, if you set a static route it should work. But in this case src_ip will be from interface lo0.0 (external address) and not from management interface fxp0 (10.200.19.30 or 10.200.19.43).
I'm trying to use a special route instance (mgmt_junos) to completely separate management routes from other (production) routes. But it doesn't seem to work or I'm doing something wrong.

Feedback