Management
Management

Error encountered when attempted to upgrade NSMXpress

11.10.08   |  
‎11-10-2008 03:58 PM

I am trying to upgrade couple of NSMXpress devices to NSM version 2008.1 and putting them in a cluster. When I run the installation script on the Primary, the following error messages appear for the GuiSvr, DevSvr, and HaSvr.

 

########## PERFORMING PRE-INSTALLATION TASKS ##########
Running preinstallcheck...
Checking if platform is valid...............................ok
Checking for correct intended platform......................ok
Checking if all needed binaries are present.................ok
Checking for platform-specific binaries.....................ok
Checking for platform-specific packages.....................ok
Checking in System File for PostgreSQL and XDB parameters...ok
Checking for PostgreSQL.....................................ok
Checking if user is root....................................ok
Checking if user nsm exists.................................ok
Checking if installed Device Server is newer................FAILED
ERROR: Cannot downgrade Device Server
Checking if installed GUI Server is newer...................FAILED
ERROR: Cannot downgrade GUI Server
Checking if installed HA Server is newer....................FAILED
ERROR: Cannot downgrade HA Server
Checking if system meets RAM requirement....................ok
Checking for sufficient disk space..........................ok
Please correct the error(s) above and run again
Removing staging directory..................................ok
For operation of NSM server, switch to user "nsm".
Please consult NSM product documentation for details.

 

I guess the script checked the current version of the above servers, and found that they are older than the version I'm trying to upgrade to. But how do I fix the errors? Any pointers are appreciated.

3 REPLIES
Management

Re: Error encountered when attempted to upgrade NSMXpress

11.11.08   |  
‎11-11-2008 01:22 AM

Hi Atlas ,

 

from which release are you upgrading ?

 

It sounds like the install script is checking the version number of the binaries installed and finding they are the same hence bailing out.

 

Was the nsmXpress unit in production with a database prior to upgrade ?

 

Kind regards

Colin

If this worked for you please flag my post as an "Accepted Solution" so others can benefit.
Management

Re: Error encountered when attempted to upgrade NSMXpress

10.11.11   |  
‎10-11-2011 03:49 AM

plz assist me i am also facing the same issue.. can any one suggest us ???

Highlighted
Management

Re: Error encountered when attempted to upgrade NSMXpress

02.29.12   |  
‎02-29-2012 07:49 AM

Hi,

 

I'm facing the same issue :

ERROR: Cannot downgrade GUI Server

I want to downgrade an NSM appliance from 2011.4 to 2007.3r5. Could someone help me please?

 

KR