Routing
Routing

Adding new Prefix

‎08-20-2013 05:51 AM

Hello All,

I recently took the reins after our net admin jumped ship. I'm awful green with Juniper gear and apologize for my questions ahead of time here. Smiley Happy

I was allocated a new /22 from ARIN recently, and can't seem to get it to advertise. I've added the addresses to the main export policies for both my carriers. I've also run 'clear bgp neighbor soft x.x.x.x' and I've even tried without specifying the neighbor. When I check with 'show route advertising-protocol bgp x.x.x.x' I see my previous advertisements, but don't see any of the new ones.

 

Curious if there is a step I may be missing.

Thanks
 -Travis

3 REPLIES 3
Routing
Solution
Accepted by topic author Sprag-O
‎08-26-2015 01:27 AM

Re: Adding new Prefix

[ Edited ]
‎08-20-2013 06:37 AM

Hi !

 

Is your route active ? what is the result of "show route x.x.x.x/22 exact" ?

 

For advertising  the /22, the route must be active. Did you generate a route corresponding to the /22 ? Exemple :

 

set routing-options aggregate route x.x.x.x/22

 

Then on your policy, you should have something like :

 

policy-statement SUMMARY {
    from {
        protocol aggregate;
        route-filter x.x.x.x/22 exact;
    }
    then accept;
}

 Regards,

 

Salah

Routing

Re: Adding new Prefix

‎08-20-2013 08:44 AM

Salah,

    Thanks for the info! I believe I had everything built out but the route.  I added the /22 to the static routing options and now I can advertise it out.

   Issue is resolved.

Routing

Re: Adding new Prefix

‎08-20-2013 03:05 PM

How did you generate the route ? static ? aggregate ?

 

If you have only one transit peer, static is fine, but it you more transit peer on different router, best practice is to generate the route (set routing-options aggregate route x.x.x.x/y)

 

Regards,

 

Salah