BGP Signalled VPLS MTU issues

‎12-20-2019 04:58 AM

Hi All, 


I have an issue where communication is present accross a VPLS connection but websites are failing to load which indicates a MTU missmatch / issue. I have tried changing the MTU accross the network to no avail


When testing from one Gateway in Location A pinging a host in Location B. The max size i can ping is 1450.


Our core MPLS links are set Physical MTU 9192 and MPLS MTU 9000


For the CE-Facing interfaces I have not set the MTU so they have defaulted to 1518 


The cisco SW MTU has been tested with 1500 aswell as 9000 just for testing purposes but still no luck


Seting the VPLS MTU in the routing instance is also not feasible as this is BGP signalled


The solution goes:


GW (SRX) --> Cisco SW (CE) --> PE-0.EN1 (SRX) --> P0.THN (ACX) -- > PE-1.THN (ACX) --> Cisco SW (CE) ---> GW (SRX) 


Could anyone point me in the right direction for this? If any more info is required please let me know





Re: BGP Signalled VPLS MTU issues

‎12-20-2019 09:16 AM
You can verify the MPLS core MTU using sweep command Use sweep command MX> ping mpls rsvp sweep On the juniper devices check for incrementing MTU Errors (show interface ge-x/y/z extensive | match "MTU errors") Above step should help you narrow down the issue in MPLS core and rest of the juniper devices. Try similar commands on cisco devices too. PS: Please accept my response as solution if it solves your query, kudos are appreciated too! Thanks Vishal