Routing
Highlighted
Routing

Basic RVI; showing in routing table as hidden

‎04-29-2017 11:49 AM

I have a simple RVI in an EX2200 routing table showing as hidden.

Address/subnet is an infrequently used/private as per IANA range.

192.0.0.0 /24

 

This is the only reason I can think of why JUNOS has moved this to hidden.

I have a ton of other RVIs defined and all are fine and injected into local routing table.

All are up/up.

 

Thoughts community ?

2 REPLIES 2
Highlighted
Routing
Solution
Accepted by topic author mgioia
‎04-30-2017 01:42 AM

Re: Basic RVI; showing in routing table as hidden

‎04-30-2017 12:03 AM

Yes, 192.0.0.0/24 is Special-Purpose Address Registry. These routes are called martian routes. Use > show route martians table inet.0 to view other martian routes. 

If you can install 192.0.0.0/24 route in local routing table with knob ( not recommended ).

[ edit routing-options ]

user@host# set martians 192.0.0.0/24 orlonger allow

[ edit routing-options ]

user@host# run show route martians table inet.0

 

inet.0:

             0.0.0.0/0 exact -- allowed

             0.0.0.0/8 orlonger -- disallowed

             127.0.0.0/8 orlonger -- disallowed

             192.0.0.0/24 orlonger -- allowed

             240.0.0.0/4 orlonger -- disallowed

             224.0.0.0/4 exact -- disallowed

             224.0.0.0/24 exact -- disallowed

 
Highlighted
Routing

Re: Basic RVI; showing in routing table as hidden

‎04-30-2017 01:44 AM

Perfect.  Thanks Manoj Karmacharya.

Feedback