Routing
Highlighted
Routing

Binding a single VRF with a specific Static LSP over RSVP

‎12-07-2013 03:21 AM

Hello guys:

 

I have a query regarding static LSP. 

 

R1---------R2(PE1)------------rsvp----------R3------------rsvp-----------R4(PE2)--------------R5

                       \                                                                                   /

                         \---------------rsvp------------R6------------rsvp----------/

 

Now my query is running RSVP within the cloud ensures protected for all services. But I want to run Static LSP from R2 (PE1) to R4 (PE2) through R3 for particular VRF service not for all VRF services. Is it possible? if possible could anyone show me the sample configuration. I will be glad 

8 REPLIES 8
Highlighted
Routing

Re: Binding a single VRF with a specific Static LSP over RSVP

‎12-08-2013 02:26 AM

Hi,

 

You can use something like the following for inspiration about the subject:

 

http://www.juniper.net/techpubs/en_US/junos/topics/usage-guidelines/vpns-mapping-vpls-traffic-to-spe...

http://www.juniper.net/techpubs/en_US/junos11.4/topics/example/policy-lsp-forwarding-next-hop-assign...

 

I think you need to have a community or target community in the match {} statement, and apply the same logic as in these examples to your deployment.

 

Hope it works!

Highlighted
Routing

Re: Binding a single VRF with a specific Static LSP over RSVP

‎12-08-2013 09:59 AM

Could you please help me out to verify the configuratoin of the following case: (consider mpls/ibgp/isis is running between PE1 & PE2)

 

 

EX1(CE-1.1.1.11/32)-.1-----10.10.10.0/29---------BBOM_VRF-.2-R1(PE1-3.3.3.33/32)--.1--------10.10.11.0/29----------.2---R2(PE2-4.4.4.44/32)-BBOM_VRF-.1-------10.10.12.0/29------------.2-EX2(CE-2.2.2.22/32)

 

R1(PE1-3.3.3.33/32)
----------------
set policy-options community BBOM_VRF members target:65000:10

set routing-instances BBOM_VRF instance-type vrf
set routing-instances BBOM_VRF interface ge-0/0/7.0
set routing-instances BBOM_VRF route-distinguisher 65000:10
set routing-instances BBOM_VRF vrf-import BBOM_import
set routing-instances BBOM_VRF vrf-export BBOM_export
set routing-instances BBOM_VRF vrf-table-label
set routing-instances BBOM_VRF routing-options static route 1.1.1.11/32 next-hop 10.10.10.1

 

set policy-options policy-statement BBOM_export term a from protocol static
set policy-options policy-statement BBOM_export term a from protocol direct
set policy-options policy-statement BBOM_export term a then community add BBOM_VRF
set policy-options policy-statement BBOM_export term a then accept
set policy-options policy-statement BBOM_export term b then reject

 

set policy-options policy-statement BBOM_import term a from protocol bgp
set policy-options policy-statement BBOM_import term a from community BBOM_VRF
set policy-options policy-statement BBOM_import term a then install-nexthop lsp PE1-PE2
set policy-options policy-statement BBOM_import term a then accept
set policy-options policy-statement BBOM_import term b then reject


set protocols mpls static-label-switched-path PE1-PE2 ingress next-hop 10.10.11.2 push 1001001 to 4.4.4.44
set protocols mpls static-label-switched-path PE1-PE2 transit 1001001 pop

 

set routing-options forwarding-table export BBOM_import

 

R2(PE2-4.4.4.44/32)
----------------

set routing-instances BBOM_VRF instance-type vrf
set routing-instances BBOM_VRF interface ge-0/0/7.0
set routing-instances BBOM_VRF route-distinguisher 65000:10
set routing-instances BBOM_VRF vrf-import BBOM_import
set routing-instances BBOM_VRF vrf-export BBOM_export
set routing-instances BBOM_VRF vrf-table-label
set routing-instances BBOM_VRF routing-options static route 2.2.2.22/32 next-hop 10.10.12.2

 

set policy-options policy-statement BBOM_export term a from protocol static
set policy-options policy-statement BBOM_export term a from protocol direct
set policy-options policy-statement BBOM_export term a then community add BBOM_VRF
set policy-options policy-statement BBOM_export term a then accept
set policy-options policy-statement BBOM_export term b then reject

 

set policy-options policy-statement BBOM_import term a from protocol bgp
set policy-options policy-statement BBOM_import term a from community BBOM_VRF
set policy-options policy-statement BBOM_import term a then install-nexthop lsp PE2-PE1
set policy-options policy-statement BBOM_import term a then accept
set policy-options policy-statement BBOM_import term b then reject

 

set protocols mpls static-label-switched-path PE2-PE1 ingress next-hop 10.10.11.1 push 1002002 to 3.3.3.33
set protocols mpls static-label-switched-path PE2-PE1 transit 1002002 pop

 

set routing-options forwarding-table export BBOM_import

Highlighted
Routing

Re: Binding a single VRF with a specific Static LSP over RSVP

‎12-09-2013 10:18 AM

You have overlap in the policies. You should have 3 unique policies:

set policy-options policy-statement BBOM_export term a from protocol static
set policy-options policy-statement BBOM_export term a from protocol direct
set policy-options policy-statement BBOM_export term a then community add BBOM_VRF <<< delete this one
set policy-options policy-statement BBOM_export term a then accept
set policy-options policy-statement BBOM_export term b then reject

set policy-options policy-statement BBOM_import term a from protocol bgp
set policy-options policy-statement BBOM_import term a from community BBOM_VRF
set policy-options policy-statement BBOM_import term a then install-nexthop lsp PE1-PE2 <<< delete this one
set policy-options policy-statement BBOM_import term a then accept
set policy-options policy-statement BBOM_import term b then reject

set policy-options policy-statement BBOM_select_LSP term a from protocol bgp      
set policy-options policy-statement BBOM_select_LSP term a from community BBOM_VRF
set policy-options policy-statement BBOM_select_LSP term a then install-nexthop lsp PE1-PE2
set policy-options policy-statement BBOM_select_LSP term b then accept

set routing-options forwarding-table export BBOM_select_LSP

Is the LSP working? Please get the proof that the LSP works. Use "ping mpls" or similar or ping from CE.

I don't know if the above will work with using the static LSP:

set protocols mpls static-label-switched-path PE1-PE2 ingress next-hop 10.10.11.2 push 1001001 to 4.4.4.44
set protocols mpls static-label-switched-path PE1-PE2 transit 1001001 pop

I would suggest to try and use RSVP and set up a RSVP signalled LSP. Then if selecting the LSP based on policy works, then next step would use the static LSP.

Hth

Highlighted
Routing

Re: Binding a single VRF with a specific Static LSP over RSVP

‎12-10-2013 11:32 PM

hello, Please check the following ppt for some query

Attachments

Highlighted
Routing

Re: Binding a single VRF with a specific Static LSP over RSVP

‎12-11-2013 09:30 PM

Please check the output of the provided case:

 

PE1 > show route table mpls.0

mpls.0: 11 destinations, 11 routes (11 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0 *[MPLS/0] 4w6d 14:23:28, metric 1
Receive
1 *[MPLS/0] 4w6d 14:23:28, metric 1
Receive
2 *[MPLS/0] 4w6d 14:23:28, metric 1
Receive
13 *[MPLS/0] 4w6d 14:23:28, metric 1
Receive
16 *[VPN/0] 23:42:15
to table BBOM_VRF.inet.0, Pop


300032 *[LDP/9] 21:48:11, metric 1
> to 10.10.11.4 via ge-0/1/1.0, Pop
300032(S=0) *[LDP/9] 21:48:11, metric 1
> to 10.10.11.4 via ge-0/1/1.0, Pop


1001001 *[MPLS/6] 22:08:24, metric 1
> to 10.10.11.4 via ge-0/1/1.0, Pop
1001001(S=0) *[MPLS/6] 22:08:24, metric 1
> to 10.10.11.4 via ge-0/1/1.0, Pop

========================================

 

 

PE1> show mpls static-lsp
Ingress LSPs:
Total 0, displayed 0, Up 0, Down 0

Transit LSPs:
LSPname Incoming-label State
PE1-PE2 1001001 Up
Total 1, displayed 1, Up 1, Down 0

Bypass LSPs:
Total 0, displayed 0, Up 0, Down 0

 

================================

 

PE1> show ldp database
Input label database, 3.3.3.33:0--4.4.4.44:0
Label Prefix
300032 3.3.3.33/32
3 4.4.4.44/32

 

Output label database, 3.3.3.33:0--4.4.4.44:0
Label Prefix
3 3.3.3.33/32
300032 4.4.4.44/32

 

================================

 

 

 

But when I delete protocol ldp:

 

Ping is not successfull but still static lsp is up. 

 

output:

 

 

 

CE1> ping 2.2.2.22
PING 2.2.2.22 (2.2.2.22): 56 data bytes
36 bytes from 10.10.10.3: Destination Net Unreachable
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 0054 e2b7 0 0000 40 01 7fcf 10.10.10.1 2.2.2.22

36 bytes from 10.10.10.3: Destination Net Unreachable
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 0054 e2e3 0 0000 40 01 7fa3 10.10.10.1 2.2.2.22

^C
--- 2.2.2.22 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss

 

 

mpls.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0 *[MPLS/0] 4w6d 15:07:56, metric 1
Receive
1 *[MPLS/0] 4w6d 15:07:56, metric 1
Receive
2 *[MPLS/0] 4w6d 15:07:56, metric 1
Receive
13 *[MPLS/0] 4w6d 15:07:56, metric 1
Receive
16 *[VPN/0] 1d 00:26:43
to table BBOM_VRF.inet.0, Pop
1001001 *[MPLS/6] 22:52:52, metric 1
> to 10.10.11.4 via ge-0/1/1.0, Pop
1001001(S=0) *[MPLS/6] 22:52:52, metric 1
> to 10.10.11.4 via ge-0/1/1.0, Pop

 

 

===================================

 

Can anyone please help regarding this problem....My intension is to for BBOM Service the traffic will follow the static lsp path...

 

FYI, in the PE1> show mpls static-lsp ..... ingress LSP is not created..is there any issue regarding this...

Highlighted
Routing

Re: Binding a single VRF with a specific Static LSP over RSVP

‎12-15-2013 02:30 AM

can anyone please provide the solution?

Highlighted
Routing

Re: Binding a single VRF with a specific Static LSP over RSVP

‎12-16-2013 07:58 AM

CE1(R5)---------PE1 (R1)-----ldp (for all service) and rsvp (only for BBOM_VRF)-----------P(R4)-----------ldp and rsvp------(R2)PE2-------------CE2 (R6)

 

PE1:

==========

 

interfaces {
inactive: em0 {
unit 0 {
description "To R2";
family inet {
address 12.12.12.1/24;
}
family iso;
family mpls;
}
}
em1 {
unit 0 {
description "To R5";
family inet {
address 15.15.15.1/24;
}
}
}
em2 {
unit 0 {
description "To R3";
family inet {
address 13.13.13.1/24;
}
}
}
em3 {
unit 0 {
description "To R4";
family inet {
address 14.14.14.1/24;
}
family iso;
family mpls;
}
}
lo0 {
unit 0 {
description "loopback of R1";
family inet {
address 1.1.1.1/32;
}
family iso {
address 49.0001.0010.0100.1001.00;
}
}
}
}
routing-options {
forwarding-table {
export map-route-to-LSP;
}
}
protocols {
rsvp {
interface em0.0;
interface em3.0;
}
mpls {
label-switched-path PE1-PE2 {
from 1.1.1.1;
to 2.2.2.2;
primary by_PE2;
}
label-switched-path PE1-PE4-PE2 {
from 1.1.1.1;
to 2.2.2.2;
preference 10;
primary by_PE1-PE4-PE2;
}
path by_PE2 {
12.12.12.2 strict;
}
path by_PE1-PE4-PE2 {
4.4.4.4 loose;
}
interface em0.0;
interface em3.0;
}
bgp {
local-as 65000;
group internal {
type internal;
local-address 1.1.1.1;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family l2vpn {
signaling;
}
family inet-mvpn {
signaling;
}
neighbor 2.2.2.2;
neighbor 4.4.4.4;
}
}
isis {
reference-bandwidth 100g;
level 2 wide-metrics-only;
level 1 disable;
interface em0.0 {
ldp-synchronization;
point-to-point;
level 2 metric 50;
}
interface em3.0 {
ldp-synchronization;
point-to-point;
level 2 metric 50;
}
interface lo0.0 {
passive;
level 1 disable;
}
}
ldp {
interface em0.0;
interface em3.0;
interface lo0.0;
}
}
policy-options {
policy-statement BBOM_export {
term a {
from protocol [ static direct bgp ];
then {
community add BBOM_VRF;
accept;
}
}
term b {
then reject;
}
}
policy-statement BBOM_import {
term a {
from {
protocol bgp;
community BBOM_VRF;
}
then {
install-nexthop strict lsp PE1-PE4-PE2;
accept;
}
}
term b {
then reject;
}
}
policy-statement map-route-to-LSP {
term a {
from {
community BBOM_VRF;
route-filter 6.6.6.6/32 exact;
}
then {
install-nexthop lsp PE1-PE4-PE2;
accept;
}
}
}
community BBOM_VRF members target:65000:10;
}
routing-instances {
BBOM_VRF {
instance-type vrf;
interface em1.0;
route-distinguisher 65000:10;
vrf-import BBOM_import;
vrf-export BBOM_export;
vrf-table-label;
routing-options {
static {
route 5.5.5.5/32 next-hop 15.15.15.5;
}
}
}
}

 

R2:

====

 

interfaces {
em0 {
unit 0 {
description "To R4";
family inet {
address 24.24.24.2/24;
}
family iso;
family mpls;
}
}
em1 {
unit 0 {
description "To R1";
family inet {
address 12.12.12.2/24;
}
family iso;
family mpls;
}
}
em2 {
unit 0 {
family inet {
address 26.26.26.2/24;
}
}
}
lo0 {
unit 0 {
description "loopback of R2";
family inet {
address 2.2.2.2/32;
}
family iso {
address 49.0001.0020.0200.2002.00;
}
}
}
}
routing-options {
forwarding-table {
export map-route-to-LSP;
}
}
protocols {
rsvp {
interface em1.0;
interface em0.0;
}
mpls {
label-switched-path PE2-PE1 {
from 2.2.2.2;
to 1.1.1.1;
primary by_PE1;
}
label-switched-path PE2-PE4-PE1 {
from 2.2.2.2;
to 1.1.1.1;
preference 10;
primary by_PE2-PE4-PE1;
}
path by_PE1 {
12.12.12.1 strict;
}
path by_PE2-PE4-PE1 {
4.4.4.4 loose;
}
interface em1.0;
interface em0.0;
}
bgp {
local-as 65000;
group internal {
type internal;
local-address 2.2.2.2;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family l2vpn {
signaling;
}
family inet-mvpn {
signaling;
}
neighbor 1.1.1.1;
neighbor 4.4.4.4;
}
}
isis {
reference-bandwidth 100g;
level 2 wide-metrics-only;
level 1 disable;
interface em0.0 {
ldp-synchronization;
point-to-point;
level 2 metric 50;
}
interface em1.0 {
ldp-synchronization;
point-to-point;
level 2 metric 50;
}
interface lo0.0 {
passive;
level 1 disable;
}
}
ldp {
interface em0.0;
interface em1.0;
interface lo0.0;
}
}
policy-options {
policy-statement BBOM_export {
term a {
from protocol [ static direct bgp ];
then {
community add BBOM_VRF;
accept;
}
}
term b {
then reject;
}
}
policy-statement BBOM_import {
term a {
from {
protocol bgp;
community BBOM_VRF;
}
then {
install-nexthop strict lsp PE2-PE4-PE1;
accept;
}
}
term b {
then reject;
}
}
policy-statement map-route-to-LSP {
term a {
from community BBOM_VRF;
then {
install-nexthop lsp PE2-PE4-PE1;
accept;
}
}
}
community BBOM_VRF members target:65000:10;
}
routing-instances {
BBOM_VRF {
instance-type vrf;
interface em2.0;
route-distinguisher 65000:10;
inactive: vrf-import BBOM_import;
inactive: vrf-export BBOM_export;
vrf-target target:65000:10;
vrf-table-label;
routing-options {
static {
route 6.6.6.6/32 next-hop 26.26.26.6;
}
}
}
}

 

==============================================

 

output:

 

PE1: 

root@R1# run show route

inet.0: 9 destinations, 9 routes (9 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[Direct/0] 1d 02:53:33
> via lo0.0
2.2.2.2/32 *[IS-IS/18] 02:05:03, metric 100
> to 14.14.14.4 via em3.0
4.4.4.4/32 *[IS-IS/18] 03:49:31, metric 50
> to 14.14.14.4 via em3.0
12.12.12.0/24 *[IS-IS/18] 02:05:03, metric 150
> to 14.14.14.4 via em3.0
13.13.13.0/24 *[Direct/0] 1d 00:59:41
> via em2.0
13.13.13.1/32 *[Local/0] 1d 00:59:41
Local via em2.0
14.14.14.0/24 *[Direct/0] 10:14:24
> via em3.0
14.14.14.1/32 *[Local/0] 10:14:24
Local via em3.0
24.24.24.0/24 *[IS-IS/18] 02:05:03, metric 100
> to 14.14.14.4 via em3.0

inet.3: 2 destinations, 3 routes (2 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2.2.2.2/32 *[LDP/9] 02:05:03, metric 1
> to 14.14.14.4 via em3.0, Push 300128
[RSVP/10] 00:43:05, metric 100
> to 14.14.14.4 via em3.0, label-switched-path PE1-PE4-PE2
4.4.4.4/32 *[LDP/9] 02:05:03, metric 1
> to 14.14.14.4 via em3.0

BBOM_VRF.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

5.5.5.5/32 *[Static/5] 1d 00:46:57
> to 15.15.15.5 via em1.0
6.6.6.6/32 *[BGP/170] 00:07:29, localpref 100, from 2.2.2.2
AS path: I
> to 14.14.14.4 via em3.0, Push 16, Push 300128(top)
15.15.15.0/24 *[Direct/0] 1d 01:09:56
> via em1.0
15.15.15.1/32 *[Local/0] 1d 01:09:56
Local via em1.0
26.26.26.0/24 *[BGP/170] 00:07:29, localpref 100, from 2.2.2.2
AS path: I
> to 14.14.14.4 via em3.0, Push 16, Push 300128(top)

iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

49.0001.0010.0100.1001/72
*[Direct/0] 1d 02:53:33
> via lo0.0

mpls.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0 *[MPLS/0] 1d 01:41:34, metric 1
Receive
1 *[MPLS/0] 1d 01:41:34, metric 1
Receive
2 *[MPLS/0] 1d 01:41:34, metric 1
Receive
16 *[VPN/0] 1d 01:41:34
to table BBOM_VRF.inet.0, Pop
300048 *[LDP/9] 02:05:03, metric 1
> to 14.14.14.4 via em3.0, Pop
300048(S=0) *[LDP/9] 02:05:03, metric 1
> to 14.14.14.4 via em3.0, Pop
300064 *[LDP/9] 02:05:03, metric 1
> to 14.14.14.4 via em3.0, Swap 300128

bgp.l3vpn.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

65000:10:6.6.6.6/32
*[BGP/170] 1d 00:47:15, localpref 100, from 2.2.2.2
AS path: I
> to 14.14.14.4 via em3.0, Push 16, Push 300128(top)
65000:10:26.26.26.0/24
*[BGP/170] 1d 00:55:40, localpref 100, from 2.2.2.2
AS path: I
> to 14.14.14.4 via em3.0, Push 16, Push 300128(top)

 

 

================================================

 

PE2:

------

 

root@R2# run show route

inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[IS-IS/18] 02:05:38, metric 100
> to 24.24.24.4 via em0.0
2.2.2.2/32 *[Direct/0] 1d 00:59:10
> via lo0.0
4.4.4.4/32 *[IS-IS/18] 04:51:10, metric 50
> to 24.24.24.4 via em0.0
12.12.12.0/24 *[Direct/0] 1d 00:59:10
> via em1.0
12.12.12.2/32 *[Local/0] 1d 00:59:10
Local via em1.0
14.14.14.0/24 *[IS-IS/18] 02:05:38, metric 100
> to 24.24.24.4 via em0.0
24.24.24.0/24 *[Direct/0] 10:14:57
> via em0.0
24.24.24.2/32 *[Local/0] 10:14:57
Local via em0.0

inet.3: 2 destinations, 3 routes (2 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[LDP/9] 02:05:37, metric 1
> to 24.24.24.4 via em0.0, Push 300160
[RSVP/10] 02:05:33, metric 100
> to 24.24.24.4 via em0.0, label-switched-path PE2-PE4-PE1
4.4.4.4/32 *[LDP/9] 02:05:37, metric 1
> to 24.24.24.4 via em0.0

BBOM_VRF.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

5.5.5.5/32 *[BGP/170] 00:06:43, localpref 100, from 1.1.1.1
AS path: I
> to 24.24.24.4 via em0.0, Push 16, Push 300160(top)
6.6.6.6/32 *[Static/5] 1d 00:47:41
> to 26.26.26.6 via em2.0
15.15.15.0/24 *[BGP/170] 00:06:43, localpref 100, from 1.1.1.1
AS path: I
> to 24.24.24.4 via em0.0, Push 16, Push 300160(top)
26.26.26.0/24 *[Direct/0] 1d 00:56:06
> via em2.0
26.26.26.2/32 *[Local/0] 1d 00:56:06
Local via em2.0

iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

49.0001.0020.0200.2002/72
*[Direct/0] 1d 00:59:10
> via lo0.0

mpls.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0 *[MPLS/0] 1d 00:59:11, metric 1
Receive
1 *[MPLS/0] 1d 00:59:11, metric 1
Receive
2 *[MPLS/0] 1d 00:59:11, metric 1
Receive
16 *[VPN/0] 1d 00:59:11
to table BBOM_VRF.inet.0, Pop
299920 *[LDP/9] 02:05:37, metric 1
> to 24.24.24.4 via em0.0, Pop
299920(S=0) *[LDP/9] 02:05:37, metric 1
> to 24.24.24.4 via em0.0, Pop
299968 *[LDP/9] 02:05:37, metric 1
> to 24.24.24.4 via em0.0, Swap 300160

bgp.l3vpn.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

65000:10:5.5.5.5/32
*[BGP/170] 00:08:04, localpref 100, from 1.1.1.1
AS path: I
> to 24.24.24.4 via em0.0, Push 16, Push 300160(top)
65000:10:15.15.15.0/24
*[BGP/170] 00:08:04, localpref 100, from 1.1.1.1
AS path: I
> to 24.24.24.4 via em0.0, Push 16, Push 300160(top)

 

==============================================

 

root@R1# run show route 6.6.6.6 extensive

BBOM_VRF.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
6.6.6.6/32 (1 entry, 1 announced)
TSI:
KRT in-kernel 6.6.6.6/32 -> {indirect(131070)}
*BGP Preference: 170/-101
Route Distinguisher: 65000:10
Next hop type: Indirect
Next-hop reference count: 6
Source: 2.2.2.2
Next hop type: Router, Next hop index: 561
Next hop: 14.14.14.4 via em3.0, selected
Label operation: Push 16, Push 300128(top)              <<<<<< here route is selecting LDP but my intension is to select the RSVP  PE1-PE4-PE2
Protocol next hop: 2.2.2.2
Push 16
Indirect next hop: 8e050b0 131070
State: <Secondary Active Int Ext>
Peer AS: 65000
Age: 8:44 Metric2: 1
Task: BGP_65000_65000.2.2.2.2+52354
Announcement bits (1): 0-KRT
AS path: I
Communities: target:65000:10
Import Accepted
VPN Label: 16
Localpref: 100
Router ID: 2.2.2.2
Primary Routing Table bgp.l3vpn.0
Indirect next hops: 1
Protocol next hop: 2.2.2.2 Metric: 1
Push 16
Indirect next hop: 8e050b0 131070
Indirect path forwarding next hops: 1
Next hop type: Router
Next hop: 14.14.14.4 via em3.0
2.2.2.2/32 Originating RIB: inet.3
Metric: 1 Node path count: 1
Forwarding nexthops: 1
Nexthop: 14.14.14.4 via em3.0

 

Highlighted
Routing

Re: Binding a single VRF with a specific Static LSP over RSVP

‎01-15-2014 07:43 AM

Hi, 

 

I was on vacation but I'm back now. Is the issue still unresolved?

 

You had one question about the following:

 


@saifudduza wrote:

 

root@R1# run show route 6.6.6.6 extensive

BBOM_VRF.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
6.6.6.6/32 (1 entry, 1 announced)
TSI:
KRT in-kernel 6.6.6.6/32 -> {indirect(131070)}
*BGP Preference: 170/-101
Route Distinguisher: 65000:10
Next hop type: Indirect
Next-hop reference count: 6
Source: 2.2.2.2
Next hop type: Router, Next hop index: 561
Next hop: 14.14.14.4 via em3.0, selected
Label operation: Push 16, Push 300128(top)              <<<<<< here route is selecting LDP but my intension is to select the RSVP  PE1-PE4-PE2
Protocol next hop: 2.2.2.2
Push 16
Indirect next hop: 8e050b0 131070
State: <Secondary Active Int Ext>
Peer AS: 65000
Age: 8:44 Metric2: 1
Task: BGP_65000_65000.2.2.2.2+52354
Announcement bits (1): 0-KRT
AS path: I
Communities: target:65000:10
Import Accepted
VPN Label: 16
Localpref: 100
Router ID: 2.2.2.2
Primary Routing Table bgp.l3vpn.0
Indirect next hops: 1
Protocol next hop: 2.2.2.2 Metric: 1
Push 16
Indirect next hop: 8e050b0 131070
Indirect path forwarding next hops: 1
Next hop type: Router
Next hop: 14.14.14.4 via em3.0
2.2.2.2/32 Originating RIB: inet.3
Metric: 1 Node path count: 1
Forwarding nexthops: 1
Nexthop: 14.14.14.4 via em3.0

 


It makes sense if it selects the wrong LSP (LDP vs RSVP signalled), because default LDP route preference is 9, and you set your RSVP signalled LSP to preference 10 by configuration:

 

mpls {
label-switched-path PE2-PE4-PE1 {
from 2.2.2.2;
to 1.1.1.1;
preference 10;
primary by_PE2-PE4-PE1;
}

}

 

Therefor LDP LSP is chosen. The default RSVP preference is 7 as per http://www.juniper.net/techpubs/en_US/junos11.4/topics/reference/general/routing-protocols-default-r... documentation.

 

I checked the JUNOS CLI in lab on MX80 running 11.4R10, and found that you can also assign static-lsp from the policy:

 

######################

admin@mx80# set policy-options policy-statement FOOBAR then install-nexthop ?
Possible completions:
> except Do not choose to install matching next hops
+ lsp Next-hop LSP name
+ lsp-regex Next-hop LSP name regular expression
+ static-lsp Next-hop static LSP name
+ static-lsp-regex Next-hop static LSP name regular expression
strict Do not use any other available next hops

######################

 

Please share your thoughts.

Feedback