Routing
Routing

Bridge Domain on MX

[ Edited ]
‎11-06-2019 05:31 AM

Hi Guys,

I am a bit confused on how Juniper is doing Layer3 and Layer2 on a single interface.

Basically I have one single physical interface and I want:
- for vlan 350 -> Layer 3 interface
- for vlan 23 -> layer 2 interfaces

My target:

1)Trunk interface where I can tag which vlan i want

2)vlan350 allowed in this trunk and terminated on this trunk as Layer3 interface (SVI)

3)vlan 23 allow on this trunk but no Layer3 termination for it.

I understood the logic (in somehow) of the concept of IRB and bridge domain: with both of them the router (I have an mx10003) is acting as Layer3 and Layer2.
Step:
1)Define the bridge domain
2)define the logical interface: one layer2 interface and one layer3 interface
3)"Insert" the defined logical-interface into the bridge-domain.

My hardware is mx-10003.
Will work somehting like:

 

 

 

 

 

 

bridge-domains {
MX10003{
domain-type bridge;
vlan-id 23;
routing-interface irb.350;
}
}
interfaces {
irb {
unit 350 {
family inet {
address a.a.a.a/31;
}

}
}
xe-1/1/10:0 {
mtu 9192;
unit 0 {
family bridge {
interface-mode trunk;
vlan-id-list [ 23 5 ];
}
}
}
}

 

Thanks

4 REPLIES 4
Highlighted
Routing

Re: Bridge Domain on MX

‎11-06-2019 07:23 AM

Hello,

 

I think you can refer following example which covers ALL the scenarios on how to use IRB interface in the bridge domain.

 

https://www.juniper.net/documentation/en_US/junos/topics/example/layer-2-bridge-domain-environment-e...

 

After gooing through above case study if you still have some question or doubt, please let me know.

PS: If my answers resolves your query, please mark answers as the solutions. Kudos are appreciated too!

Thanks

Vishal

Highlighted
Routing

Re: Bridge Domain on MX

[ Edited ]
‎11-06-2019 08:27 PM

This is what your configuration is creating:BRIDGE DOMAIN.png

 

I don't think this matches what you are trying to achieve.

 

Regards, 

Yasmin Lara - Juniper Ambassador #QuadE - JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
JNCIS-CLOUD, JNCDS-DC, JNCIA-DevOps
Highlighted
Routing

Re: Bridge Domain on MX

‎11-07-2019 03:04 AM

when you have multiple units and are mixing layer 3 and layer 2 on the same interface you will be using flexible vlan tagging and not port mode trunk. 

 

The exact commands are different on SRX versus MX.  

 

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Highlighted
Routing

Re: Bridge Domain on MX

‎11-07-2019 10:24 AM

Hi,

 

For pure layer 3, you don't need a BD and its layer 2 interface. You should be able to find examples regarding service provier and enterprise style interface configuration for junos.

 

Your request is pretty straightforward, you can try following 

 

 


#show interfaces ge-1/0/0 |display set
set interfaces ge-1/0/0 flexible-vlan-tagging
set interfaces ge-1/0/0 encapsulation flexible-ethernet-services
set interfaces ge-1/0/0 unit 23 family bridge interface-mode trunk
set interfaces ge-1/0/0 unit 23 family bridge vlan-id-list 23
set interfaces ge-1/0/0 unit 350 vlan-id 350
set interfaces ge-1/0/0 unit 350 family inet address 1.1.1.1/30

set bridge-domains bd23 vlan-id 23


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Feedback