Routing
Routing

Can't route out of the switch on EX2200

‎02-25-2016 01:25 PM

I have an EX2200 with 5 VLANs/Subnets configured:

31 (10.1.31.0/24)

34 (10.1.34.0/24)

50 (10.1.50.0/24)

102 (10.1.102.0/24)

98 (10.2.1.0/24)

 

The switch is connected to a router (actually it's a Sophos UTM), via the 10.2.1.0 network:

EX2200 10.2.1.1

Router 10.2.1.10

 

I have a default route pointing to the router interface for any traffic needing to pass through the router. If I try to ping the router interface (10.2.1.10), I am able to from two of the subnets (31 and 34), but not the other two (50 and 102). I have no security restrictions on the switch, and the router is allowing all traffic from all of the subnets, and I can ping VLAN 98s L3 interface (10.1.2.1), from all subents.

 

All four are configured exactly the same, with the exception of the L3 interface, from what I can see. What else can I do to figure out why these networks cant leave the switch?

4 REPLIES 4
Routing

Re: Can't route out of the switch on EX2200

‎02-25-2016 02:36 PM

Here is what it looks like, trying to ping from 2 subnets on the switch, to the router interface.

pings.gifAn example of the behaviour I see.

 

Routing

Re: Can't route out of the switch on EX2200

‎02-26-2016 12:12 AM

Hi  JSinclair,

 

This will usually be because you don't have the routes to 10.1.50.0/24 and 10.1.102.0/24 properly configured on the Sophos UTM.

 

Routes to the two networks on the Sophos UTM should point to 10.2.1.1

 

Thanks,
Hisham

Please accept my comment as a solution, if it helped in resolving your issue, to help guide other commentators and encourage others.
Routing

Re: Can't route out of the switch on EX2200

‎02-26-2016 07:04 AM

Thank Hisham, all of my routes were correct. It looks like it wasn't a configuration issue as there was an update to the router (UTM) that I scheduled to install last night. It was only a securty patch, but the UTM rebooted, and when I came in this morning, everything was working.

Routing

Re: Can't route out of the switch on EX2200

‎03-07-2016 02:23 PM
Can you add some kudos and mark as resolvedSmiley Happy
[KUDOS PLEASE! If you think I earned it!
If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]