Routing
Highlighted
Routing

Cannot commit when apply scheduler-map ?

‎03-27-2020 10:06 PM

Hi all,

 

I'm try in my lab using vMX to apply scheduler-map but it have an error when i try commit. I'm using this url https://www.juniper.net/documentation/en_US/junos/topics/example/cos-scheduler-map-security-applying... . Below is my config and error. Appreciate any one can highlight my mistake.

 

interfaces {
ge-0/0/5 {
unit 0 {
classifiers {
inet-precedence ipp;
}
rewrite-rules {
dscp dscp_v4;
dscp-ipv6 dscp_v6;
}
}
}
ge-0/0/6 {
##
## Warning: 'per-unit-scheduler', 'hierarchical-scheduler', or 'shared-scheduler' for this interface is required for scheduler map on interface unit
##
unit 0 {
scheduler-map qos-scheduler;
rewrite-rules {
dscp dscp_v4;
dscp-ipv6 dscp_v6;
}
}
}
}

 

[edit class-of-service]
test@vmx# commit
[edit class-of-service interfaces]
'ge-0/0/6'
'per-unit-scheduler', 'hierarchical-scheduler', or 'shared-scheduler' for this interface is required for scheduler map on interface unit
error: commit failed: (statements constraint check failed)

 

 

Thanks

 

6 REPLIES 6
Highlighted
Routing

Re: Cannot commit when apply scheduler-map ?

‎03-27-2020 10:53 PM

Hey  kronicklez,

 

Greetings mate, you will need to use per-unit-scheduler', 'hierarchical-scheduler', or 'shared-scheduler to overcome this commit error, however, for each one of these you need to meet some software and hardware requirements, for hierarchical and shared schedulers, with per unit, you need to take into consideration that the ‘unit 0’ is not considered a VLAN, so ‘per-unit-scheduling’ will not apply. 

 

Quick solution: use the scheduler you have on the physical interface and this would do the job.

e.i

 

set class-of-service interfaces ge-0/0/5 scheduler-map qos-scheduler

set class-of-service interfaces ge-0/0/6 scheduler-map qos-scheduler


If this solves your problem, please mark this post as "Accepted Solution" so we can help others too \Smiley Happy/

Regards,

Lil Dexx
JNCIE-ENT#863, 3X JNCIP-[SP-ENT-DC], 4X JNCIA [cloud-DevOps-Junos-Design], Champions Ingenius, SSYB

 

 

Highlighted
Routing

Re: Cannot commit when apply scheduler-map ?

‎03-28-2020 03:50 AM

Hi Lidexx,

 

Still cannot commit. Below is the error.

 

[edit class-of-service]
teat@vmx# commit
[edit class-of-service interfaces]
'ge-0/0/6'
Ifd ge-0/0/6: rate limit validation failed for smap qos-scheduler. Rate-limit is only supported on queues of priority high or strict-high.
error: configuration check-out failed

[edit class-of-service]
root@vmx#

 

Thanks

 

Highlighted
Routing

Re: Cannot commit when apply scheduler-map ?

‎03-30-2020 09:14 AM

Hi,

 

Greetings. We moved one step forward by adding per-unit-scheduler 

 

Can you please share the configuration for all your schedulers and sheduler-map. As the error message indicates, we need to modify one of the schedulers to remove rate-limit option 


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Highlighted
Routing

Re: Cannot commit when apply scheduler-map ?

‎03-30-2020 10:22 AM

Hi Mengzhe,

 

Below is my config on my vMX lab. Appreciate where should i apply scheduler-map on ge-0/0/6 because it appear an error during the commit.

 

classifiers {
inet-precedence ipp {
import default;
forwarding-class BE {
loss-priority low code-points [ 000 001 010 ];
}
forwarding-class AF {
loss-priority low code-points [ 011 100 ];
}
forwarding-class EF {
loss-priority low code-points 101;
}
forwarding-class NC {
loss-priority low code-points [ 110 111 ];
}
}
}
forwarding-classes {
queue 0 BE;
queue 1 AF;
queue 2 EF;
queue 3 NC;
}

interfaces {

ge-0/0/6 {
unit 0 {
rewrite-rules {
dscp dscp_v4;
dscp-ipv6 dscp_v6;
}
}
rewrite-rules {
dscp dscp_v4 {
forwarding-class AF {
loss-priority low code-point 000000;
}
forwarding-class BE {
loss-priority low code-point 000000;
}
forwarding-class EF {
loss-priority low code-point 000000;
}
forwarding-class NC {
loss-priority low code-point 000000;
}
}
dscp-ipv6 dscp_v6 {
forwarding-class AF {
loss-priority low code-point 000000;
}
forwarding-class BE {
loss-priority low code-point 000000;
}
forwarding-class EF {
loss-priority low code-point 000000;
}
forwarding-class NC {
loss-priority low code-point 000000;
}
}
}

 

scheduler-maps {
qos-scheduler {
forwarding-class BE scheduler BE;
forwarding-class AF scheduler AF;
forwarding-class EF scheduler EF;
forwarding-class NC scheduler NC;
}
}
schedulers {
BE {
transmit-rate {
percent 40;
rate-limit;
}
}
AF {
transmit-rate {
percent 10;
rate-limit;
}
}
EF {
transmit-rate {
percent 30;
rate-limit;
}
}
NC {
transmit-rate {
percent 20;
rate-limit;
}
}
}

 

 

Thanks

 

 

Highlighted
Routing

Re: Cannot commit when apply scheduler-map ?

‎03-30-2020 12:35 PM

 

Hey kronicklez,

 

Greetings, the previous commit error has been corrected after applying the scheduler on the physical interface, this new commit error you are facing is due to the rate-limit knob you configured under each scheduler. 

 

This can only be configured when you set the priority to strick high or high, none of your schedulers have priorities hence this commit error is being exhibited, please remove the rate-limit knob and this should do the job.


If this solves your problem, please mark this post as "Accepted Solution" so we can help others too \Smiley Happy/

Regards,

 

Lil Dexx
JNCIE-ENT#863, 3X JNCIP-[SP-ENT-DC], 4X JNCIA [cloud-DevOps-Junos-Design], Champions Ingenius, SSYB

Highlighted
Routing

Re: Cannot commit when apply scheduler-map ?

‎03-30-2020 07:47 PM

Hi Lidexx,

 

Let's say if the requirement need to rate-limit the scheduler so is it any other way instead using like my config?

 

Thanks and apprciate your feedback