Routing
Highlighted
Routing

Cisco to Juniper BGP conversion

[ Edited ]
‎09-30-2013 10:10 AM

Hi folks,

Need a little help with some bgp conversion from ios to junos. I have a production environment currently running juniper routers(j4350)/switches(ex4200). My development environment is running cisco 3560G. I would like to remove the cisco and replace with a pair of ex4200. So the ios to junos conversion tool was a bit convoluted.

Does anyone have a more concise way to migrate the cisco bgp to junos?

thanks in advance.

 

Cisco bgp snippet

 

router bgp 19602

no synchronization

bgp router-id 10.43.127.5

bgp log-neighbor-changes

bgp dampening

network 10.43.92.0 mask 255.255.255.0

network 10.43.93.0 mask 255.255.255.0

network 10.43.94.0 mask 255.255.255.0

network 10.43.95.0 mask 255.255.255.0

network 10.43.127.5 mask 255.255.255.255

neighbor 10.43.126.30 remote-as 19602

neighbor 10.43.126.30 transport path-mtu-discovery

neighbor 10.43.126.30 next-hop-self

neighbor 10.43.126.30 soft-reconfiguration inbound

neighbor 172.31.254.54 remote-as 65535

neighbor 172.31.254.54 transport path-mtu-discovery

neighbor 172.31.254.54 ebgp-multihop 5

neighbor 172.31.254.54 soft-reconfiguration inbound

no auto-summary

!

Junos bgp snippet

 

set routing-options static route 10.43.127.5/32 next-hop 10.43.64.5

set routing-options static route 10.43.127.5/32 resolve

set routing-options autonomous-system 65535

set protocols mpls icmp-tunneling

set protocols mpls interface ge-0/0/3.0

set protocols mpls interface ge-0/0/0.205

set protocols mpls interface ge-0/0/0.210

set protocols mpls interface ge-0/0/0.208

set protocols bgp group ebgp-dev type external

set protocols bgp group ebgp-dev multihop ttl 5

set protocols bgp group ebgp-dev local-address 172.31.254.54

set protocols bgp group ebgp-dev export dev-export

set protocols bgp group ebgp-dev peer-as 19602

set protocols bgp group ebgp-dev as-override

set protocols bgp group ebgp-dev neighbor 10.43.127.5 description lvhl-cg-dev-l3s1

set protocols bgp group internal type internal

set protocols bgp group internal local-address 172.31.254.54

set protocols bgp group internal family inet unicast

set protocols bgp group internal family l2vpn signaling

set protocols bgp group internal export next-hop-self

set protocols bgp group internal local-as 65111

set protocols bgp group internal neighbor 172.31.254.100 description lvsn-cg-pe-shrd-rtr1

set protocols bgp group internal neighbor 172.31.254.101 description lvsn-cg-pe-shrd-rtr2

set protocols ospf traceoptions file ospf-log

set protocols ospf traceoptions file size 1m

set protocols ospf traceoptions file files 10

set protocols ospf traceoptions file world-readable

set protocols ospf traceoptions flag general

set protocols ospf traffic-engineering

set protocols ospf export bgp-ospf

set protocols ospf import ospf-import-deny

set protocols ospf area 0.0.0.0 interface fxp0.0 disable

set protocols ospf area 0.0.0.0 interface lo0.0 passive

set protocols ospf area 0.0.0.0 interface ge-0/0/2.0 interface-type p2p

set protocols ospf area 0.0.0.0 interface ge-0/0/2.0 metric 250

set protocols ospf area 0.0.0.0 interface ge-0/0/3.0 interface-type p2p

set protocols ospf area 0.0.0.0 interface ge-0/0/3.0 metric 250

set protocols ospf area 0.0.0.0 interface ge-0/0/1.0 metric 300

set protocols ospf area 0.0.0.0 interface t3-1/0/0.0 interface-type p2p

set protocols ospf area 0.0.0.0 interface t3-1/0/0.0 metric 1000

set protocols ospf area 0.0.0.0 interface ge-0/0/0.205 interface-type p2p

set protocols ospf area 0.0.0.0 interface ge-0/0/0.205 metric 1000

set protocols ospf area 0.0.0.0 interface ge-0/0/0.205 bfd-liveness-detection minimum-interval 500

set protocols ospf area 0.0.0.0 interface ge-0/0/0.205 bfd-liveness-detection multiplier 3

set protocols ospf area 0.0.0.0 interface ge-0/0/0.210 interface-type p2p

set protocols ospf area 0.0.0.0 interface ge-0/0/0.210 metric 1000

set protocols ospf area 0.0.0.0 interface ge-0/0/0.210 bfd-liveness-detection minimum-interval 500

set protocols ospf area 0.0.0.0 interface ge-0/0/0.210 bfd-liveness-detection multiplier 3

set protocols ldp track-igp-metric

set protocols ldp interface ge-0/0/0.205

set protocols ldp interface ge-0/0/0.208

set protocols ldp interface ge-0/0/0.210

set protocols ldp interface ge-0/0/3.0

set policy-options policy-statement bgp-ospf term permit from route-filter 10.43.95.0/24 exact

set policy-options policy-statement bgp-ospf term permit from route-filter 10.43.92.0/24 exact

set policy-options policy-statement bgp-ospf term permit from route-filter 10.43.93.0/24 exact

set policy-options policy-statement bgp-ospf term permit from route-filter 10.43.94.0/24 exact

set policy-options policy-statement bgp-ospf term permit from route-filter 10.43.127.5/32 exact

set policy-options policy-statement bgp-ospf term permit from route-filter 10.43.127.6/32 exact

set policy-options policy-statement bgp-ospf term permit then external type 1

set policy-options policy-statement bgp-ospf term permit then accept

set policy-options policy-statement bgp-ospf term deny-all then reject

set policy-options policy-statement dev-export term permit from route-filter 0.0.0.0/0 exact

set policy-options policy-statement dev-export term permit then accept

set policy-options policy-statement dev-export term deny-all then reject

set policy-options policy-statement next-hop-self then next-hop self

set policy-options policy-statement ospf-import-deny term permit from route-filter 10.43.95.0/24 exact

set policy-options policy-statement ospf-import-deny term permit from route-filter 10.43.92.0/24 exact

set policy-options policy-statement ospf-import-deny term permit from route-filter 10.43.93.0/24 exact

set policy-options policy-statement ospf-import-deny term permit from route-filter 10.43.94.0/24 exact

set policy-options policy-statement ospf-import-deny term permit from route-filter 10.43.127.5/32 exact

set policy-options policy-statement ospf-import-deny term permit from route-filter 10.43.127.6/32 exact

set policy-options policy-statement ospf-import-deny term permit then reject

set security forwarding-options family mpls mode packet-based

 

 

Attachments

4 REPLIES 4
Highlighted
Routing

Re: Cisco to Juniper BGP conversion

‎10-02-2013 02:38 PM

As you can imagine, this question must have been asked and answered hundreds of times. Please take a look at these links and see if they help. Please read them before you get frustrated and say it does not work as you already have experienced that. One of the nice features with Juniper is the consistency or at least fairly consistent comands and OS across systems.IOS is not the same across different systems of that vendor and different versions. Such a fully featured and fully functional tool would be awesome, but you can imagine what it would take to create one. And of course it would have to be created so the operation is one way only, one direction, C2J with no possibility of reverse engineering the tool. We cannot encourage using anything less than the top of the line, next gen equipment.
http://www.gossamer-threads.com/lists/nsp/juniper/30329

http://forums.juniper.net/t5/SRX-Services-Gateway/Need-any-cisco-ASA-to-Juniper-srx-conversion-tool/...

https://kb.juniper.net/InfoCenter/index?page=content&id=KB13220
http://forums.juniper.net/jnet/attachments/jnet/Day1Books/188/6/Junos4IOS%20book.pdf

https://i2j.juniper.net/release/index.jsp

[KUDOS PLEASE! If you think I earned it!
If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]
Highlighted
Routing

Re: Cisco to Juniper BGP conversion

‎03-15-2018 10:28 AM

I do not have access to all the links to conversion tool. it needs partner login I suppose?

Highlighted
Routing

Re: Cisco to Juniper BGP conversion

‎03-15-2018 11:14 AM

yes, however, you can also go through Juniper documents for example configuration.

Highlighted
Routing

Re: Cisco to Juniper BGP conversion

‎03-15-2018 05:30 PM

The I2J tool is available to users as well not just partners.   The login is on the support section of the site.  You should be able to create an account there similar to the way you made the forum account.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Feedback