Routing
Highlighted
Routing

Dynamic LSP using RSVP over IPV6 network

‎06-04-2019 01:18 PM

I have a ACX2200 Router and I am trying to setup an LSP using RSVP. The management network is a IPV6 network. I have ospf3 running which comes up fine. But if our unit send a RSVP PATH message , the juniper router rejects it and sends back an ICMP6 error "Parameter Problem (unrecognized next header type encountered)". If the network is changed to ipv4 it works fine and I can see the PATH and RESV messages and the labels get exchanged. 

 

Please let me know if I am missing any configuration. Current configuration pasted below. I can provide more details in case it is needed.

 

Thank you,

Ram Krishnan

 

interfaces {
ge-0/0/2 {
unit 0 {
family inet6 {
address 00:fe:1::01/64;
}
family mpls;
}
}
ge-0/0/3 {
unit 0 {
family inet {
address 2.3.4.5/28;
}
family inet6 {
address 00:fc:1::1/64;
}
family mpls;
}
}
fxp0 {
unit 0 {
family inet {
address 10.3.64.250/16;
}
}
}
lo0 {
unit 0 {
family inet {
address 127.0.0.1/32;
}
}
}
}
routing-options {
router-id 2.2.2.2;
}
protocols {
rsvp {
tunnel-services;
interface all;
interface fxp0.0 {
disable;
}
}
mpls {
interface all;
}
ospf {
area 0.0.0.0 {
interface ge-0/0/3.0;
}
}
ospf3 {
area 0.0.0.0 {
interface ge-0/0/3.0;
}
}
}

 

8 REPLIES 8
Highlighted
Routing

Re: Dynamic LSP using RSVP over IPV6 network

‎06-04-2019 06:15 PM

I guess RSVP messages are always ipv4. can you get the tcpdump for rsvp packet to confirm?

You may want to consider ospf3 with ipv4-unicast-realm to support both ipv4 and ipv6 family 


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Highlighted
Routing

Re: Dynamic LSP using RSVP over IPV6 network

‎06-05-2019 05:55 AM

Thank you for the prompt reply. 

The RSVP Path message that goes out of our box is a IPV6 message and I have ospf3 enabled but not with the ipv4 realm. Osfp3 neighbor shows up and they are in state full. So I am not able to understand by juniper rejects the RSVP PATH message. It is the IPV6 layer that is different in that case vs the IPV4 above that they are both identical. 

The ospf3 seems to be exchanging all the ipv6 routes and I am able to ping the ipv6 addresses. This rejection seems very specific on support for RSVP IPV6 messages in the Juniper box. Is there any document that states that there is support or there is none. 

 

 

I have pasted the wireshark capture with the error pointer in the ICMP6 error reply and the original RSVP message in IPV6 format.

wiresharkRsvpIPV6Error.pngwiresharkRsvpIPV6PathMessage.png

 

Thanks,

Ram

 

Highlighted
Routing
Solution
Accepted by Jeremiah (Trusted Contributor)
‎06-17-2019 07:33 AM

Re: Dynamic LSP using RSVP over IPV6 network

‎06-05-2019 06:29 AM

Hello Ram,

 

RSVP over IPv6 doesn't seem supported by JUNOS yet.

If you check MPLS Applications Feature Guide, you'll see a separate section LDP Native IPv6 Support Overview section. But there is nothing about RSVP over IPv6. Unfortunately, there seems to be no documentation on juniper.net site where it's stated clearly, but I'm afraid it's so.

 

HTH


Best regards,
Sergii
-------------------------------------------------------------------
Please accept the solution if your problem is resolved Smiley Happy
-------------------------------------------------------------------

Highlighted
Routing

Re: Dynamic LSP using RSVP over IPV6 network

‎06-07-2019 05:07 AM
Thank you very much Sergii. I was hoping that was not the case :-). I would guess LDP would the be the only alternative for Dynamic LSP setup over a IPV6 native network. Ram
Highlighted
Routing

Re: Dynamic LSP using RSVP over IPV6 network

‎06-07-2019 12:58 PM
You're very welcome! Agree - LDP is the only option for this scenario at the moment. Best regards, Sergii ------------------------------------------------------------------- Please accept the solution if your problem is resolved Smiley Happy -------------------------------------------------------------------
Highlighted
Routing

Re: Dynamic LSP using RSVP over IPV6 network

‎06-10-2019 04:45 AM
I am not able to click on Accept Solution. Once I click it, it says page not found. Not sure if any maintenance is being done. But I do accept this as a solution. Thanks, Ram
Highlighted
Routing

Re: Dynamic LSP using RSVP over IPV6 network

‎06-10-2019 06:34 AM
Hey there! Yep, unfortunately J-Net is experiencing technical difficulties at the moment. I sent out a Community Talk post alerting the community yesterday (https://forums.juniper.net/t5/BLOG-Community-Talk/If-you-ve-noticed-that-J-Net-has-been-acting-weird...) We apologize for the inconvenience and we are working hard to fix this! In the meantime, I'll take note of this and will accept the solution on your behalf as soon as I can. - Jeremiah, J-Net Community Manager
Jeremiah
J-Net Community Manager
Highlighted
Routing

Re: Dynamic LSP using RSVP over IPV6 network

[ Edited ]
‎06-10-2019 10:38 AM

Hi @r.krishnan , @Sergii 

 

*UPDATE* I've went ahead and accepted @Sergii response as a solution. Thanks again to you both, and let's continue to engage and help out our fellow peers moving forward! Smiley Happy

 

Please note that J-Net is back and running as normal. Please feel free to accept the reply that answered the OP question.

 

Jeremiah

J-Net Community Manager

Jeremiah
J-Net Community Manager
Feedback