Routing
Highlighted
Routing

EX4300, load-balancing, per-packet

‎01-17-2014 09:47 AM

Hi,

 

i am not sure, if i right in "routing", or "switching" forum. But i hope it is here 😉

 

The both MX-Router announce over ospf to the EX-VC each a default-route.

What i want is, that load-balance per-packet is used on the EX, so both MX-Router will be used.

 

I have currently configured:

 

routing-options {
    nonstop-routing;
    forwarding-table {
        export load-balance;
    }
}

policy-options {
    policy-statement load-balance {
        then {
            load-balance per-packet;
        }
    }
}

 

At the first moment, it looks like good:

 

ex4300> show route 8.8.8.8                                          

inet.0: 14 destinations, 14 routes (14 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0.0.0.0/0          *[OSPF/150] 1d 17:47:08, metric 10, tag 0
                    > to x.x.x.x via xe-0/2/0.0
                      to x.x.x.x via xe-1/2/0.0

 

ex4300> show route forwarding-table destination 8.8.8.8          
Routing table: default.inet
Internet:
Destination        Type RtRef Next hop           Type Index NhRef Netif
default            user     0                    ulst 131070     3
                              xx:xx:xx:xx:xx:xx   ucst  1453     2 xe-0/2/0.0
                              xx:xx:xx:xx:xx:xx   ucst  1458     2 xe-1/2/0.0
default            perm     0                    rjct    36     1

Routing table: default-switch.inet
Internet:
Destination        Type RtRef Next hop           Type Index NhRef Netif
default            perm     0                    rjct  1353     1

Routing table: __master.anon__.inet
Internet:
Destination        Type RtRef Next hop           Type Index NhRef Netif
default            perm     0                    rjct  1373     1

{master:0}
ex4300>

 

But if i make some tests and show "monitor interface ...", servers how are connected to EX4300-RE0 will use "xe-0/2/0" and servers are connected to EX4300-RE1 will be use "xe-1/2/0".

 

if have also tested with and without, but the same result:

 

forwarding-options {
    hash-key {
        family inet {
            layer-3;
            layer-4;
        }
    }
}

 

Is there anywhere a config-failure, or a misstake?

 

Thanks for your help!

 

Regards,

Thomas

Attachments

1 REPLY 1
Highlighted
Routing

Re: EX4300, load-balancing, per-packet

[ Edited ]
‎01-22-2014 05:54 PM

Are you changing the source and destination in your tests? Try running tracerout to different destinations multiple times each and change the source addresses also. You should see over a period of time, the changes. It will not be perfect round-robin, but per-flow. this is what contribute to the improvement in applications requiring low latency. When you run the monitor traffic interface, are you not noticing the output packets roughly close over a period of time?

 

Can you provide the output of these commands ?


> show pfe route ip prefix x.x.x.x/24 detail
> show interfaces xe-0/2/0.0 | match rate
> show interfaces xe-1/2/0.0 | match rate
> monitor interface traffic (just the sections for these two interfaces)

[KUDOS PLEASE! If you think I earned it!
If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]
Feedback