Routing
Routing

EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

‎12-17-2019 05:47 AM

Hello everyone!

We`re having issues with EX4600 switch which we`re testing right now(so i dont have jtac support as this device is for testing right now).

The problem is when we got interface configured with 3 different encapsulations like this:

show interfaces xe-0/0/0
flexible-vlan-tagging;
mtu 9000;
encapsulation flexible-ethernet-services;
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members VLAN1;
        }
    }
}
unit 2 {
    vlan-id 2;
    family inet {
        address 172.18.1.3/31;
    }
    family mpls;
}
unit 11 {
    encapsulation vlan-ccc;
    vlan-id 11;
}

unit 11 used for l2circuit

When l2circuit comes up unit 0 starts to drop all incoming traffic. Workaround for get back unit 0 working is to delete unit 0 commit config and then do rollback. This issue happens on all version of junos for EX4600 that i`ve tried: 19.1, 18.4,17.4.

Have anyone seen issue like this? 

10 REPLIES 10
Routing
Solution
Accepted by topic author smelnik
3 weeks ago

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

[ Edited ]
‎12-17-2019 06:39 AM

Hi smelnik,

 

There's an issue fixed on these lines, what's the Junos version on the EX? Please use the JTAC recommended release or one of the following and confirm if that resolves.

17.2R3
18.1R1
17.3R3
17.4R2
18.1R1
17.2R3
17.3R3
17.4R2
18.1X75-D10
18.1X75-D10
16.1R7
15.1R7
16.1R7
14.1X53-D47
15.1X53-D233
15.1X53-D233
17.1R3
17.1R3

 

This should be documented as follows, I'll check and update this on a public link once you can confirm resolution:

The flexible-ethernet-services/vlan-bridge and vlan-ccc configuration will not work when both are configured together on all the QFX5k platforms and EX4600. Either one of them should be configured and not both.

 

set interfaces xe-0/0/18 encapsulation flexible-ethernet-services  (At physical link layer)

OR

set interfaces xe-0/0/18 encapsulation vlan-ccc

AND

set interfaces xe-0/0/18 unit x encapsulation vlan-bridge    (At logical link layer)

OR

set interfaces xe-0/0/18 unit x encapsulation vlan-ccc

 

It will not throw any commit check error or display a warning message.

 

Hope this helps.

 

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated Smiley Happy.

 

Routing

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

‎12-17-2019 08:41 AM

Hello mriyaz,

i`ve tried 18.1R1-S1 and 18.1R3-S8 and issue still exists:

 

show interfaces xe-0/0/0
flexible-vlan-tagging;
mtu 9000;
encapsulation flexible-ethernet-services;
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members VLAN1;
        }
    }
}
unit 2 {
    vlan-id 2;
    family inet {
        address 172.18.1.3/31;
    }
    family mpls;
}
unit 11 {
    encapsulation vlan-ccc;
    vlan-id 11;
}
show ethernet-switching table

MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static, C - Control MAC
           SE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)


Ethernet switching table : 1 entries, 1 learned
Routing instance : default-switch
    Vlan                MAC                 MAC         Age    Logical                NH        RTR
    name                address             flags              interface              Index     ID
    VLAN1          1c:9c:8c:2e:75:4b   D             -   xe-0/0/4.0             0         0

Routing

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

a month ago

What are all the encapsulation options you get for the units is there a straigt vlan option?

 

I would try removing unit 0 and instead if available, configuring another unit number using the vlan id of whatever is VLAN1 instead of port mode trunk and vlan member.

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Routing

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

a month ago

Hello spuluka,

smelnik@EX-172-18-1-253# set interfaces xe-0/0/0.0 encapsulation ?

smelnik@EX-172-18-1-253# set interfaces xe-0/0/0.0 encapsulation ?
Possible completions:
  dix                  Ethernet DIXv2 (RFC 894)
  vlan-bridge          VLAN layer-2 bridging
  vlan-ccc             802.1q tagging for a cross-connect
  vlan-vpls            VLAN virtual private LAN service

i`ve already tried setting unit !=0 for ethernet-switching unit, but that didnt helped.

 

Routing

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

a month ago

Hello smelnik

 

Can you try using a higher unit for family ethernet switching that goes below the rest of the units? i would like to check if the unit order has something to do with it.

 

for i.e: 

set interfaces xe-0/0/0.100 family ethernet-switching.... 

 

Let me know how it goes.


Thank you, 
Franky

Routing

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

4 weeks ago

Hi FrankyRko,

i`ve already tried using unit with ethernet switching as last unit on interface, but that didn`t changed situation - agter l2circuit is up ethernet-switching is broken.

Routing

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

4 weeks ago

Hi smelnik


Thanks for confirming, 

 

I'm wondering if this has something to do with it, but it sounds very close to me.

 

https://www.juniper.net/documentation/en_US/junos/topics/reference/general/mpls-limitations-qfx-seri...

 

(QFX5100, QFX5110, QFX5120, QFX5200, QFX5210, EX4600) When VLAN bridge encapsulation is enabled on a CE connected interface, the switch drops packets if both flexible Ethernet services and VLAN CCC encapsulations are configured on the same logical interface. Only one can be configured, not both. For example:

set interfaces xe-0/0/18 encapsulation flexible-ethernet-services, or set interfaces xe-0/0/18 encapsulation vlan-ccc.

Routing

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

3 weeks ago

Looks like it wont work Smiley Sad

I was mislead by the fact that when you recreate unit with ethernet-switching everything is working until reboot.

Well, looks like it is potentially working, but not on current junos version.

Routing

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

3 weeks ago

Try removing unit 0 and add a new unit using vlan-bridge and the vlan id directly using this method for the trunk unit.

 

https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/layer-2-services-bridge-...

 

Steve Puluka BSEET - Juniper Ambassador
IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
http://puluka.com/home
Routing

Re: EX4600: problems with traffic drop on unit with eth-switching when multiple encapsulations are enabled on interface

a week ago

Hello.

There is no encapsulation vlan-bridge and bridge-domains on EX switches.