Routing
Routing

Hight CPU usage on MX series (ipopt processes)

‎11-09-2014 10:49 AM

Hi,

 

There is a problem on MX-80, 13.3R3.6. 

MX works as a BRAS with dynamic-subscriber management and MS-MIC for NAT translation.

 

> show subscribers summary 

Subscribers by State
   Configured: 3
   Active: 966
   Total: 969

Subscribers by Client Type
   DHCP: 969
   Total: 969

 

> show services nat mappings summary 

Service Interface:                                          ms-0/2/0  
Total number of address mappings:                           827       

> show services sessions count 
Interface   Service set                                          Sessions count
ms-0/2/0    NAT-SERVICE-SET                                               52080

 

Here is the problem:

 

> show chassis routing-engine 
Routing Engine status:
    Temperature                 47 degrees C / 116 degrees F
    CPU temperature             59 degrees C / 138 degrees F
    DRAM                      2048 MB (2048 MB installed)
    Memory utilization          66 percent
    CPU utilization:
      User                      21 percent
      Background                 0 percent
      Kernel                    13 percent
      Interrupt                 55 percent
      Idle                      10 percent
    Model                          RE-MX80

Most load process:

 

> show system processes extensive       
last pid: 36069;  load averages:  1.50,  2.64,  4.17  up 45+18:23:42    20:44:31
186 processes: 9 running, 151 sleeping, 26 waiting

Mem: 875M Active, 133M Inact, 272M Wired, 431M Cache, 112M Buf, 272M Free
Swap: 2821M Total, 2821M Free


  PID USERNAME  THR PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
   38 root        1 -36 -155     0K    16K WAIT   480:59 34.86% swi3: ipopt ip6opt
   10 root        1 171   52     0K    16K RUN    837.9H 14.89% idle
   11 root        1 -40 -159     0K    16K WAIT    25.7H  6.84% swi2: netisr 0
 1556 root        1 127    0 28648K 19364K select 369:11  5.66% snmpd
   27 root        1 -68 -187     0K    16K RUN    548:00  5.52% irq36: tsec1
 1448 root        1 127    0 62316K 42692K RUN    376:37  5.47% mib2d
 1358 root       11  99    0 19688K 10284K ucond   79.0H  5.03% clksyncd
 1148 root        1 112    0 15392K  8868K RUN    161:34  2.98% eventd
   26 root        1 -68 -187     0K    16K WAIT   224:37  1.07% irq35: tsec1
 1343 root        1  98    0   128M 18676K select 146:22  0.10% chassisd

 

 

Not the first time I observe this problem. Вoes anyone know what this process swi3: ipopt ip6opt?

3 REPLIES 3
Routing

Re: Hight CPU usage on MX series (ipopt processes)

‎11-10-2014 02:15 AM

Сomrades, have ideas?

Routing

Re: Hight CPU usage on MX series (ipopt processes)

‎12-08-2014 10:36 AM

show pfe statistics traffic

 

Highlighted
Routing

Re: Hight CPU usage on MX series (ipopt processes)

‎01-18-2015 12:57 PM

Updated to the new firmware is stable 14.1R2.12.

Thank for reply.