Routing
Routing

How-To: Build a service provider network with a single Juniper Networks box--Part 2 #L3-VPN With Route Reflector

by Super Contributor on ‎03-21-2017 11:22 AM - edited a month ago by Administrator Administrator
03.21.17   |   11:22 AM

Hi Folks,
This paper is in continuation of my series of articles starting with the title "How-To: Build a service provider network with a single Juniper Networks box". The theme for this series is “ALL IN ONE BOX”; It helps you in building service provider networks with multiple rich features like IPv6 [6PE,6VPE], multicast, L2VPN, L3VPN, INTER-AS VPN [OPTION A,B,C], etc. with the help of a single Juniper box! All you need is a single box with couple of physical loop cables or lt [logical tunnel] interfaces.

 

You can also use a virtual vMX box deployed in ESXi or KVM with a virtual loop!

 

Topology Covered in this Article:
Earlier, I helped you to build and understand a MPLS L3VPN topology with IGP as OSPF and RSVP LSP for MPLS. We configured direct MP-iBGP peering between the PE routers. However the challenge with this topology is the complexity and operations overload increases with the count of Provider Edge routers. Since, IBGP does not readvertise updates to other IBGP-enabled devices and we end up creating individual MP-iBGP sessions between each devices to create a fully meshed topology. Route-Reflectors can be used to address this requirement and reduce overload on Provide edge routers.

 

Today, I would love to introduce the route-reflectors in my topology. Because of the internal BGP (IBGP) full-mesh requirement, we do introduce route reflectors to simplify configuration. The formula to compute the number of sessions required for a full mesh is v * (v - 1)/2, where v is the number of BGP-enabled devices. The full-mesh model does not scale well. Using a route reflector, you group routers into clusters, which are identified by numeric identifiers unique to the autonomous system (AS). Within the cluster, you must configure a BGP session from a single router (the route reflector) to each internal peer. With this configuration, the IBGP full-mesh requirement is met.

 

Requirement:
Operating system: Junos OS Release 9.3 or higher
Box: EX Series, M Series, MX Series, PTX Series, T Series [any box that supports logical systems]
Interconnecting the logical systems can be achieved with lt interface [logical tunnel] or with physical interfaces.
Interfaces Supported: Ethernet Interfaces ge/xe that supports 802.1Q VLAN

 

I will start with a single physical loop cable with multiple VLANs for each subunit.

 

 

            +----------+
            |          |<-Loop Cable
            |          |
    +------+++--------+++--------+
    |      +-+        +-+        |
    | Interface 1  Interface 2   |
    |                            |
    |                            |
    |   One Physical             |
    |   EX, M, MX, PTX, T Series |
    |                            |
    +----------------------------+
 


Steps:
Loop two physical interfaces in the box.
Copy the following configuration template to a word editor and replace the string interface1/interface2 with the actual interfaces you have looped.
Load the configuration to the box with “load merge terminal relative”.

Topology:
This is a MPLS L3VPN topology with IGP as OSPF and RSVP LSP for MPLS. There are MP-iBGP peering between r1/r5 [PE] to r4 [RR]. The PE-CE protocol is EBGP. The route reflector does not change the next hop attribute of a reflected prefix.

 

 

+---------------------------+----------------------------------------------------+--------------+
|  r0 lo0.100 192.168.1.100 |                                                    | MPLS CLOUD   |
|  r1 lo0.101 192.168.1.101 |                   RR                               | IGP-OSPF     |
|  r2 lo0.102 192.168.1.102 |                +-----+                             | MPLS-RSVP-LSP|
|  r3 lo0.103 192.168.1.103 |           I2.24| R4  | I1.43                       +--------------+
|  r4 lo0.104 192.168.1.104 |           +----+ P3  +----+                                       |
|  r5 lo0.105 192.168.1.105 |           |    +-----+    |                                       |
|  r6 lo0.106 192.168.1.106 |           |               |                                       |
+---------------------------+           |    AS 100     |                                       |
|        <----ebgp----->                |               |               <-----ebgp----->        |
|                                 I1.24 |               | I2.43                                 |
|    +-----+I1.1     +-----+         +--+--+I1.23    +--+--+         +-----+I1.56    +-----+    |
|    | R0  +---------+ R1  |I1.12    | R2  +---------+ R3  |I1.35    | R5  +---------+ R6  |    |
|    | CE1 |     I2.1| PE1 +---------+ P1  |         | P2  +---------+ PE2 |    I2.56| CE2 |    |
|    +-----+         +-----+    I2.12+-----+    I2.23+-----+    I2.35+-----+         +-----+    |
|   AS 64512                                                                         AS 64512   |
|                                                                                               |
|                                                                                               |
+-----------------------------------------------------------------------------------------------+
|    Template  -  MPLS L3VPN - IGP-OSPF # MPLS RSVP LSP # PE-CE Protocol BGP  # SINGLE RR       |
+-----------------------------------------------------------------------------------------------+

 

 

Configuration:

 

 

logical-systems {
    r0 {
        interfaces {
            interface1 {
                unit 1 {
                    vlan-id 1;
                    family inet {
                        address 1.1.1.1/30;
                    }
                    family mpls;
                }
            }
            lo0 {
                unit 100 {
                    family inet {
                        address 192.168.1.100/32;
                    }
                }
            }
        }
        protocols {
            bgp {
                export connected_to_bgp;
                group PE_PEERING {
                    neighbor 1.1.1.2 {
                        local-address 1.1.1.1;
                        peer-as 100;
                    }
                }
            }
        }
        policy-options {
            policy-statement connected_to_bgp {
                from protocol direct;
                then accept;
            }
        }
        routing-options {
            autonomous-system 64512;
        }
    }
    r1 {
        interfaces {
            interface1 {
                unit 12 {
                    vlan-id 12;
                    family inet {
                        address 1.1.12.1/30;
                    }
                    family mpls;
                }
            }
            interface2 {
                unit 1 {
                    vlan-id 1;
                    family inet {
                        address 1.1.1.2/30;
                    }
                    family mpls;
                }
            }
            lo0 {
                unit 101 {
                    family inet {
                        address 192.168.1.101/32;
                    }
                }
            }
        }
        protocols {
            rsvp {
                interface interface1.12;
            }
            mpls {
                label-switched-path r1-to-r5 {
                    to 192.168.1.105;
                }
                label-switched-path r1-to-r4 {
                    to 192.168.1.104;
                }
                interface interface1.12;
            }
            bgp {
                group ibgp-to-rr {
                    type internal;
                    local-address 192.168.1.101;
                    family inet-vpn {
                        unicast;
                    }
                    family l2vpn {
                        signaling;
                    }
                    family inet-mvpn {
                        signaling;
                    }
                    neighbor 192.168.1.104;
                }
            }
            ospf {
                traffic-engineering;
                area 0.0.0.0 {
                    interface lo0.101;
                    interface interface1.12;
                }
            }
        }
        routing-instances {
            vpna {
                instance-type vrf;
                interface interface2.1;
                route-distinguisher 100:11111;
                vrf-target target:100:111111;
                protocols {
                    bgp {
                        group vpna {
                            neighbor 1.1.1.1 {
                                local-address 1.1.1.2;
                                peer-as 64512;
                                as-override;
                            }
                        }
                    }
                }
            }
        }
        routing-options {
            autonomous-system 100;
        }
    }
    r2 {
        interfaces {
            interface1 {
                unit 23 {
                    vlan-id 23;
                    family inet {
                        address 1.1.23.1/30;
                    }
                    family mpls;
                }
                unit 24 {
                    vlan-id 24;
                    family inet {
                        address 1.1.24.1/30;
                    }
                    family mpls;
                }
            }
            interface2 {
                unit 12 {
                    vlan-id 12;
                    family inet {
                        address 1.1.12.2/30;
                    }
                    family mpls;
                }
            }
            lo0 {
                unit 102 {
                    family inet {
                        address 192.168.1.102/32;
                    }
                }
            }
        }
        protocols {
            rsvp {
                interface interface2.12;
                interface interface1.23;
                interface interface1.24;
            }
            mpls {
                interface interface2.12;
                interface interface1.23;
                interface interface1.24;
            }
            ospf {
                traffic-engineering;
                area 0.0.0.0 {
                    interface interface2.12;
                    interface lo0.102;
                    interface interface1.23;
                    interface interface1.24;
                }
            }
        }
    }
    r3 {
        interfaces {
            interface1 {
                unit 35 {
                    vlan-id 35;
                    family inet {
                        address 1.1.35.1/30;
                    }
                    family mpls;
                }
            }
            interface2 {
                unit 23 {
                    vlan-id 23;
                    family inet {
                        address 1.1.23.2/30;
                    }
                    family mpls;
                }
                unit 43 {
                    vlan-id 43;
                    family inet {
                        address 1.1.43.2/30;
                    }
                    family mpls;
                }
            }
            lo0 {
                unit 103 {
                    family inet {
                        address 192.168.1.103/32;
                    }
                }
            }
        }
        protocols {
            rsvp {
                interface interface2.23;
                interface interface2.43;
                interface interface1.35;
            }
            mpls {
                interface interface2.23;
                interface interface2.43;
                interface interface1.35;
            }
            ospf {
                traffic-engineering;
                area 0.0.0.0 {
                    interface interface2.23;
                    interface lo0.103;
                    interface interface2.43;
                    interface interface1.35;
                }
            }
        }
    }
    r4 {
        interfaces {
            interface1 {
                unit 43 {
                    vlan-id 43;
                    family inet {
                        address 1.1.43.1/30;
                    }
                    family mpls;
                }
            }
            interface2 {
                unit 24 {
                    vlan-id 24;
                    family inet {
                        address 1.1.24.2/30;
                    }
                    family mpls;
                }
            }
            lo0 {
                unit 104 {
                    family inet {
                        address 192.168.1.104/32;
                    }
                }
            }
        }
        protocols {
            rsvp {
                interface interface2.24;
                interface interface1.43;
            }
            mpls {
                label-switched-path r4-to-r1 {
                    to 192.168.1.101;
                }
                label-switched-path r4-to-r5 {
                    to 192.168.1.105;
                }
                interface interface2.24;
                interface interface1.43;
            }
            bgp {
                group ibgp-to-rr_client {
                    type internal;
                    local-address 192.168.1.104;
                    family inet-vpn {
                        unicast;
                    }
                    family l2vpn {
                        signaling;
                    }
                    family inet-mvpn {
                        signaling;
                    }
                    cluster 192.168.1.104;
                    neighbor 192.168.1.101;
                    neighbor 192.168.1.105;
                }
            }
            ospf {
                traffic-engineering;
                area 0.0.0.0 {
                    interface interface2.24;
                    interface lo0.104;
                    interface interface1.43;
                }
            }
        }
        routing-options {
            autonomous-system 100;
        }
    }
    r5 {
        interfaces {
            interface1 {
                unit 56 {
                    vlan-id 56;
                    family inet {
                        address 1.1.56.1/30;
                    }
                    family mpls;
                }
            }
            interface2 {
                unit 35 {
                    vlan-id 35;
                    family inet {
                        address 1.1.35.2/30;
                    }
                    family mpls;
                }
            }
            lo0 {
                unit 105 {
                    family inet {
                        address 192.168.1.105/32;
                    }
                }
            }
        }
        protocols {
            rsvp {
                interface interface2.35;
            }
            mpls {
                label-switched-path r5-to-r1 {
                    to 192.168.1.101;
                }
                label-switched-path r5-to-r4 {
                    to 192.168.1.104;
                }
                interface interface2.35;
            }
            bgp {
                group ibgp-to-rr {
                    type internal;
                    local-address 192.168.1.105;
                    family inet-vpn {
                        unicast;
                    }
                    family l2vpn {
                        signaling;
                    }
                    family inet-mvpn {
                        signaling;
                    }
                    neighbor 192.168.1.104;
                }
            }
            ospf {
                traffic-engineering;
                area 0.0.0.0 {
                    interface interface2.35;
                    interface lo0.105;
                }
            }
        }
        routing-instances {
            vpna {
                instance-type vrf;
                interface interface1.56;
                route-distinguisher 100:11111;
                vrf-target target:100:111111;
                protocols {
                    bgp {
                        group vpna {
                            neighbor 1.1.56.2 {
                                local-address 1.1.56.1;
                                peer-as 64512;
                                as-override;
                            }
                        }
                    }
                }
            }
        }
        routing-options {
            autonomous-system 100;
        }
    }
    r6 {
        interfaces {
            interface2 {
                unit 56 {
                    vlan-id 56;
                    family inet {
                        address 1.1.56.2/30;
                    }
                    family mpls;
                }
            }
            lo0 {
                unit 106 {
                    family inet {
                        address 192.168.1.106/32;
                    }
                }
            }
        }
        protocols {
            bgp {
                export connected_to_bgp;
                group PE_PEERING {
                    neighbor 1.1.56.1 {
                        local-address 1.1.56.2;
                        peer-as 100;
                    }
                }
            }
        }
        policy-options {
            policy-statement connected_to_bgp {
                from protocol direct;
                then accept;
            }
        }
        routing-options {
            autonomous-system 64512;
        }
    }
}
interfaces {
    interface1 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
    }
    interface2 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
    }
}

 

Troubleshooting Commands:

Sample Output:

Interface 1: ge-0/0/2

Interface 2: ge-0/0/3

 

To see all the ospf neighbors in the box from all logical-systems:

 

lab> show ospf neighbor logical-system all | no-more  
 
logical-system: r1
Address          Interface              State     ID               Pri  Dead
1.1.12.2         interface1.12            Full      192.168.1.102    128    37
-----
 
logical-system: r0
OSPF instance is not running
-----
 
logical-system: r5
1.1.35.1         interface2.35            Full      192.168.1.103    128    36
-----
 
logical-system: r3
1.1.35.2         interface1.35            Full      192.168.1.105    128    33
1.1.23.1         interface2.23            Full      192.168.1.102    128    33
1.1.43.1         interface2.43            Full      192.168.1.104    128    30
-----
 
logical-system: r2
1.1.23.2         interface1.23            Full      192.168.1.103    128    35
1.1.24.2         interface1.24            Full      192.168.1.104    128    35
1.1.12.1         interface2.12            Full      192.168.1.101    128    38
-----
 
logical-system: r6
OSPF instance is not running
-----
 
logical-system: r4
1.1.43.2         interface1.43            Full      192.168.1.103    128    39
1.1.24.1         interface2.24            Full      192.168.1.102    128    32
-----
 
logical-system: default
OSPF instance is not running

 

Few command Outputs from all logical-systems:

 

 

lab> show mpls lsp logical-system all | no-more 
 
logical-system: r1
Ingress LSP: 2 sessions
To              From            State Rt P     ActivePath       LSPname
192.168.1.104   192.168.1.101   Up     0 *                      r1-to-r4
192.168.1.105   192.168.1.101   Up     0 *                      r1-to-r5
Total 2 displayed, Up 2, Down 0

Egress LSP: 2 sessions
To              From            State   Rt Style Labelin Labelout LSPname 
192.168.1.101   192.168.1.104   Up       0  1 FF       3        - r4-to-r1
192.168.1.101   192.168.1.105   Up       0  1 FF       3        - r5-to-r1
Total 2 displayed, Up 2, Down 0

Transit LSP: 0 sessions
Total 0 displayed, Up 0, Down 0
-----
 
logical-system: r0
MPLS not configured
-----
 
logical-system: r5

Ingress LSP: 2 sessions
To              From            State Rt P     ActivePath       LSPname
192.168.1.101   192.168.1.105   Up     0 *                      r5-to-r1
192.168.1.104   192.168.1.105   Up     0 *                      r5-to-r4
Total 2 displayed, Up 2, Down 0

Egress LSP: 2 sessions
To              From            State   Rt Style Labelin Labelout LSPname 
192.168.1.105   192.168.1.104   Up       0  1 FF       3        - r4-to-r5
192.168.1.105   192.168.1.101   Up       0  1 FF       3        - r1-to-r5
Total 2 displayed, Up 2, Down 0

Transit LSP: 0 sessions
Total 0 displayed, Up 0, Down 0
-----
 
logical-system: r3

Ingress LSP: 0 sessions
Total 0 displayed, Up 0, Down 0

Egress LSP: 0 sessions
Total 0 displayed, Up 0, Down 0

Transit LSP: 4 sessions
To              From            State   Rt Style Labelin Labelout LSPname 
192.168.1.101   192.168.1.105   Up       0  1 FF  299824   299824 r5-to-r1
192.168.1.104   192.168.1.105   Up       0  1 FF  299792        3 r5-to-r4
192.168.1.105   192.168.1.104   Up       0  1 FF  299776        3 r4-to-r5
192.168.1.105   192.168.1.101   Up       0  1 FF  299808        3 r1-to-r5
Total 4 displayed, Up 4, Down 0
-----
 
logical-system: r2

Ingress LSP: 0 sessions
Total 0 displayed, Up 0, Down 0

Egress LSP: 0 sessions
Total 0 displayed, Up 0, Down 0

Transit LSP: 4 sessions
To              From            State   Rt Style Labelin Labelout LSPname 
192.168.1.101   192.168.1.104   Up       0  1 FF  299776        3 r4-to-r1
192.168.1.101   192.168.1.105   Up       0  1 FF  299824        3 r5-to-r1
192.168.1.104   192.168.1.101   Up       0  1 FF  299792        3 r1-to-r4
192.168.1.105   192.168.1.101   Up       0  1 FF  299808   299808 r1-to-r5
Total 4 displayed, Up 4, Down 0
-----
 
logical-system: r6
MPLS not configured
-----
 
logical-system: r4

Ingress LSP: 2 sessions
To              From            State Rt P     ActivePath       LSPname
192.168.1.101   192.168.1.104   Up     0 *                      r4-to-r1
192.168.1.105   192.168.1.104   Up     0 *                      r4-to-r5
Total 2 displayed, Up 2, Down 0

Egress LSP: 2 sessions
To              From            State   Rt Style Labelin Labelout LSPname 
192.168.1.104   192.168.1.105   Up       0  1 FF       3        - r5-to-r4
192.168.1.104   192.168.1.101   Up       0  1 FF       3        - r1-to-r4
Total 2 displayed, Up 2, Down 0

Transit LSP: 0 sessions
Total 0 displayed, Up 0, Down 0
-----
 
logical-system: default
MPLS not configured

lab> set cli logical-system r1 
Logical system: r1

lab:r1> show route summary
Autonomous system number: 100
Router ID: 192.168.1.101

inet.0: 12 destinations, 12 routes (12 active, 0 holddown, 0 hidden)
Direct: 2 routes, 2 active
Local: 1 routes, 1 active
OSPF: 9 routes, 9 active

inet.3: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
RSVP: 2 routes, 2 active

vpna.inet.0: 5 destinations, 6 routes (5 active, 0 holddown, 0 hidden)
Direct: 1 routes, 1 active
Local: 1 routes, 1 active
BGP: 4 routes, 3 active

mpls.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
MPLS: 4 routes, 4 active
VPN: 1 routes, 1 active

bgp.l3vpn.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
BGP: 2 routes, 2 active

The Provider Edge boxes r1 and r5 are peering with r4 the route reflector:

lab:r1> show bgp summary
Groups: 2 Peers: 2 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0
2 2 0 0 0 0
bgp.l2vpn.0
0 0 0 0 0 0
bgp.mvpn.0
0 0 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
1.1.1.1 64512 227 225 0 0 1:40:53 Establ
vpna.inet.0: 1/2/2/0
192.168.1.104 100 229 221 0 0 1:39:45 Establ
bgp.l3vpn.0: 2/2/2/0
bgp.l2vpn.0: 0/0/0/0
bgp.mvpn.0: 0/0/0/0
vpna.inet.0: 2/2/2/0

lab:r1> show route 192.168.1.105

inet.0: 12 destinations, 12 routes (12 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

192.168.1.105/32 *[OSPF/10] 01:35:17, metric 4
> to 1.1.12.2 via interface1.12

inet.3: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

192.168.1.105/32 *[RSVP/7/1] 01:35:12, metric 4
> to 1.1.12.2 via interface1.12, label-switched-path r1-to-r5

lab:r1> show route forwarding-table destination 192.168.1.105
Logical system: r1
Routing table: default.inet
Internet:
Destination Type RtRef Next hop Type Index NhRef Netif
192.168.1.105/32 user 0 1.1.12.2 ucst 1069 12 interface1.12

Logical system: r1
Routing table: __master.anon__.inet
Internet:
Destination Type RtRef Next hop Type Index NhRef Netif
default perm 0 rjct 800 1

Logical system: r1
Routing table: vpna.inet
Internet:
Destination Type RtRef Next hop Type Index NhRef Netif
default perm 0 rjct 809 1

lab:r1> show route table inet.3

inet.3: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

192.168.1.104/32 *[RSVP/7/1] 02:40:57, metric 2
> to 1.1.12.2 via interface1.12, label-switched-path r1-to-r4
192.168.1.105/32 *[RSVP/7/1] 01:35:22, metric 4
> to 1.1.12.2 via interface1.12, label-switched-path r1-to-r5

lab:r1>

To see routes received from the route reflector:
lab:r1> show route receive-protocol bgp 192.168.1.104

inet.0: 12 destinations, 12 routes (12 active, 0 holddown, 0 hidden)

inet.3: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)

vpna.inet.0: 5 destinations, 6 routes (5 active, 0 holddown, 0 hidden)
Prefix Nexthop MED Lclpref AS path
* 1.1.56.0/30 192.168.1.105 100 I
* 192.168.1.106/32 192.168.1.105 100 64512 I

mpls.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)

bgp.l3vpn.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
Prefix Nexthop MED Lclpref AS path
100:11111:1.1.56.0/30
* 192.168.1.105 100 I
100:11111:192.168.1.106/32
* 192.168.1.105 100 64512 I

To see all routes advertising to the route reflector:
lab:r1> show route advertising-protocol bgp 192.168.1.104

vpna.inet.0: 5 destinations, 6 routes (5 active, 0 holddown, 0 hidden)
Prefix Nexthop MED Lclpref AS path
* 1.1.1.0/30 Self 100 I
* 192.168.1.100/32 Self 100 64512 I

From the Route Reflector End:
lab:r1> set cli logical-system r4
Logical system: r4

lab:r4> show bgp summary
Groups: 1 Peers: 2 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0
4 4 0 0 0 0
bgp.l2vpn.0
0 0 0 0 0 0
bgp.mvpn.0
0 0 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
192.168.1.101 100 230 224 0 0 1:41:04 Establ
bgp.l3vpn.0: 2/2/2/0
bgp.l2vpn.0: 0/0/0/0
bgp.mvpn.0: 0/0/0/0
192.168.1.105 100 231 223 0 0 1:41:02 Establ
bgp.l3vpn.0: 2/2/2/0
bgp.l2vpn.0: 0/0/0/0
bgp.mvpn.0: 0/0/0/0

The routes received from the PE box r1 in the Route reflector:
lab:r4> show route receive-protocol bgp 192.168.1.101

inet.0: 13 destinations, 13 routes (13 active, 0 holddown, 0 hidden)

inet.3: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)

mpls.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)

bgp.l3vpn.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
Prefix Nexthop MED Lclpref AS path
100:11111:1.1.1.0/30
* 192.168.1.101 100 I
100:11111:192.168.1.100/32
* 192.168.1.101 100 64512 I

The route reflector does not change the next hop attribute of a reflected prefix.

lab:r4> show route receive-protocol bgp 192.168.1.101 extensive

inet.0: 13 destinations, 13 routes (13 active, 0 holddown, 0 hidden)

inet.3: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)

mpls.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)

bgp.l3vpn.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
* 100:11111:1.1.1.0/30 (1 entry, 1 announced)
Accepted
Route Distinguisher: 100:11111
VPN Label: 299776
Nexthop: 192.168.1.101
Localpref: 100
AS path: I
Communities: target:100:111111

* 100:11111:192.168.1.100/32 (1 entry, 1 announced)
Accepted
Route Distinguisher: 100:11111
VPN Label: 299776
Nexthop: 192.168.1.101
Localpref: 100
AS path: 64512 I
Communities: target:100:111111

The routes advertised from the RR box to r5 in the Route reflector:
lab:r4> show route advertising-protocol bgp 192.168.1.105 extensive

bgp.l3vpn.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
* 100:11111:1.1.1.0/30 (1 entry, 1 announced)
BGP group ibgp-to-rr_client type Internal
Route Distinguisher: 100:11111
VPN Label: 299776
Nexthop: 192.168.1.101
Localpref: 100
AS path: [100] I
Communities: target:100:111111
Cluster ID: 192.168.1.104
Originator ID: 192.168.1.101

* 100:11111:192.168.1.100/32 (1 entry, 1 announced)
BGP group ibgp-to-rr_client type Internal
Route Distinguisher: 100:11111
VPN Label: 299776
Nexthop: 192.168.1.101
Localpref: 100
AS path: [100] 64512 I
Communities: target:100:111111
Cluster ID: 192.168.1.104
Originator ID: 192.168.1.101

lab:r4> show route advertising-protocol bgp 192.168.1.105

bgp.l3vpn.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
Prefix Nexthop MED Lclpref AS path
100:11111:1.1.1.0/30
* 192.168.1.101 100 I
100:11111:192.168.1.100/32
* 192.168.1.101 100 64512 I

From the remote end Provider Edge box r5:
lab:r5> show route instance vpna
Instance Type
Primary RIB Active/holddown/hidden
vpna vrf
vpna.inet.0 5/0/0

lab:r5> show route table vpna 1.1.1.0

vpna.inet.0: 5 destinations, 6 routes (5 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.0/30 *[BGP/170] 01:43:56, localpref 100, from 192.168.1.104
AS path: I, validation-state: unverified
> to 1.1.35.1 via interface2.35, label-switched-path r5-to-r1


lab:r5> show route table vpna 1.1.1.0 extensive

vpna.inet.0: 5 destinations, 6 routes (5 active, 0 holddown, 0 hidden)
1.1.1.0/30 (1 entry, 1 announced)
TSI:
KRT in-kernel 1.1.1.0/30 -> {indirect(1048575)}
Page 0 idx 0, (group vpna type External) Type 1 val 0x3dfc4ac (adv_entry)
Advertised metrics:
Nexthop: Self
AS path: [100] I
Communities: target:100:111111
Path 1.1.1.0 from 192.168.1.104 Vector len 4. Val: 0
*BGP Preference: 170/-101
Route Distinguisher: 100:11111
Next hop type: Indirect, Next hop index: 0
Address: 0x54916f0
Next-hop reference count: 6
Source: 192.168.1.104
Next hop type: Router, Next hop index: 1088
Next hop: 1.1.35.1 via interface2.35, selected
Label-switched-path r5-to-r1
Label operation: Push 299776, Push 299824(top)
Label TTL action: prop-ttl, prop-ttl(top)
Load balance label: Label 299776: None; Label 299824: None;
Label element ptr: 0x5491620
Label parent element ptr: 0x5491500
Label element references: 1
Label element child references: 0
Label element lsp id: 0
Session Id: 0x14a
Protocol next hop: 192.168.1.101
Label operation: Push 299776
Label TTL action: prop-ttl
Load balance label: Label 299776: None;
Indirect next hop: 0x3ec8b80 1048575 INH Session ID: 0x151
State: <Secondary Active Int Ext ProtectionCand>
Local AS: 100 Peer AS: 100
Age: 1:43:58 Metric2: 3
Validation State: unverified
Task: BGP_100.192.168.1.104
Announcement bits (2): 0-KRT 1-BGP_RT_Background
AS path: I (Originator)
Cluster list: 192.168.1.104
Originator ID: 192.168.1.101
Communities: target:100:111111
Import Accepted
VPN Label: 299776
Localpref: 100
Router ID: 192.168.1.104
Primary Routing Table bgp.l3vpn.0
Indirect next hops: 1
Protocol next hop: 192.168.1.101 Metric: 3
Label operation: Push 299776
Label TTL action: prop-ttl
Load balance label: Label 299776: None;
Indirect next hop: 0x3ec8b80 1048575 INH Session ID: 0x151
Indirect path forwarding next hops: 1
Next hop type: Router
Next hop: 1.1.35.1 via interface2.35
Session Id: 0x14a
192.168.1.101/32 Originating RIB: inet.3
Metric: 3 Node path count: 1
Forwarding nexthops: 1
Nexthop: 1.1.35.1 via interface2.35

lab:r5>


 

Few Command Lists For Troubleshooting/Isolation/Understanding:

Global Instance:
show ospf neighbor logical-system all | no-more
show mpls lsp logical-system all | no-more

 

From Specific Logical Router R1 [PE]:
set cli logical-system r1
show route summary
show bgp summary
show route receive-protocol bgp 192.168.1.104
show route advertising-protocol bgp 192.168.1.104
show mpls lsp
show mpls lsp extensive
show route 192.168.1.105
show route forwarding-table destination 192.168.1.105
show route table inet.3

 

In RR:
show route receive-protocol bgp 192.168.1.101
show route receive-protocol bgp 192.168.1.101 extensive
show route advertising-protocol bgp 192.168.1.105

 

In Remote RE [r5]
show route table vpna 1.1.1.0
show route table vpna 1.1.1.0 extensive

 

From r1:
ping routing-instance vpna 1.1.56.1

 

To come back to global Instance:
clear cli logical-system

If my series helps you, feel free to click the "Kudos" icon.

-Python

'
Comments
04.29.17
rotciv50
Excellent lab setup!!
05.07.17
Super Contributor

Thanks Permalink! The next topology with VPLS is ready to be published shortly!

 

-rengar