Routing
Highlighted
Routing

I'm going to migrate CISCO's ATM CONFIG to JUNIPER.

‎01-05-2020 05:55 PM

Hello.

ATM CONFIG is new to me and I'd like to ask you a question.

The ATM module is MIC type and is as follows. (MIC-3D-8OC3-2OC12-ATM)

CISCO currently has the following CONFIG:

------------------------------------------------------------------------

interface ATM1/0/0

interface ATM1/0/0.1 point-to-point
mtu1500
bandwidth 20000
ip address 1.1.1.1 255.255.255.252
pvc 1/129
cbr20000
oam-pvc manage
encapsulation aal5snap


interface ATM1/0/0.5
mtu1500
bandwidth 512
ip address 2.1.1.1 255.255.255.252

pvc 1/118
vbr-nrt 512 512 1
oam-pvc 0
encapsulation aal5snap

 

The information I migrated to Juniper is as follows.

---------------------------------------------------------------

set chassis fpc 2 pic 0 framing sdh
set chassis fpc 2 pic 0 port 0 speed oc3-stm1

 

set interfaces at-2/0/0 hierarchical-scheduler
set interfaces at-2/0/0 atm-options vpi 1

 

set interfaces at-2/0/0 unit 1 encapsulation atm-snap
set interfaces at-2/0/0 unit 1 bandwidth 20m
set interfaces at-2/0/0 unit 1 vci 1.129
set interfaces at-2/0/0 unit 1 oam-period 60
set interfaces at-2/0/0 unit 1 oam-liveness up-count 3
set interfaces at-2/0/0 unit 1 oam-liveness down-count 3
set interfaces at-2/0/0 unit 1 family inet mtu 1500
set interfaces at-2/0/0 unit 1 family inet address 1.1.1.1/30

 

set class-of-service traffic-control-profiles 20M atm-service cbr
set class-of-service traffic-control-profiles 20M peak-rate 52084

set class-of-service interfaces at-2/0/0 unit 1 output-traffic-control-profile 20M

 

 

set interfaces at-2/0/0 unit 5 encapsulation atm-snap
set interfaces at-2/0/0 unit 5 bandwidth 512k
set interfaces at-2/0/0 unit 5 vci 1.118
set interfaces at-2/0/0 unit 5 oam-period disable
set interfaces at-2/0/0 unit 5 family inet mtu 1500
set interfaces at-2/0/0 unit 5 family inet address 2.1.1.1/30

 

set class-of-service traffic-control-profiles 512-512-1 atm-service nrtvbr
set class-of-service traffic-control-profiles 512-512-1 peak-rate 1334
set class-of-service traffic-control-profiles 512-512-1 sustained-rate 1334
set class-of-service traffic-control-profiles 512-512-1 max-burst-size 1

 

set class-of-service interfaces at-2/0/0 unit 5 output-traffic-control-profile 512-512-1

 


The problem is that it's hard to verify because you can't test it now.
Help me, experts!

Happy New Year.

 

 

 

 

 

 

1 REPLY 1
Highlighted
Routing

Re: I'm going to migrate CISCO's ATM CONFIG to JUNIPER.

‎01-14-2020 10:12 PM

Hi There,

I must say you have already done a pretty decent job of converting cisco config to Junos config. Please refer to following links for extensive configuraiton of ATM interfaces in JUNOS along with example:

 

https://www.juniper.net/documentation/en_US/junos/topics/concept/interfaces-atm-interfaces-overview....

https://www.juniper.net/documentation/en_US/junos/topics/example/interfaces-configuring-atm2-iq-inte...

https://www.juniper.net/documentation/en_US/junos/topics/example/interfaces-configuring-atm1-interfa...

 

Hope this helps.

Thanks

Hope this helps

--------------------------------------------------------------------------------------------------------
If this post was helpful, please mark this post as an "Accepted Solution".
Kudos are always appreciated!
--------------------------------------------------------------------------------------------------------
Feedback