Routing

last person joined: 3 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  IPv6 SLAAC Global Address Assignment over PPP using SRX300

    Posted 03-27-2018 04:29

    Hi all, 

     

    I'm currently attempting to configure an SRX300 as dual stack, using an FTTP connection. The IPv4 works fine, PPP authenticates and the LNS (Cisco ASR) assigns the addressing correctly.

     

    The issue I'm having is with IPv6 and the set up for using SLAAC to have a gateway assigned to the pp0.0 interface to route between the ASR and the SRX. The ASR has a /48 subnet for assigning /64s as auto config gateways and this works absolutely fine on Cisco devices. I've yet to get it working with an SRX. I've been unable to determine if there are any know issues with SLAAC on an SRX using a pp0 interface, so I'm assuming it does but let me know if otherwise.


    2a00:f18:19:9::/64 is the subnet I'm statically configuring on the LAN and there is a static route on the ASR installed when the PPP session comes up. Here's the configuration from my SRX, with unrelated config removed:

     

    version 15.1X49-D45;
    security {
        forwarding-options {
            family {
                inet6 {
                    mode flow-based;
                }
                mpls {
                    mode packet-based;
                }
            }
        }
    }
    interfaces {
        ge-0/0/0 {
            description LAN;
            mtu 9192;
            unit 0 {
                family inet {
                    mtu 1500;
                    address 192.168.0.1/24;
                }
                family inet6 {
                    address 2a00:f18:19:9::1/64;
                }
            }
        }
        ge-0/0/5 {
            description SUPPLIER;
            unit 0 {
                encapsulation ppp-over-ether;
            }
        }
        lo0 {
            unit 0 {
                family inet {
                    filter {
                        input management;
                    }
                }
                family inet6 {
                    address 2a00:f18:19:9::fffe/128;
                }
            }
        }
        pp0 {
            unit 0 {
                ppp-options {
                    chap {
                        default-chap-secret "[PPP-PASSWORD-OMITTED]"; ## SECRET-DATA
                        local-name "[PPP-USERNAME-OMITTED]";
                        passive;
                    }
                }
                pppoe-options {
                    underlying-interface ge-0/0/5.0;
                    idle-timeout 0;
                    auto-reconnect 3;
                    client;
                }
                family inet {
                    mtu 1492;
                    negotiate-address;
                }
                family inet6 {
                    mtu 1492;
                }
            }
        }
    }
    routing-options {
        rib inet6.0 {
            static {
                route 0::0/0 next-hop pp0.0;
            }
        }
        static {
            route 0.0.0.0/0 next-hop pp0.0;
        }
    }
    protocols {
        router-advertisement {
            interface pp0.0 {
                managed-configuration;
                prefix 2a00:f18:19:9::/64 {
                    no-autonomous;
                }
            }
        }
        neighbor-discovery;
    }

     

    Here's an output of the RA I'm getting from the ASR, which has selected 2a00:f18:4:18::/64 from its /48 pool:

     

    show ipv6 router-advertisement
    Interface: pp0.0
      Advertisements sent: 19, last sent 00:00:31 ago
      Solicits received: 0
      Advertisements received: 11
      Solicited router advertisement unicast: Disable
      Advertisement from fe80::72ca:9bff:fe74:e700, heard 01:34:55 ago
        Managed: 0 [1]
        Other configuration: 0
        Link MTU: 1492 bytes
        Reachable time: 0 ms
        Default lifetime: 1800 sec
        Retransmit timer: 0 ms
        Current hop limit: 64
        Prefix: 2a00:f18:4:18::/64
          Valid lifetime: 2592000 sec
          Preferred lifetime: 604800 sec
          On link: 1
          Autonomous: 1

     

    Thanks for looking, appreciate any pointers anyone is able to give. If any further information is required, please ask.

     



  • 2.  RE: IPv6 SLAAC Global Address Assignment over PPP using SRX300
    Best Answer

    Posted 05-02-2018 01:53

    As the SRX is routing, it needed to be set to packet based. Now working as desired.

     

    security {
        forwarding-options {
            family {
                inet6 {
                    mode packet-based;
                }
                mpls {
                    mode packet-based;
                }
            }
        }
    }