Routing
Routing

IPv6 vrrp not working

‎12-18-2019 07:49 AM

Hi There,

 

I am configuring IPv6 vrrp between mx960 and MLXe.

MLX vrrp master

mx960 Standby

Problem: the 2 ipv6 interfaces configured on mx960 and MLXe are able to ping each other.

As soon i cativate the vrrp than the ping does not work anymore.

Note: vrrp IPv4 just work fine between the MLXe and mx960.

What step do you suggest to make to investigate the problem on juniper ´s side?

Thnaks.

3 REPLIES 3
Highlighted
Routing

Re: IPv6 vrrp not working

‎12-18-2019 08:59 AM
Hello, I hope you have the "accpet-data" knob under the VRRP config to allow it to respond to ICMP traffic. Apart from VRRP config I hope you have the interface and prefix defined under "protocols router-advertisement" and "show ivp6 neighbors" is showing the MLX as neighbor. As usual, do check the firewall filter. Here is the configuration example for VRRPv6 https://www.juniper.net/documentation/en_US/junos/topics/example/vrrp-for-ipv6-example-config.html If this doesn't help send me the config, show ipv6 neighbor, show vrrp output to look into it. PS: Please accept my response as solution if it answers your query, kudos are appreciated too! Thanks Vishal
Highlighted
Routing

Re: IPv6 vrrp not working

‎12-20-2019 02:00 AM

Hello,

So

- router-advertisement already applied

set protocols router-advertisement interface ae16.0 virtual-router-only

 

- accept-data not applied yet but at the end it is useful only for pinging the VIP https://forums.juniper.net/t5/Ethernet-Switching/Accept-data-VRRP/td-p/265315 so should not interferee with normal vrrp process

 

- output:

show ipv6 neighbors

2a01:xxx:xxxx:xxx::4 00:00:5e:00:02:01 incomplete 0 no no ae16.0
fe80::1 00:00:5e:00:02:01 incomplete 0 no no ae16.0

 

show vrrp details

Physical interface: ae16, Unit: 0, Address: xxxx:xxx:xxx:xxx::5/124
Index: 339, SNMP ifIndex: 750, VRRP-Traps: enabled, VRRP-Version: 3
Interface state: up, Group: 1, State: master, VRRP Mode: Active
Priority: 100, Advertisement interval: 1, Authentication type: none
Advertisement threshold: 3, Computed send rate: 0
Preempt: yes, Accept-data mode: no, VIP count: 2, VIP: fe80::1, 2a01:xxx:xxx:xxx::4
Advertisement Timer: 0.575s, Master router: fe80::7e25:86ff:fe39:bc
Virtual router uptime: 2d 21:18, Master router uptime: 2d 21:18
Virtual Mac: 00:00:5e:00:02:01
Preferred: yes
Tracking: disabled

 

Thanks

 

 

Highlighted
Routing

Re: IPv6 vrrp not working

‎12-20-2019 08:17 AM
Hello, It seems like split brain situation. Your MX router is the showing as VRRP master and you have learned the VMAC from other router too but unfortunately its in incomplete state. In working scenario it should in reachable state. 2a01:xxx:xxxx:xxx::4 00:00:5e:00:02:01 incomplete 0 no no ae16.0 fe80::1 00:00:5e:00:02:01 incomplete 0 no no ae16.0 Its possible that packets are getting dropped Please initiate a ping from MX to other router and capture a tcpdump on ae16.0 to figure out what's going on monitor traffic interface ae16.0 no-resolve monitor traffic interface ae16.0 no-resolve matching icmp Its possible that either the device are misconfigured or packets are getting dropped in the middle. Please share you configuration from juniper router and share a topology diagram. Thanks Vishal
Feedback