Routing
Highlighted
Routing

IRB Interfaces and LAG load-balancing.

[ Edited ]
‎09-14-2018 03:32 AM

Hello.

 

Recently, we had some issues with load-balancing across LAG, but only if we used IRB's interfaces.
I'll try to explain, but i'm sorry for my English, it isn't native for me.

 

There is a MX480 connected to two l3 switches by 4-link LAG. OSPF, MPLS and LDP is configured on these interfaces. Then, we created vpls connections beetwen some physical interfaces on l3switches and MX, and the load-balancing is worked fine.

A two month ago, we configured IRB interfaces as the vpls routed interface,
and we had problem here - the traffic is sending by only one interface in the LAG bundle.

I tried to emulate this issue in the lab environment, and i noticed that vMX with Junos version 15.1Rx and above - worked correctly with IRB.


We had upgraded our MX480 last night from 13.3 to 15.1r6 (GTAC recommended version), but we still have this issue.

Can anyone help me with this?

 

A part of MX's configuration is below:

 

Spoiler
set interfaces xe-1/2/0 gigether-options 802.3ad ae9
set interfaces xe-1/2/1 gigether-options 802.3ad ae9
set interfaces xe-1/2/2 gigether-options 802.3ad ae9
set interfaces xe-1/2/3 gigether-options 802.3ad ae9

set interfaces ae9 description UPLINK-MPLS-CITY2
set interfaces ae9 vlan-tagging
set interfaces ae9 mtu 9000
set interfaces ae9 aggregated-ether-options lacp active
set interfaces ae9 aggregated-ether-options lacp periodic fast
set interfaces ae9 aggregated-ether-options lacp system-priority 100
set interfaces ae9 unit 3456 description CITY-MPLS
set interfaces ae9 unit 3456 vlan-id 3456
set interfaces ae9 unit 3456 family inet mtu 2000
set interfaces ae9 unit 3456 family inet address 10.101.249.21/30
set interfaces ae9 unit 3456 family mpls

set interfaces irb unit 8 description peering-city2
set interfaces irb unit 8 family inet address x.x.x.x/30

set protocols ospf area 0.0.0.0 interface ae9.3456
set protocols ldp interface ae9.3456
set protocols ldp interface lo0.0

set routing-instances peer-city2 instance-type vpls
set routing-instances peer-city2 vlan-id none
set routing-instances peer-city2 routing-interface irb.8
set routing-instances peer-city2 protocols vpls no-tunnel-services
set routing-instances peer-city2 protocols vpls vpls-id 3461
set routing-instances peer-city2 protocols vpls mtu 1550
set routing-instances peer-city2 protocols vpls neighbor 10.110.0.100


 

 

Regards,
Denis Seven,
JNCIA-Junos, Cloud
4 REPLIES
Routing

Re: IRB Interfaces and LAG load-balancing.

‎09-14-2018 07:49 AM

Hello,

Let's clarify some facts first, shall we?

1/ do You have MPC linecards in Your MX480, or DPC, or a mix of he two?

2/ do You see imbalance only for traffic going out of/into IRB, or for VPLS-switched traffic, or both?

3/ posting a diagram of the traffic flow in question would help a lot.

HTH

Thx

Alex

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Routing

Re: IRB Interfaces and LAG load-balancing.

[ Edited ]
‎09-16-2018 01:49 AM

Hello, Alex.

 

1. We've MPC linecards only. 

2.  Only for IRB interfaces.

      a> If a VPLS has physical port as incoming iface, outgoing traffic spreads across LAG's links properly.

      b> If a VPLS has an IRB iface instead, outgoing traffic goes out to one LAG's iface only.

3. 

Case 2a. This LAG uses VPLS with physical ifaces only.

Spoiler
JunLagPol.JPG

Case 2b. There are some VPLS with IRB ifaces.

 

Spoiler
JunLagEkb.JPG

 In this case, we've two overutilized ifaces in LAG - xe-1/2/2 and xe-1/2/3 

 

Regards,
Denis Seven,
JNCIA-Junos, Cloud
Routing

Re: IRB Interfaces and LAG load-balancing.

‎09-16-2018 03:26 AM

Hello,

Thanks for sharing the information requested. A couple of follow-up questions:

1/ is the VPLS traffic PPPOE or IP/IPv6?

If IP/IPv6, then I would expect the LB to work by default based on IP header fields

2/ do You have this line in the config:

set forwarding-options enhanced-hash-key family multiservice no-payload

HTH

Thx

Alex

 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Routing

Re: IRB Interfaces and LAG load-balancing.

‎09-16-2018 06:57 AM

1. IPv4. It's  a traffic from Internet to a MX in another city. After that MX, traffic is going to customers.

Suddenly, in case without IRB, we have traffic whit PPPoE headers, and it's balancing well.  

2. No, we haven't.

We experimented with this options in the lab enviroment, but didn't reach our goals.

Regards,
Denis Seven,
JNCIA-Junos, Cloud