Routing
Highlighted
Routing

ISIS Attached Bit questions

‎02-26-2020 01:54 PM

ISIS-diag.JPG

I captured LSP packets on vMX1 interface ge-0/0/1 facing vMX3. I got the following two LSP packets. One has attached bit on, the other has attached bit off. They have differnet LSP_ID I highlighted.

Can someone explain to me the reasons ?

root@vMX1# run show interfaces ge-0/0/1 | match Curr
  Current address: 00:05:86:71:d8:01, Hardware address: 00:05:86:71:d8:01

ISIS-attachedBit-1.JPG

ISIS-attachedBit-2.JPG

thanks !!

8 REPLIES 8
Highlighted
Routing

Re: ISIS Attached Bit questions

‎02-26-2020 08:14 PM

Hello Gongyayu

 

On the vmx nodes are you running the isis inside a vrf or in the global routing instance ?

Also both the vmx1 and vmx3 are level 1 only and still you are seeing the attached bit right ?

It would be helpful if you can paste the isis configuration here.

Highlighted
Routing
Solution
Accepted by topic author gongyayu
‎02-27-2020 08:56 AM

Re: ISIS Attached Bit questions

‎02-27-2020 03:32 AM

Hello,

 


@gongyayu wrote:

 

I captured LSP packets on vMX1 interface ge-0/0/1 facing vMX3. I got the following two LSP packets. One has attached bit on, the other has attached bit off. They have differnet LSP_ID I highlighted.

 

 

The LSP with ATT==0 is from DIS/pseudonode.

And JUNOS does not run SPF on behalf of pseudonode, it only considers pseudonode as transit node for LAN. 

Since ISO 10589 standard says that in order to set ATT bit, the L2 IS must determine (i.e. run SPF) that it can reach other L2 IS, then DIS/pseudonode does not set ATT bit.

To avoid this "problem" by eliminating DIS election, use point-to-point ISIS link type on Ethernet

https://www.juniper.net/documentation/en_US/junos/topics/reference/configuration-statement/point-to-...

HTH

Thx

Alex

 

 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Highlighted
Routing

Re: ISIS Attached Bit questions

‎02-27-2020 08:54 AM
vMX1
root@vMX1# show | display set
set version 14.1R1.10
set system host-name vMX1
set interfaces ge-0/0/0 unit 0 family inet address 10.10.4.11/24
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family inet address 172.16.2.11/24
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/2 unit 0 family inet address 10.10.6.11/24
set interfaces ge-0/0/2 unit 0 family iso
set interfaces ge-0/0/3 unit 0 family inet address 10.10.1.11/24
set interfaces ge-0/0/3 unit 0 family iso
set interfaces lo0 unit 0 family iso address 49.0124.0000.0000.0011.00
set protocols isis export Exp2ISIS
set protocols isis interface ge-0/0/0.0 level 1 disable
set protocols isis interface ge-0/0/1.0 level 2 disable
set protocols isis interface ge-0/0/2.0 level 1 disable
set protocols isis interface ge-0/0/3.0 level 1 disable
set protocols isis interface lo0.0
set policy-options policy-statement Exp2ISIS term 1 from protocol isis
set policy-options policy-statement Exp2ISIS term 1 from route-filter 172.31.2.0/24 exact
set policy-options policy-statement Exp2ISIS term 1 then accept
set policy-options policy-statement Exp2ISIS term 2 then reject
set policy-options policy-statement isis-l2-into-l1 from protocol isis
set policy-options policy-statement isis-l2-into-l1 from level 2
set policy-options policy-statement isis-l2-into-l1 to level 1
set policy-options policy-statement isis-l2-into-l1 then accept

vMX3
root@vMX3# show | display set set version 14.1R1.10 set system host-name vMX3 set logical-systems vMX-LR3 interfaces lt-0/0/0 unit 1 encapsulation ethernet set logical-systems vMX-LR3 interfaces lt-0/0/0 unit 1 peer-unit 0 set logical-systems vMX-LR3 interfaces lt-0/0/0 unit 1 family inet address 172.31.2.12/24 set logical-systems vMX-LR3 interfaces lt-0/0/0 unit 1 family iso set logical-systems vMX-LR3 interfaces lo0 unit 1 family iso address 49.0124.0000.0000.0023.00 set logical-systems vMX-LR3 protocols isis interface lt-0/0/0.1 level 2 disable set logical-systems vMX-LR3 protocols isis interface lo0.1 set chassis fpc 0 pic 0 tunnel-services bandwidth 10g set interfaces lt-0/0/0 unit 0 encapsulation ethernet set interfaces lt-0/0/0 unit 0 peer-unit 1 set interfaces lt-0/0/0 unit 0 family inet address 172.31.2.11/24 set interfaces lt-0/0/0 unit 0 family iso set interfaces ge-0/0/1 unit 0 family inet address 172.16.2.13/24 set interfaces ge-0/0/1 unit 0 family iso set interfaces lo0 unit 0 family iso address 49.0124.0000.0000.0013.00 set protocols isis interface lt-0/0/0.0 set protocols isis interface ge-0/0/1.0 level 2 disable set protocols isis interface lo0.0

thanks for taking a look !!

Highlighted
Routing

Re: ISIS Attached Bit questions

‎02-27-2020 08:58 AM

thanks so much !!!

Highlighted
Routing

Re: ISIS Attached Bit questions

‎02-27-2020 10:21 PM

Hi Gongyayu

 

You will see the attached bit in the cases where either you are having ISIS connections inside of a routing-instance or a logical system. If you have isis L1 only adjacency between to different nodes (no under routing instance or logical system) then you will not see the attached bit in the LSP.

The explanation by aarseniev is the reason why this is behaving so.

Highlighted
Routing

Re: ISIS Attached Bit questions

[ Edited ]
‎02-28-2020 03:41 AM

Hello,

 


@raviky wrote:

Hi Gongyayu

 

You will see the attached bit in the cases where either you are having ISIS connections inside of a routing-instance or a logical system.

 

It does not matter, ISIS adjacency in GRT behaves the same way.

 


@raviky wrote:

If you have isis L1 only adjacency between to different nodes (no under routing instance or logical system) then you will not see the attached bit in the LSP.


Again, routing-instance/logical system or GRT does not matter. What matters is L2 IS (not L1!) being able to reach another L2 IS.

In plain English - ATT bit is seen in L1 LSP being sent by L1/L2 IS but it's L2 part of L1/L2 IS which needs to reach (i.e. calculate the SPF towards) another L2 IS.

ISO 10589 standard is quite authoritative in this regard, google for it.

HTH

Thx

Alex

 

 

 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Highlighted
Routing

Re: ISIS Attached Bit questions

a month ago

thanks so much !

Highlighted
Routing

Re: ISIS Attached Bit questions

a month ago

Awesome reply

 

I saw this once in the past with cisco, ended up reviewing the operation of ISIS for multi access circuits to find out that it was n

needed to just set the link for point-to-point.

 

Nice job! Kudos for you.

 

Smiley Happy