Routing
Highlighted
Routing

L2VC is not comming up b/w juniper and cisco

[ Edited ]
‎03-03-2020 01:45 PM

HI, 

 

i am trying setup  a l2VC (Layer 2 VPN) b/w cisco and juniper but it is not comming up. i have a operational T-LDP session b/w juniper-Cisco. i'm getting encapsulation mismatch error on the below circuit

 

   -------em3.0------Juniper(PE1  1.1.1.1)----------MPLS BACKBONE-----------------Cisco(PE2 4.4.4.4)----------------

 

 


root@R1> show configuration protocols l2circuit
traceoptions {
file l2circuit size 10k files 2;
flag all;
}
neighbor 4.4.4.4 {
interface em3.0 {
virtual-circuit-id 1234;
control-word;
encapsulation-type ethernet;
}
}

root@R1>

root@R1> show configuration interfaces em3
encapsulation ethernet;
unit 0 {
family mpls;
}

 

Address Interface Label space ID Hold time
4.4.4.4 lo0.0 4.4.4.4:0 20
Transport address: 4.4.4.4, Configuration sequence: 0
Up for 00:16:42
Reference count: 2
Hold time: 27, Proposed local/peer: 27/27
Hello interval: 9
Hello flags: targeted, request send targeted
Neighbor types: configured-layer2

root@R1>

 

 

 

root@R1> show l2circuit connections extensive
Layer-2 Circuit Connections:

Legend for connection status (St)
EI -- encapsulation invalid NP -- interface h/w not present
MM -- mtu mismatch Dn -- down
EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
CM -- control-word mismatch Up -- operational
VM -- vlan id mismatch CF -- Call admission control failure
OL -- no outgoing label IB -- TDM incompatible bitrate
NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
BK -- Backup Connection ST -- Standby Connection
CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
LD -- local site signaled down RS -- remote site standby
RD -- remote site signaled down XX -- unknown

Legend for interface status
Up -- operational
Dn -- down
Neighbor: 4.4.4.4
Interface Type St Time last up # Up trans
em3.0(vc 1234) rmt NC

root@R1>

 


Mar 4 02:52:02.384839 Flash processing complete for L2CKT from l2ckt.0
Mar 4 02:52:02.384853 rt_flash_update_callback: flash l2 circuit (l2circuit.0) done
Mar 4 02:52:03.767882 l2protec_ldp_session_notify: session: 2.2.2.2, state: Up, Upstream Label Assignment: No
Mar 4 02:52:07.251916 [l2ckt_intf_change_process] Change processing for intf em3.0: 0x4000410 0x82090c
Mar 4 02:52:07.252005 l2ckt_intf_create_mib2d_notify: Not a TDM/ATM VC
Mar 4 02:52:07.252047 Evaluated local PW status code 0x1 for intf em3.0 (nbr 4.4.4.4) belonging to instance L2circuit
Mar 4 02:52:07.252083 [l2ckt_intf_bkup_change_process] Change processing for backup PW of intf em3.0, belonging to instance L2circuit, flags:0x40
Mar 4 02:52:07.252116 Evaluated local PW status code 0x1 for intf em3.0 (nbr 4.4.4.4) belonging to instance L2circuit
Mar 4 02:52:07.252146 [l2ckt_vc_update] Failure to create/update vc 4.4.4.4:1234 --> interface encaps is not CCC/TCC
Mar 4 02:52:07.252174 [l2ckt_stby_pw_vc_update] VC connection not present for PW 4.4.4.4:1234
Mar 4 02:52:07.252200 em3.0 OP state transition to DOWN [Transport-LSP: 0,vpls_num_ifds: 0 is_pw_phy: 1, out_label 191]

Mar 4 02:52:16.938164 rt_flash_update_callback: flash l2 circuit (inet.0) start
Mar 4 02:52:16.938221 rt_flash_update_callback: flash l2 circuit (inet.0) done

 

 

 

Sunil Kumar

 

 

 

 

 

 

7 REPLIES 7
Highlighted
Routing

Re: L2VC is not comming up b/w juniper and cisco

‎03-03-2020 01:53 PM

Your CE facing interface needs to be CCC encapsulated

 

root@R1> show configuration interfaces em3
encapsulation ethernet;   <<<<<<<
unit 0 {
family mpls;  <<<<<<
}

 

Best

 

Mu

Highlighted
Routing

Re: L2VC is not comming up b/w juniper and cisco

‎03-03-2020 02:14 PM

Hi ,

Thanks for your responce.

i'm getting below error while setting the encapsulation to CCC.

 

root@R1# show interfaces em3
encapsulation ethernet-ccc;
unit 0;

[edit]
root@R1# set interfaces em3 unit 0 family ccc

[edit]
root@R1# commit
[edit interfaces em3 unit 0]
'family'
family ccc not valid on this interface.
error: configuration check-out failed

[edit]
root@R1#

 

Sunil Sandhu

Highlighted
Routing

Re: L2VC is not comming up b/w juniper and cisco

‎03-03-2020 07:01 PM

Try the following interface configuration on the CE facing interface

 

 

flexible-vlan-tagging;
encapsulation vlan-ccc;
unit 815 {
encapsulation vlan-ccc;
vlan-id 815;
family ccc;

 

Hope this helps
}

Highlighted
Routing

Re: L2VC is not comming up b/w juniper and cisco

‎03-03-2020 07:01 PM
Hi Sunil,

Please add "set interfaces em3.0 encapsulation vlan-ccc" along with "set interfaces em3.0 family ccc".

Hope this helps.

Regards,
-r.

--------------------------------------------------

If this solves your problem, please mark this post as "Accepted Solution."
Kudos are always appreciated :).
Highlighted
Routing

Re: L2VC is not comming up b/w juniper and cisco

‎03-03-2020 08:56 PM

Hey mate, from the below logs I can see that the "em" interface is chosen to configure  L2VPN on PE1.

Neighbor: 4.4.4.4
Interface Type St Time last up # Up trans
em3.0(vc 1234) rmt NC <- NC -- intf encaps not CCC/TCC 

root@R1>

This choice of interface is quite disturbing since Em interfaces are for Master and Back up routing engines to communicate with each other, no doubt why you were not able to make the "em3 unit 0" part of the CCC family. I advise you to choose another interface that supports all the std protocol family-like Inet CCC VPls etc. 

You can also refer https://kb.juniper.net/InfoCenter/index?page=content&id=KB33394&cat=MX480_1&actp=LIST&showDraft=fals...

 

hope this helps

Cheers 

 

Highlighted
Routing

Re: L2VC is not comming up b/w juniper and cisco

‎03-03-2020 09:06 PM

Hey mate, from the below logs I can see that the "em" interface is chosen to configure  L2VPN on PE1.

Neighbor: 4.4.4.4
Interface Type St Time last up # Up trans
em3.0(vc 1234) rmt NC <- NC -- intf encaps not CCC/TCC 

root@R1>

This choice of interface is quite disturbing since Em interfaces are for Master and Back up routing engines to communicate with each other, no doubt why you were not able to make the "em3 unit 0" part of the CCC family. I advise you to choose another interface that supports all the std protocol family-like Inet CCC VPls etc. 

You can also refer https://kb.juniper.net/InfoCenter/index?page=content&id=KB33394&cat=MX480_1&actp=LIST&showDraft=fals...

 

hope this helps

Cheer

Highlighted
Routing

Re: L2VC is not comming up b/w juniper and cisco

‎03-04-2020 07:07 AM

What platform are you using? And why you'd like to use em3 interface (which I think is mgmt interface)? Can you use normal data interface, like ge- xe- instead?


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Feedback