Routing
Highlighted
Routing

LACP Issue, one interface is not staying in collecting distributing

‎08-28-2019 06:57 AM

Hello,

There is a LACP configured between 2 routers.

nellie@SG1-CORE1-RE0> show lacp interfaces ae0
Aggregated interface: ae0
LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout Activity
ge-0/0/3       Actor    No    No    No   No  Yes   Yes     Slow Active
ge-0/0/3     Partner    No    No    No   No   No   Yes     Slow Passive
ge-1/0/3       Actor    No    No   Yes  Yes  Yes   Yes     Slow Active
ge-1/0/3     Partner    No    No   Yes  Yes  Yes   Yes     Slow Passive
LACP protocol:        Receive State  Transmit State          Mux State
ge-0/0/3                  Current   Slow periodic Attached
ge-1/0/3                  Current   Slow periodic Collecting distributing

 The problem is with interface ge-0/0/3, it is "flapping between states" going from collecting distributing to attached.

 

<-- starting with ge-0/0/3 in attached state
15:17:35.701903  In
Actor Information TLV (0x01), length 20
State Flags [Aggregation, Expired]
Partner Information TLV (0x02), length 20
State Flags [Activity, Timeout, Aggregation, Collecting, Distributing]

<-- ge-0/0/3 goes into distributing
15:17:39.479895  In
Actor Information TLV (0x01), length 20
State Flags [Aggregation, Synchronization]
Partner Information TLV (0x02), length 20
State Flags [Activity, Aggregation, Synchronization]
15:17:39.510643  In
Actor Information TLV (0x01), length 20
State Flags [Aggregation, Synchronization, Collecting, Distributing]
Partner Information TLV (0x02), length 20
State Flags [Activity, Aggregation, Synchronization]

<--But 15s later, port goes into attached
15:17:55.867696  In
Actor Information TLV (0x01), length 2
State Flags [Aggregation, Synchronization]
Partner Information TLV (0x02), length 20
State Flags [Activity, Aggregation, Synchronization, Collecting, Distributing]
15:17:55.868162  In
Actor Information TLV (0x01), length 20
State Flags [Aggregation]
Partner Information TLV (0x02), length 20
State Flags [Activity, Aggregation, Synchronization, Collecting, Distributing]

 Please help me understand what is happening.

5 REPLIES 5
Highlighted
Routing

Re: LACP Issue, one interface is not staying in collecting distributing

‎08-28-2019 07:09 AM

Hi! 

 

There are multiple reasons for LACP member link to bounce between distributing and attached. It could be on hardware as well. I would suggest you to open a JTAC ticket to check the issue thoroughly.

 

Best

 

Mu

Highlighted
Routing

Re: LACP Issue, one interface is not staying in collecting distributing

‎08-28-2019 10:46 AM

Hi rocketfkinscience,

 

Perhaps the PDUs are not being exchanged at the same rate on the two routers.

 

Can you try setting LACP to 'slow' if it's fast at the moment and see if that helps maintain a consistent state longer?

 

Cheers

Pooja

Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too!!!

Highlighted
Routing

Re: LACP Issue, one interface is not staying in collecting distributing

‎08-28-2019 11:52 AM

Can you please check LACP Rx and Tx stats

 

1) clear the LACP stats on both side of the LAG bundle


clear lacp statistics interfaces ge-0/0/3

 

clear lacp statistics interfaces ge-1/0/3

 

2) After the state flap check if there is a difference in LACP stats of ge-0/0/3 as against to ge-1/0/3

 

show lacp statistics interfaces ae0

If other side is not juniper then do it for juniper side only.

Thanks

Vishal

Highlighted
Routing

Re: LACP Issue, one interface is not staying in collecting distributing

‎09-02-2019 01:09 AM

Hello, this is also what i was thinking off.

i will reply with results.

Highlighted
Routing

Re: LACP Issue, one interface is not staying in collecting distributing

‎09-12-2019 09:16 AM

rocketfkinscience,

 

Just wondering if you had the chance to test this?

 

Cheers

Pooja