Routing
Routing

LACP not going up

‎05-27-2019 03:59 AM

Hello,

 

I have the following topology:

 

S1  (ge-0/0/2) ---- (ge-0/0/1) R3

S1 (ge-0/0/3) ---- (ge-0/0/1) R4

 

COnfiguration on S1 is:

interfaces {
ge-0/0/2 {
ether-options {
802.3ad ae0;
}
}
ge-0/0/3 {
ether-options {
802.3ad ae0;
}
}
ae0 {
flexible-vlan-tagging;
encapsulation extended-vlan-bridge;
aggregated-ether-options {
lacp {
active;
periodic fast;
}
}
unit 10 {
vlan-id 10;
}
unit 11 {
vlan-id 11;
}
}
irb {
unit 10 {
family inet {
address 17.8.10.10/24;
}
}
unit 11 {
family inet {
address 17.8.11.11/24;
}
}
}
}
protocols {
lldp {
interface all;
}
}
vlans {
MGM {
vlan-id 10;
interface ae0.10;
l3-interface irb.10;
}
MGM2 {
vlan-id 11;
interface ae0.11;
l3-interface irb.11;
}
}

 

 

On R3 is:

interfaces {
ge-0/0/1 {
gigether-options {
802.3ad {
lacp {
port-priority 100;
}
ae100;
}
}
}
ge-0/0/4 {
unit 0 {
family inet {
address 17.8.0.4/24;
}
}
}
ae100 {
flexible-vlan-tagging;
aggregated-ether-options {
lacp {
active;
system-id 00:00:00:00:00:01;
admin-key 100;
}
mc-ae {
mc-ae-id 100;
redundancy-group 100;
chassis-id 0;
mode active-standby;
status-control active;
}
}
}
}
protocols {
iccp {
local-ip-addr 17.8.0.4;
peer 17.8.0.3 {
redundancy-group-id-list [ 10 11 100 ];
liveness-detection {
minimum-interval 8000;
multiplier 3;
}
}
}
lldp {
interface all;
}
}
switch-options {
service-id 1;
}

 

On R4 is:

interfaces {
ge-0/0/1 {
gigether-options {
802.3ad {
lacp {
port-priority 200;
}
ae100;
}
}
}
ge-0/0/3 {
unit 0 {
family inet {
address 17.8.0.3/24;
}
}
}
ae100 {
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
aggregated-ether-options {
lacp {
active;
periodic fast;
system-id 00:00:00:00:00:01;
admin-key 100;
}
mc-ae {
mc-ae-id 100;
redundancy-group 100;
chassis-id 1;
mode active-standby;
status-control standby;
}
}
}
}
protocols {
iccp {
local-ip-addr 17.8.0.3;
peer 17.8.0.4 {
redundancy-group-id-list [ 10 11 100 ];
liveness-detection {
minimum-interval 8000;
multiplier 3;
}
}
}
lldp {
interface all;
}
}
switch-options {
service-id 1;
}

 

ICCP between R3 and R4 is UP:

root@R4# run show iccp

Redundancy Group Information for peer 17.8.0.4
TCP Connection : Established
Liveliness Detection : Up
Redundancy Group ID Status
10 Up
11 Up
100 Up

Client Application: l2ald_iccpd_client
Redundancy Group IDs Joined: None

Client Application: lacpd
Redundancy Group IDs Joined: None

 


[edit]
root@R3# run show iccp

Redundancy Group Information for peer 17.8.0.3
TCP Connection : Established
Liveliness Detection : Up
Redundancy Group ID Status
10 Up
11 Up
100 Up

Client Application: l2ald_iccpd_client
Redundancy Group IDs Joined: None

Client Application: lacpd
Redundancy Group IDs Joined: None

 

#show lacp interfaces and #show interfaces mc-ae are returning blank results on all devices, please help me understand what is wrong.

 

Regards,

Alexandru Minzat

3 REPLIES 3
Routing
Solution
Accepted by topic author rocketfkinscience
‎05-27-2019 05:08 AM

Re: LACP not going up

‎05-27-2019 04:07 AM

Hello Alexandru,

 

You need to create AE interfaces first:

set chassis aggregated-devices ethernet device-count <x>

If you use ae100, then you need to configure at least 101 ae interface on that node (obviously it's better to use lower numbers first - ae0, ae1, etc.):

set chassis aggregated-devices ethernet device-count 101

 

HTH


Best regards,
Sergii
-------------------------------------------------------------------
Please accept the solution if your problem is resolved Smiley Happy
-------------------------------------------------------------------

Routing

Re: LACP not going up

‎05-27-2019 05:10 AM

Thanks you, it worked!

Regards

Routing

Re: LACP not going up

‎08-12-2019 09:19 PM

The interface index 'x' is a value from ae0-ae4092.  It is not directly related to the device count.