Routing
Routing

LDP-VPLS stuck in OL state

[ Edited ]
‎05-22-2019 02:17 AM

Hello friends,

I am trying to test a custom scenario in VPLS, but my setup is being stuck in 'OL' state {no outgoing label}. Following is the topology and configs and related show outputs. Can someone point out where I am going wrong?

 

Topology (please refer attached file for topo diagram if below topo diagram is jumbled up):
---------
=> Please note: P3 is a logical router running on PE2.
=> Not posting configs of P1, P2 and P4 as they are simple generic core routers (verified IGP connectivity between all PEs and Ps)

CE1---PE1----P1---P2------P3--------PE2---CE2
| | | (LR on PE2)
| | |
------P4------
|
PE3---CE3

Configs:
-------
PE1:
set interfaces ge-0/0/0 unit 0 family inet address 10.30.0.1/24
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family inet6
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 unit 0 family inet address 10.20.0.1/24
set interfaces ge-0/0/1 unit 0 family iso
set interfaces ge-0/0/1 unit 0 family inet6
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces ge-0/0/2 encapsulation ethernet-vpls
set interfaces ge-0/0/2 unit 0
set routing-instances vpls-red instance-type vpls
set routing-instances vpls-red protocols vpls traceoptions file vplstraces_PE1.txt
set routing-instances vpls-red protocols vpls traceoptions file size 40m
set routing-instances vpls-red protocols vpls traceoptions file world-readable
set routing-instances vpls-red protocols vpls traceoptions flag all detail
set routing-instances vpls-red protocols vpls vpls-id 1
set routing-instances vpls-red protocols vpls neighbor 10.255.144.228
set routing-instances vpls-red protocols vpls neighbor 10.255.144.89
set routing-instances vpls-red interface ge-0/0/2.0
set routing-options route-distinguisher-id 10.255.144.93
set routing-options router-id 10.255.144.93
set routing-options autonomous-system 100
set protocols ospf traffic-engineering
set protocols ospf area 0.0.0.0 interface all
set protocols ospf area 0.0.0.0 interface fxp0.0 disable
set protocols ospf area 0.0.0.0 interface ge-0/0/6.0 metric 10000
set protocols rsvp interface all link-protection
set protocols rsvp interface fxp0.0 disable
set protocols mpls label-switched-path r0-r5 to 192.168.255.205
set protocols mpls label-switched-path r0-r5 ldp-tunneling
set protocols mpls label-switched-path r0-r5 link-protection
set protocols mpls label-switched-path r0-r5 primary use-IF1
set protocols mpls label-switched-path r0-r8 to 10.255.144.89
set protocols mpls label-switched-path r0-r8 ldp-tunneling
set protocols mpls path use-IF1 10.20.0.2 strict
set protocols mpls path use-IF3 10.30.0.2 strict
set protocols mpls interface all
set protocols mpls interface fxp0.0 disable

PE2:
set logical-systems R5 interfaces ge-0/0/0 unit 0 family inet address 10.14.0.1/24
set logical-systems R5 interfaces ge-0/0/0 unit 0 family iso
set logical-systems R5 interfaces ge-0/0/0 unit 0 family inet6
set logical-systems R5 interfaces ge-0/0/0 unit 0 family mpls
set logical-systems R5 interfaces lo0 unit 105 description "R5 LR Loopback"
set logical-systems R5 interfaces lo0 unit 105 family inet address 192.168.255.205/32
set logical-systems R5 protocols ospf traffic-engineering
set logical-systems R5 protocols ospf area 0.0.0.0 interface all
set logical-systems R5 protocols ospf area 0.0.0.0 interface fxp0.0 disable
set logical-systems R5 protocols rsvp interface all
set logical-systems R5 protocols ldp interface ge-0/0/0.0
set logical-systems R5 protocols ldp interface fxp0.0 disable
set logical-systems R5 protocols ldp interface lo0.105
set logical-systems R5 protocols mpls label-switched-path r5-r0 to 10.255.144.93
set logical-systems R5 protocols mpls label-switched-path r5-r0 ldp-tunneling
set logical-systems R5 protocols mpls label-switched-path r5-r8 to 10.255.144.89
set logical-systems R5 protocols mpls label-switched-path r5-r8 ldp-tunneling
set logical-systems R5 protocols mpls interface all
set logical-systems R5 protocols ospf3 area 0.0.0.0 interface all
set logical-systems R5 protocols ospf3 area 0.0.0.0 interface fxp0.0 disable
set chassis network-services enhanced-ip
set interfaces ge-0/0/1 description "Default LR R1 to R7 LR on unit 2"
set interfaces ge-0/0/1 encapsulation ethernet-vpls
set interfaces ge-0/0/1 unit 0
set routing-instances vpls-red instance-type vpls
set routing-instances vpls-red protocols vpls traceoptions file vplstraces_PE2.txt
set routing-instances vpls-red protocols vpls traceoptions file size 40m
set routing-instances vpls-red protocols vpls traceoptions file world-readable
set routing-instances vpls-red protocols vpls traceoptions flag all detail
set routing-instances vpls-red protocols vpls vpls-id 1
set routing-instances vpls-red protocols vpls neighbor 10.255.144.93
set routing-instances vpls-red protocols vpls neighbor 10.255.144.89
set routing-instances vpls-red interface ge-0/0/1.0
set routing-options route-distinguisher-id 10.255.144.228
set routing-options router-id 10.255.144.228
set routing-options autonomous-system 100
set protocols ospf traffic-engineering
set protocols ospf area 0.0.0.0 interface all
set protocols ospf area 0.0.0.0 interface fxp0.0 disable
set protocols mpls interface all
set protocols mpls interface fxp0.0 disable

PE3:
set chassis network-services enhanced-ip
set interfaces ge-0/0/0 unit 0 family inet address 10.38.0.8/24
set interfaces ge-0/0/0 unit 0 family iso
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 description "Default LR R8 to R9 LR on unit 2"
set interfaces ge-0/0/1 encapsulation ethernet-vpls
set interfaces ge-0/0/1 unit 0
set routing-instances vpls-red instance-type vpls
set routing-instances vpls-red protocols vpls traceoptions file vplstraces_PE3.txt
set routing-instances vpls-red protocols vpls traceoptions file size 40m
set routing-instances vpls-red protocols vpls traceoptions file world-readable
set routing-instances vpls-red protocols vpls traceoptions flag all detail
set routing-instances vpls-red protocols vpls vpls-id 1
set routing-instances vpls-red protocols vpls neighbor 10.255.144.93
set routing-instances vpls-red protocols vpls neighbor 10.255.144.228
set routing-instances vpls-red interface ge-0/0/1.0
set routing-options route-distinguisher-id 10.255.144.89
set routing-options router-id 10.255.144.89
set routing-options autonomous-system 100
set protocols ospf traffic-engineering
set protocols ospf area 0.0.0.0 interface all
set protocols ospf area 0.0.0.0 interface fxp0.0 disable
set protocols rsvp interface all
set protocols rsvp interface fxp0.0 disable
set protocols mpls label-switched-path r8-r0 to 10.255.144.93
set protocols mpls label-switched-path r8-r0 ldp-tunneling
set protocols mpls label-switched-path r8-r5 to 192.168.255.205
set protocols mpls label-switched-path r8-r5 ldp-tunneling
set protocols mpls interface all
set protocols mpls interface fxp0.0 disable


Outputs:
---------
PE1:
regress@PE1_re> show vpls connections
<...truncated...>
Instance: vpls-red
VPLS-id: 1
Neighbor Type St Time last up # Up trans
10.255.144.228(vpls-id 1) rmt OL
10.255.144.89(vpls-id 1) rmt OL

regress@PE1_re> show rsvp session
Ingress RSVP: 3 sessions
To From State Rt Style Labelin Labelout LSPname
10.255.144.89 10.255.144.93 Dn 0 0 - - - r0-r8
128.220.12.37 10.255.144.93 Up 0 1 SE - 299792 Bypass->10.20.0.2
192.168.255.205 10.255.144.93 Up 0 1 SE - 299776 r0-r5
Total 3 displayed, Up 2, Down 1

Egress RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0

Transit RSVP: 2 sessions
To From State Rt Style Labelin Labelout LSPname
10.255.144.93 192.168.255.205 Dn 0 0 - - - r5-r0
10.255.144.93 10.255.144.89 Dn 0 0 - - - r8-r0
Total 2 displayed, Up 0, Down 2

regress@PE1_re> show route protocol ospf

inet.0: 51 destinations, 51 routes (50 active, 0 holddown, 1 hidden)
+ = Active Route, - = Last Active, * = Both

10.14.0.0/24 *[OSPF/10] 03:12:18, metric 3
> to 10.30.0.2 via ge-0/0/0.0
to 10.20.0.2 via ge-0/0/1.0
10.23.0.0/24 *[OSPF/10] 03:12:18, metric 2
to 10.30.0.2 via ge-0/0/0.0
> to 10.20.0.2 via ge-0/0/1.0
10.24.0.0/24 *[OSPF/10] 03:12:18, metric 2
> to 10.20.0.2 via ge-0/0/1.0
10.34.0.0/24 *[OSPF/10] 03:13:02, metric 2
> to 10.30.0.2 via ge-0/0/0.0
10.38.0.0/24 *[OSPF/10] 03:13:02, metric 2
> to 10.30.0.2 via ge-0/0/0.0
128.220.12.23/32 *[OSPF/10] 03:12:18, metric 2
> to 10.30.0.2 via ge-0/0/0.0
to 10.20.0.2 via ge-0/0/1.0
128.220.12.37/32 *[OSPF/10] 03:12:18, metric 1
> to 10.20.0.2 via ge-0/0/1.0
128.220.12.77/32 *[OSPF/10] 03:13:02, metric 2
> to 10.30.0.2 via ge-0/0/0.0
128.220.12.195/32 *[OSPF/10] 03:13:02, metric 1
> to 10.30.0.2 via ge-0/0/0.0
192.168.255.205/32 *[OSPF/10] 03:12:18, metric 3
to 10.30.0.2 via ge-0/0/0.0
> to 10.20.0.2 via ge-0/0/1.0
224.0.0.5/32 *[OSPF/10] 03:15:29, metric 1
MultiRecv

inet.3: 1 destinations, 2 routes (1 active, 0 holddown, 1 hidden)

iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

mpls.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)

PE2:
regress@PE2_re> show vpls connections
<...truncated...>
Instance: vpls-red
VPLS-id: 1
Neighbor Type St Time last up # Up trans
10.255.144.89(vpls-id 1) rmt OL
10.255.144.93(vpls-id 1) rmt OL

regress@PE2_re> show rsvp session logical-system R5
Ingress RSVP: 2 sessions
To From State Rt Style Labelin Labelout LSPname
10.255.144.89 192.168.255.205 Dn 0 0 - - - r5-r8
10.255.144.93 192.168.255.205 Dn 0 0 - - - r5-r0
Total 2 displayed, Up 0, Down 2

Egress RSVP: 2 sessions
To From State Rt Style Labelin Labelout LSPname
192.168.255.205 10.255.144.89 Up 0 1 FF 3 - r8-r5
192.168.255.205 10.255.144.93 Up 0 1 SE 3 - r0-r5
Total 2 displayed, Up 2, Down 0

Transit RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0

regress@PE2_re> show route protocol ospf

inet.0: 36 destinations, 36 routes (36 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

224.0.0.5/32 *[OSPF/10] 03:24:43, metric 1
MultiRecv

iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

mpls.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)

l2circuit.0: 2 destinations, 2 routes (0 active, 0 holddown, 2 hidden)


PE3:
regress@PE3_re> show vpls connections
<...truncated...>
Instance: vpls-red
VPLS-id: 1
Neighbor Type St Time last up # Up trans
10.255.144.228(vpls-id 1) rmt OL
10.255.144.93(vpls-id 1) rmt OL

regress@PE3_re> show rsvp session
Ingress RSVP: 2 sessions
To From State Rt Style Labelin Labelout LSPname
10.255.144.93 10.255.144.89 Dn 0 0 - - - r8-r0
192.168.255.205 10.255.144.89 Up 0 1 FF - 299776 r8-r5
Total 2 displayed, Up 1, Down 1

Egress RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0

Transit RSVP: 2 sessions
To From State Rt Style Labelin Labelout LSPname
10.255.144.89 10.255.144.93 Dn 0 0 - - - r0-r8
10.255.144.89 192.168.255.205 Dn 0 0 - - - r5-r8
Total 2 displayed, Up 0, Down 2

regress@PE3_re> show route protocol ospf

inet.0: 49 destinations, 49 routes (49 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.14.0.0/24 *[OSPF/10] 03:16:01, metric 3
> to 10.38.0.3 via ge-0/0/0.0
10.20.0.0/24 *[OSPF/10] 03:14:10, metric 3
> to 10.38.0.3 via ge-0/0/0.0
10.23.0.0/24 *[OSPF/10] 03:16:01, metric 2
> to 10.38.0.3 via ge-0/0/0.0
10.24.0.0/24 *[OSPF/10] 03:16:01, metric 3
> to 10.38.0.3 via ge-0/0/0.0
10.30.0.0/24 *[OSPF/10] 03:13:06, metric 4
> to 10.38.0.3 via ge-0/0/0.0
10.34.0.0/24 *[OSPF/10] 03:16:01, metric 2
> to 10.38.0.3 via ge-0/0/0.0
128.220.12.23/32 *[OSPF/10] 03:16:01, metric 2
> to 10.38.0.3 via ge-0/0/0.0
128.220.12.37/32 *[OSPF/10] 03:14:10, metric 2
> to 10.38.0.3 via ge-0/0/0.0
128.220.12.195/32 *[OSPF/10] 03:16:01, metric 1
> to 10.38.0.3 via ge-0/0/0.0
128.220.14.157/32 *[OSPF/10] 03:13:06, metric 3
> to 10.38.0.3 via ge-0/0/0.0
192.168.255.205/32 *[OSPF/10] 03:16:01, metric 3
> to 10.38.0.3 via ge-0/0/0.0
224.0.0.5/32 *[OSPF/10] 03:18:01, metric 1
MultiRecv

inet.3: 1 destinations, 2 routes (1 active, 0 holddown, 1 hidden)

iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

mpls.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)

 

Attachments

3 REPLIES 3
Highlighted
Routing

Re: LDP-VPLS stuck in OL state

‎05-22-2019 06:15 AM

Hello,

Obvious errors (taking PE1 as an example):

1/ "family vpls" is not enabled on ge-0/0/2.0

2/ interface lo0.0 is not present

3/ router-id 10.255.144.93 is not assigned to lo0.0

4/ "protocols ldp" stanza missing in the config - must have LDP enabled on lo0.0 for LDP VPLS

5/ "protocols ldp" stanza missing and RSVP LSP towards LDP neighbors 10.255.144.228 + 10.255.144.89 missing in the config  - hence, likely no routes in inet.3 and no outgoing transport label.

Please add, re-test and report back. If still not working re-post complete actual configs to analyze.

HTH

Thx

Alex

 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Highlighted
Routing

Re: LDP-VPLS stuck in OL state

‎05-22-2019 01:28 PM

no-tunnel-services is also needed in your case

https://www.juniper.net/documentation/en_US/junos/topics/reference/configuration-statement/no-tunnel...

 


Mengzhe Hu
JNCIE x 3 (SP DC ENT)
Highlighted
Routing

Re: LDP-VPLS stuck in OL state

‎05-25-2019 12:07 PM

Hi,

 

Please refer the videos tutorial for LDP based VPLS config:

 

Basic VPLS LDP Configuration

 

 

//Regards

AD

 

[KUDOS PLEASE! If you think I earned it!

If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]

 

Feedback