Routing
Highlighted
Routing

LDP based L2 Circuit -- Issue

‎11-26-2013 10:55 PM

Hi guys!

 

I'm trying to establish LDP based L2 circuit in a topology over GNS3. But the circuit won't work. Diagram & conf details are here:

L2-Junos.jpg

Configuration on CORE_J:

interfaces {
em0 {
unit 0 {
family inet {
address 10.10.10.1/30;
}
family iso;
family mpls;
}
}
em1 {
unit 0 {
family inet {
address 10.10.10.5/30;
}
family iso;
family mpls;
}
}
lo0 {
unit 0 {
family inet {
address 10.10.10.12/32;
}
family iso {
address 49.0001.1010.1212.1212.00;
}
family mpls;
}
}
}
protocols {
mpls {
interface em0.0;
interface em1.0;
interface lo0.0;
}
isis {
interface em0.0 {
level 1 disable;
}
interface em1.0 {
level 1 disable;
}
interface lo0.0 {
level 1 disable;
}
}
ldp {
interface em0.0;
interface em1.0;
interface lo0.0;
}
}

 

Configuration on PE_J1:

interfaces {
em1 {
unit 0 {
family inet {
address 10.10.10.6/30;
}
family iso;
family mpls;
}
}
em3 {
vlan-tagging;
encapsulation vlan-ccc;
unit 520 {
encapsulation vlan-ccc;
vlan-id 520;
}
}
lo0 {
unit 0 {
family inet {
address 10.10.10.13/32;
}
family iso {
address 49.0001.1010.1313.1313.00;
}
family mpls;
}
}
}
protocols {
mpls {
interface em1.0;
interface lo0.0;
}
isis {
interface em1.0 {
level 1 disable;
}
interface lo0.0 {
level 1 disable;
}
}
ldp {
interface em1.0;
interface lo0.0;
}
l2circuit {
neighbor 10.10.10.14 {
interface em3.520 {
virtual-circuit-id 520;
}
}
}
}

 

Configuration on PE_J2:

 

 

interfaces {
em0 {
unit 0 {
family inet {
address 10.10.10.2/30;
}
family iso;
family mpls;
}
}
em3 {
vlan-tagging;
encapsulation vlan-ccc;
unit 520 {
encapsulation vlan-ccc;
vlan-id 520;
}
}
lo0 {
unit 0 {
family inet {
address 10.10.10.14/32;
}
family iso {
address 49.0001.1010.1414.1414.00;
}
family mpls;
}
}
}
protocols {
mpls {
interface em0.0;
interface lo0.0;
}
isis {
interface em0.0 {
level 1 disable;
}
interface lo0.0 {
level 1 disable;
}
}
ldp {
interface em0.0;
interface lo0.0;
}
l2circuit {
neighbor 10.10.10.13 {
interface em3.520 {
virtual-circuit-id 520;
}
}
}
}

 

Troubleshooting Outputs (CORE_J):

root> show ldp session detail
Address: 10.10.10.13, State: Operational, Connection: Open, Hold time: 26
Session ID: 10.10.10.12:0--10.10.10.13:0
Next keepalive in 6 seconds
Passive, Maximum PDU: 4096, Hold time: 30, Neighbor count: 1
Neighbor types: discovered
Keepalive interval: 10, Connect retry interval: 1
Local address: 10.10.10.12, Remote address: 10.10.10.13
Up for 00:45:23
Last down 00:45:27 ago; Reason: received notification from peer
Number of session flaps: 1
Capabilities advertised: none
Capabilities received: none
Protection: disabled
Local - Restart: disabled, Helper mode: enabled
Remote - Restart: disabled, Helper mode: enabled
Local maximum neighbor reconnect time: 120000 msec
Local maximum neighbor recovery time: 240000 msec
Nonstop routing state: Not in sync
Next-hop addresses received:
10.10.10.6
10.10.10.13

Address: 10.10.10.14, State: Operational, Connection: Open, Hold time: 28
Session ID: 10.10.10.12:0--10.10.10.14:0
Next keepalive in 8 seconds
Passive, Maximum PDU: 4096, Hold time: 30, Neighbor count: 1
Neighbor types: discovered
Keepalive interval: 10, Connect retry interval: 1
Local address: 10.10.10.12, Remote address: 10.10.10.14
Up for 00:45:00
Last down 00:45:03 ago; Reason: received notification from peer
Number of session flaps: 1
Capabilities advertised: none
Capabilities received: none
Protection: disabled
Local - Restart: disabled, Helper mode: enabled
Remote - Restart: disabled, Helper mode: enabled
Local maximum neighbor reconnect time: 120000 msec
Local maximum neighbor recovery time: 240000 msec
Nonstop routing state: Not in sync
Next-hop addresses received:
10.10.10.2
10.10.10.14

 

Troubleshooting Outputs (PE_J1):

 

PE_J1.jpg

 

Troubleshooting Outputs (PE_J2):

PE_J2.jpg

 

And the C_A1 & C_A2 routers are not pinging each other. Please can anyone help?

Khurram Aziz
CCIE R&S 58415, JNCIA-Cloud, COA, CCDP, JNCIP-SP, JNCIS-SEC, CCNP, CCIP
6 REPLIES 6
Highlighted
Routing

Re: LDP based L2 Circuit -- Issue

‎11-27-2013 10:38 PM

No one to help me? Man Sad

Khurram Aziz
CCIE R&S 58415, JNCIA-Cloud, COA, CCDP, JNCIP-SP, JNCIS-SEC, CCNP, CCIP
Highlighted
Routing

Re: LDP based L2 Circuit -- Issue

‎11-28-2013 04:55 AM

Hi there,

AFAIK, any L2 VPN dataplane (Martini or Kompella or CCC) does not work in Olive/GNS3 and never worked.

Only control plane works in Olive/GNS3.

HTH

Thanks
Alex

 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Highlighted
Routing

Re: LDP based L2 Circuit -- Issue

‎12-01-2013 09:16 AM

I established an L2 between JUNOS & IOS. I wasn't able to carry traffic from CE to CE coz Junos gives some "overrun array" error etc. However, the mpls ping has been successful unlike Junos to Junos as I pasted above.

 

IOS Outcome:

 

L2-IOS.jpg

 

Junos Outcome:

L2-Junos.jpg

Khurram Aziz
CCIE R&S 58415, JNCIA-Cloud, COA, CCDP, JNCIP-SP, JNCIS-SEC, CCNP, CCIP
Highlighted
Routing

Re: LDP based L2 Circuit -- Issue

‎12-01-2013 01:15 PM

Hi there,

MPLS ping is a control plane feature

http://tools.ietf.org/html/rfc4379 

 

In "ping" mode (basic connectivity check), the packet should reach the end of the path, at which point it is sent to the control plane of the egress LSR

 And guess what? MPLS ping request is generated by ingress' LSR/headend' control plane.

As I mentioned in my earlier post, I'd be mightily surprised if anyone makes data plane for any kind of L2VPN to work in GNS3/Olive (including physical Olive).

HTH

Thanks
Alex 

_____________________________________________________________________

Please ask Your Juniper account team about Juniper Professional Services offerings.
Juniper PS can design, test & build the network/part of the network as per Your requirements

+++++++++++++++++++++++++++++++++++++++++++++

Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Highlighted
Routing

Re: LDP based L2 Circuit -- Issue

[ Edited ]
‎12-01-2013 03:11 PM

Hi,

 

Your configuration looks perfect, I tried the draft martini in past and it worked without any issue with olive.

 

I advice you to restart the device and try it on the plain Ethernet interface as well (don't remember now but I think I tried draft martini on plain Ethernet interface instead of dot1q interface in Olive, don't believe on olive 100% as many stuff does not work on it).

 

If possible send the output of following CLI as well.

 

run show ldp neighbor
run show route table inet.3

 

Here is link about the working stuff on olive (not sure about the authenticity os the link).

 

http://juniper.cluepon.net/index.php/Olive

 

Regards

Satinder Singh

JNCIE# 2151 SP, JNCIP ENT, CCIE# 26831 SP
www.linkedin.com/in/satinder7singh

If this post solves your problem, please mark this post as "Accepted Solution".
Kudos are appreciated.
Routing

Re: LDP based L2 Circuit -- Issue

‎12-07-2013 06:07 AM

error: VLAN CCC Encapsulation: Not allowed on untagged interfaces

Khurram Aziz
CCIE R&S 58415, JNCIA-Cloud, COA, CCDP, JNCIP-SP, JNCIS-SEC, CCNP, CCIP
Feedback