Routing

last person joined: 5 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  M5 SNMP missing IP-MIB on some logical-systems

    Posted 03-01-2012 08:05

     

    I have an M5 configured with 14 logical-systems on a single port. This is in a test lab, not production.

    Each logical system is configured relatively identically.

     

    Most logical systems respond to IP-MIB queries, e.g.

     

    $ snmpwalk 10.171.30.12 -v2c -cM5VdcTest8/default@devsnmp ipAdEntAddr
    $ IP-MIB::ipAdEntAddr.10.171.81.10 = IpAddress: 10.171.81.10

     

     

    However, some logical-systems (a random subset per re-boot), report that they do not have OIDs in the MIB... e.g.

     

    $ snmpwalk 10.171.30.12 -v2c -cM5VdcTest10/default@devsnmp ipAdEntAddr
    $ IP-MIB::ipAdEntAddr = No Such Object available on this agent at this OID

     

     

    Typically 2-3 logical routers will be missing the IP-MIB.  After a reboot, the actual logical-systems that are affected will change (seemingly randomly).  The affected systems do respond to other OIDs, for example, OIDs in the IP-FORWARD-MIB.  All logical systems are reachable on their assigned IPs.

     

    I am trying to use IP-MIB::ipAdEntAddr to determine which IP addresses belong to logical-systems vs the host system via SNMP.  Is this a bug?  Or is this a result of bad configuration?

     

    Configuration...

     

    version 10.4R9.2;
    system {
        host-name devm5;
        location floor 3;
        root-authentication {
            encrypted-password "x"; ## SECRET-DATA
        }
        login {
              user devgroup {
                uid 2001;
                class super-user;
                authentication {
                    encrypted-password "x"; ## SECRET-DATA
                }
            }
        }
        services {
            ssh {
                root-login deny;
            }
            telnet;
        }
        syslog {
            user * {
                any emergency;
            }
            file messages {
                any notice;
                authorization info;
            }
        }
    }
    logical-systems {
        DMZ-router {
            interfaces {
                fe-0/0/2 {
                    unit 0 {
                        family inet {
                            address 10.171.52.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.52.1;
                }
            }
        }
        M5VdcTest1 {
            interfaces {
                fe-0/0/3 {
                    unit 53 {
                        vlan-id 53;
                        family inet {
                            address 10.171.53.10/24;
                        }
                    }
                }
            }
            routing-instances {
                test {
                    instance-type no-forwarding;
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.53.1;
                }
            }
        }
        M5VdcTest10 {
            interfaces {
                fe-0/0/3 {
                    unit 83 {
                        vlan-id 83;
                        family inet {
                            address 10.171.83.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.83.1;
                }
            }
        }
        M5VdcTest11 {
            interfaces {
                fe-0/0/3 {
                    unit 84 {
                        vlan-id 84;
                        family inet {
                            address 10.171.84.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.84.1;
                }
            }
        }
        M5VdcTest12 {
            interfaces {
                fe-0/0/3 {
                    unit 85 {
                        vlan-id 85;
                        family inet {
                            address 10.171.85.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.85.1;
                }
            }
        }
        M5VdcTest13 {
            interfaces {
                fe-0/0/3 {
                    unit 86 {
                        vlan-id 86;
                        family inet {
                            address 10.171.86.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.86.1;
                }
            }
        }
        M5VdcTest14 {
            interfaces {
                fe-0/0/3 {
                    unit 87 {
                        vlan-id 87;
                        family inet {
                            address 10.171.87.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.87.1;
                }
            }
        }
        M5VdcTest2 {
            interfaces {
                fe-0/0/3 {
                    unit 54 {
                        vlan-id 54;
                        family inet {
                            address 10.171.54.10/24;
                        }
                    }
                }
            }
            routing-instances {
                test {
                    instance-type no-forwarding;
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.54.1;
                }
            }
        }
        M5VdcTest3 {
            interfaces {
                fe-0/0/3 {
                    unit 55 {
                        vlan-id 55;
                        family inet {
                            address 10.171.55.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.55.1;
                }
            }
        }
        M5VdcTest4 {
            interfaces {
                fe-0/0/3 {
                    unit 56 {
                        vlan-id 56;
                        family inet {
                            address 10.171.56.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.56.1;
                }
            }
        }
        M5VdcTest5 {
            interfaces {
                fe-0/0/3 {
                    unit 57 {
                        vlan-id 57;
                        family inet {
                            address 10.171.57.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.57.1;
                }
            }
        }
        M5VdcTest6 {
            interfaces {
                fe-0/0/3 {
                    unit 58 {
                        vlan-id 58;
                        family inet {
                            address 10.171.58.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.58.1;
                }
            }
        }
        M5VdcTest7 {
            interfaces {
                fe-0/0/3 {
                    unit 80 {
                        vlan-id 80;
                        family inet {
                            address 10.171.80.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.80.1;
                }
            }
        }
        M5VdcTest8 {
            interfaces {
                fe-0/0/3 {
                    unit 81 {
                        vlan-id 81;
                        family inet {
                            address 10.171.81.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.81.1;
                }
            }
        }
        M5VdcTest9 {
            interfaces {
                fe-0/0/3 {
                    unit 82 {
                        vlan-id 82;
                        family inet {
                            address 10.171.82.10/24;
                        }
                    }
                }
            }
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 10.171.82.1;
                }
            }
        }
    }
    interfaces {
        fe-0/0/0 {
            description fe-0/0/0;
            unit 0 {
                family inet {
                    address 197.87.10.2/24;
                }
                family inet6 {
                    mtu 1500;
                    address 2001:db8:a2:B21::/64 {
                        eui-64;
                        primary;
                        preferred;
                    }
                }
            }
        }
        fe-0/0/1 {
            unit 0 {
                family inet {
                    address 197.87.20.2/24;
                }
                family inet6 {
                    address 2001:db8:a2:B20::/64 {
                        eui-64;
                        primary;
                        preferred;
                    }
                }
            }
        }
        fe-0/0/3 {
            vlan-tagging;
        }
        fxp0 {
            unit 0 {
                family inet {
                    address 10.171.30.12/24;
                }
                family inet6;
            }
        }
        lo0 {
            unit 0 {
                family inet {
                    address 127.0.0.1/32;
                }
            }
        }
    }
    snmp {
        v3 {
            vacm {
                security-to-group {
                    security-model v1 {
                        security-name security_name {
                            group group1;
                        }
                        security-name billbob {
                            group group1;
                        }
                    }
                }
            }
            snmp-community 1 {
                community-name "$9$dnws4HkPz39UjBESyW8oJGji."; ## SECRET-DATA
                security-name billbob;
                context billybob;
            }
        }
        community devsnmp {
            authorization read-only;
            routing-instances DMZ-router/default { ## Warning: 'routing-instances' is deprecated
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest1/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest2/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest3/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest4/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest5/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest6/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest7/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest8/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest9/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest10/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest11/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest12/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest13/default {
                clients {
                    0.0.0.0/0;
                }
            }
            routing-instance M5VdcTest14/default {
                clients {
                    0.0.0.0/0;
                }
            }
        }
        community christest;
        community qasnmp {
            authorization read-only;
        }
        routing-instance-access {
            access-list {
                *;
            }
        }
    }
    routing-options {
        rib inet6.0 {
            static {
                route ::/0 {
                    qualified-next-hop 3000:1:2:2::2;
                    qualified-next-hop 3000:1:2:2::AB2;
                }
                route 4001:1:c:d::/64 {
                    qualified-next-hop 3000:1:2:2::ab4;
                }
            }
        }
        static {
            route 0.0.0.0/0 next-hop 10.171.30.1;
        }
    }
    protocols {
        router-advertisement {
            interface fe-0/0/0.0 {
                prefix 2001:db8:a2:b21::/64 {
                    on-link;
                }
            }
        }
        ospf {
            area 3.0.0.0 {
                interface fe-0/0/0.0;
                interface fe-0/0/1.0;
            }
        }
        ospf3 {
            area 0.0.0.0 {
                interface fe-0/0/0.0;
                interface fe-0/0/1.0;
            }
        }
    }
    routing-instances {
        another-vrf {
            description "A virtual router instance";
            instance-type virtual-router;
        }
        still-another {
            description "no forwarding instance";
            instance-type no-forwarding;
        }
    }

     



  • 2.  RE: M5 SNMP missing IP-MIB on some logical-systems
    Best Answer

    Posted 03-12-2012 12:00

    FWIW...

     

    I pared down the configuration to 10 virtual systems, and things appear to be working conststently now.  I am now running on the assumption that this was a system resource issue - with a buggy mode of failure.

     

    I can't find any tech pubs that state memory requirements/recommendations when running various numbers of logical systems.